Exchange Server 2000 Backup Failure

It appears I have a problem with my Exchange Server backing up the Information Store and the SRS with Windows Backup.

The error message on the report is as follows:

----------------------

Backup Status
Operation: Backup
Active backup destination: File
Media name: "Media created 03/05/2006 at 08:00"

Backup of "SERVER\Microsoft Information Store\First Storage Group"
Backup set #1 on media #1
Backup description: "Set created 03/05/2006 at 08:00"
Backup Type: Normal

Backup started on 03/05/2006 at 08:00.
Backup completed on 03/05/2006 at 08:03.
Directories: 4
Files: 5
Bytes: 1,066,509,102
Time:  3 minutes and  45 seconds
Media name: "Media created 03/05/2006 at 08:00"

Backup of "SERVER\Microsoft Site Replication Service\SRS Storage"
Backup set #2 on media #1
Backup description: "Set created 03/05/2006 at 08:00"
Backup Type: Normal

Backup started on 03/05/2006 at 08:03.
WARNING: Portions of "\SRS MDB" cannot be read.  The backed up data is corrupt or incomplete.
This file will not restore correctly.
WARNING: Portions of "\Log Files" cannot be read.  The backed up data is corrupt or incomplete.
This file will not restore correctly.
Backup completed on 03/05/2006 at 08:04.
Directories: 3
Files: 0
Bytes: 0
Time:  1 second

----------------------

The O/S details are Windows 2000 Server SP4, Exchange Server 2000 SP3 (Build 6249.4).

I have tried the following tasks to fix this problem:

Shutdown and disabled all anti-virus software
Used the console logon instead of a remote connection to the server
Used the eseutil to repair and defrag and re-mounted the store resulting in no failures
Added Backup Operators and Administrator to the 'Create Global Objects' policy in the Domain Controller Security Policy

I'm now out of ideas on how to fix this problem and any other suggestions will be appreciated!

Lee.
LVL 1
fishcake999Asked:
Who is Participating?
 
vasanthgnbConnect With a Mentor Commented:
Ohhhhh... You have lost SRS database. Do you still have a 5.5 server running????

Follow the steps to recreate it. You need another server to do this.

To re-create an SRS, follow these steps:
1. Install a second Exchange Server 2003 or Exchange 2000 server in the site, if it is required.  
2. Start Exchange System Manager from the first Exchange Server 2003 computer.
3. Double-click Tools to view the Site Replication Services container.
Note : Each SRS in your organization appears as Microsoft Exchange Site Replication Service Server_name . If Directory Replication Service Administrative_group_name appears, click Site Replication Service View on the View menu.  
4. Click Site Replication Services, click Action, click New, and then click Site Replication Service.
Note : When you create a new SRS, Exchange Server 2003 performs directory updates similar to the updates that are performed when you join a new server to a site. It may take several minutes for the process to complete.  
5. Follow the instructions that appear to create the new SRS.  
6. You are prompted to enter a password that will be used to run the SRS.
These credentials are loaded from the msexchlegacydomain and msexchlegacyaccount attributes of the Exchange Server administrative group that contains the SRS.  
7. If there are multiple Exchange Server 5.5 computers in the site, click the Exchange Server 5.5 server that will be synchronized with the new SRS.
By default, Exchange System Manager auto-selects the second directory service if there is only one other directory service in the administrative group.  
8. After the new SRS has been created, delete the original SRS on the first server.  

Regards,
Vasanth.
0
 
amaheshwariCommented:

You have to fix the database issue:

In Exchange system manager, dismount databases stores that you want to
repair.
1 In command prompt to the C:\...\Exchsrvr\Bin> directory and run the
following commands IN SEQUENCE on the corrupted databases.

a. eseutil /p "path to .edb file in quotes" TO REPAIR

b. eseutil /d "path to .edb file in quotes" TO DEFRAG

c. isinteg -s <your server name> -fix -test alltests FOR INTEGRITY

i. In the report you should get 0 errors, 0 warning, 0 fixes

ii. If you have any one of these non zero, the same command need to
be run again, until you get 0,0,0 or the error/warning/fix count reappears
without changing.

2 In Exchange system manager, mount both store.


after it you will not found any issue in backup.
0
 
ksharma4Commented:
I will suggest you to try backing up using ntbackup to make sure it is exchange or the backup software.

Thanks
Kunal
0
Easily manage email signatures in Office 365

Managing email signatures in Office 365 can be a challenging task if you don't have the right tool. CodeTwo Email Signatures for Office 365 will help you implement a unified email signature look, no matter what email client is used by users. Test it for free!

 
fishcake999Author Commented:
I have tried the eseutil before and I have just tried it again.

Everything runs fine with 0,0,0 errors, but the same problem in the report is still occuring.

Lee.
0
 
fishcake999Author Commented:
ksharma4 -

I am using NT Backup at the moment, backing up to file rather than tape, although backup up to tape was causing the same problem too.
0
 
vasanthgnbCommented:
Check whether you see the SRS database and log files in Exchsrvr\srsdata folder. If not that is your problem. Try to restart the Microsoft Exchange Site Replication service and see if you get any errors in the app log.

Thanks,
Vasanth.
0
 
fishcake999Author Commented:
I have the following three files in the \srsdata folder:

lconfig.map
rconfig.map
srstempl.edb

These files have the original creation dates and have never been modified though. I restarted the Site Replication service, and the application log generated this error:

"  The Microsoft Exchange Site Replication Service could not initialize its Exchange database (EDB) and returned error 1.  The Site Replication Service will wait in a semi-running state so the database can be restored from backup and the SRS can mount it. "

...and gave me a link here:

http://www.microsoft.com/products/ee/transform.aspx?EvtSrc=MSExchangeSRS&EvtCat=Internal%20Processing%20&EvtID=1400&CoName=Microsoft%20Corporation&ProdName=Microsoft%20Exchange&ProdVer=6.0.6603.0&FileVer=6.0.6603.0

I can't restore it from a backup because I have not yet achieved a successful backup of the Exchange.
0
 
fishcake999Author Commented:
Ok, after looking at  your comments for the SRS, I may have found an alternative way around this.

I don't really have any need for another Exchange server on site, I don't feel there is enough users to warrant a secondary server.

I have disabled the Microsoft Site Replication Service on the server as I don't need any replication, because I don't have a second server to replicate to!

I've done another backup after disabling the server and no errors occured, so i'm guessing it was trying to back something up that didn't exist, i.e. the SRS?

One thing I may have a problem with, is when I browse to the file in NT Backup Restore mode, under the tree of "SERVER\Microsoft Information Store\Mailbox Store (SERVER)" and catalog the file, it reports as 0 bytes and there are 'No Entries Found' . This is the report for this supposedly 0 byte backup file:

Backup started on 03/05/2006 at 14:44.
Backup completed on 03/05/2006 at 14:47.
Directories: 4
Files: 6
Bytes: 1,061,266,320
Time:  3 minutes and  5 seconds

Do you have any further ideas why this may be?!
0
 
vasanthgnbCommented:
That is fine. That is how NTBackup displays. But still, I would recomment you to restore it in a test machine for testing if you are so doubtful.

Regards,
Vasanth.
0
All Courses

From novice to tech pro — start learning today.