[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1260
  • Last Modified:

Terminal server: Printing to LPT1 as LPT1, not TSXXX

I have a workstation with a local label printer attached to LPT1. When I log this station into the terminal server (as a remote desktop client), it creates a print session for the client in the form TSXXXX COMPUTER NAME PRNXX -- well and good, that's what it's evidently supposed to do. I can print fine to the label printer from the client station when I'm logged into the terminal server, as well as when I'm not logged in.

So here's the problem: We have a  program that basically runs the DOS copy command-- Copy Label.txt LPT1:, and that prints our labels. For this program to work, the port MUST be called "LPT1:". TSXXX is the port the program finds, and although that's redirected from the terminal server To LPT1 on the client station, it's not recognized as LPT1 by the program.

So I either need a program that can translate "TSXXX" to "LPT1", or I need a way to tell the terminal server to call the port "LPT1:". Is the latter solution possible?
0
vbinpa
Asked:
vbinpa
  • 4
  • 3
1 Solution
 
ZadkinCommented:
For a shared printer something like:
net use lpt1 \\printserver\sharename /persistent:yes
0
 
vbinpaAuthor Commented:
Thanks, I'll give it a shot.
0
 
vbinpaAuthor Commented:
consider this  250 points of 500....
Well, I got it to work, as a test, from my machine, logged into the terminal server. My machine  is part of a domain. My computer is called UNITxx. The printer is simply connected to my workstation, to lpt1, as a local printer, shared as "zdesigner". So I was able to say 'net use LPT1: \\Unitxx\zdesigner' while logged into the terminal server.

In addition to this, I had to set up a local port on the terminal server called
\\unitxx\zdesigner, and designate that as the port for the printer.

However, our remote client is not part of the domain, and I kept getting an error message saying 'network path not found' when attempting to set up a local port on the terminal server for him. Can I do this without making him a member of the domain?

Oh, keep in mind that the only way our program works is to basically run the DOS command, 'COPY XXX.txt LPT1:' I can print from the remote client using notepad, but not our program. The printer has to be known as LPT1.

Jim
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
ZadkinCommented:
I used it  to solve a local  USB printer problem to an old dos application.

>> Can I do this without making him a member of the domain?
Yes,  but:
-  he needs to resolve the server name (verify with ping servername),  so the Wins server setting must be correct ( verify with ipconfig /all) or through the lmhosts file .  Otherwise I expect that you can replace the server name with the server IP adress.

- he needs access rights on the printer,  must be everyone and not just authenticated users.
0
 
vbinpaAuthor Commented:
Thanks for the extra info...I'm off the job for a week or two but will certainly get back to you with the results.
0
 
vbinpaAuthor Commented:
Thanks Zadkin-- What you said will probably work. I just haven't had time to deal with this particular issue. As far as I'm concerned, you get another 250 points.
0
 
ZadkinCommented:
Knock on wood,  thanks for the points
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now