Lost disk signature

Posted on 2006-05-03
Last Modified: 2008-01-09

Dell PE2450
Dell PERC 3/Si controller
Seagate Cheetah ST336607LC SCSI U320 HDD (hotswap job)

We have (had?) the above server in a branch office, and it has just died.  Further inspection reveals the boot drive has failed, and the system will no longer boot.  All data (files/exchange .edbs) are stored on a separate disk that had no problems.

No problem with that, not bothered about the system as i can reinstall it, but the data is obviously vitally important.  Booted into KNOPPIX linux from CD, it mounted up the remaining scsi drive (data disk) and allowed me to view the files no problem.

For vairous reasons (lack of knowledge of linux, and my inability to mount a 250GB USB HDD in knoppix), I took the disk out and put it into another server with the same drive caddys, running windows 2000 svr.  Disk was detected fine by scsi/raid card, and windows 2000 svr recognised the disk fine.

Problem is, like an idiot, I hit the dreaded 'Yes' button on the 'Write Signature to new disk?" popup.  I now have a disk with 35GB of data on it (i hope!), but it shows up as 'unallocated' in windows 2000, and now the PERC controller in the original server doesn't recognise the volume on the disk (presumably as the config has been overwritten by the win2k disk signature).

Short of sending the disk off and paying for professional DR, is there any way I can get the disk working again (in any operating system!) so i can copy the data off?  When I plug it into the PERC card on original server, the PERC card boots and says 'no volumes detected'.  PERC utilities recognise the disk, and gives me the options of formatting or initialising.

Any ideas?


Question by:straynor
    LVL 2

    Accepted Solution

    You can use a program called get data back for NTFS.
    It will scan the drive and dump the data, often it also finds deleted files :)

    LVL 47

    Expert Comment

    Amplifying on cvsadmin's post


    The demo version is free and will tell you what files it can recover.  You pay for full functionality.  Highly recommended.
    LVL 30

    Expert Comment

    Seen this one and got bit by it.
    Here is your problem:
    NT4 is running NTFS 4 and when you attached it to a W2K box it wrote the NTFS 5 signature to it.(and converted it to dynamic)
    This is a bad thing .

    You could try this:

    But is does seem strange that the W2K box doesn't see it any more(after all it did do the conversion).
    I did this at one point and the W2K still saw it ,but when I booted it up it would cause data corruption that wouldn't get fixed because it complained the the version of chkdsk was incompatible.

    You could also try Captian Nemo and see it that works.
    LVL 1

    Author Comment

    Thanks for the replies, i tried getdataback and it has worked a treat!  My bacon is saved!

    All the best!


    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    How to run any project with ease

    Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
    - Combine task lists, docs, spreadsheets, and chat in one
    - View and edit from mobile/offline
    - Cut down on emails

    Hi, I've made you some graphics for a better understanding how RAID works. First of all, there are two ways a raid can be generated: - By hardware - By software What does that mean? This means: If you have a hardware RAID controller, there…
    I previously wrote an article addressing the use of UBCD4WIN and SARDU. All are great, but I have always been an advocate of SARDU. Recently it was suggested that I go back and take a look at Easy2Boot in comparison.
    This video teaches viewers how to encrypt an external drive that requires a password to read and edit the drive. All tasks are done in Disk Utility. Plug in the external drive you wish to encrypt: Make sure all previous data on the drive has been …
    This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…

    779 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    13 Experts available now in Live!

    Get 1:1 Help Now