• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 349
  • Last Modified:

BorderManager and ASP

Hi Gang,

Quick question that's probably pretty easy. Here's the story.

We're running BorderManager 3.8 SP3 for our proxy server and I like it just fine. A while back I found that some websites would time out or would just come up "File Not Found" while using them. The odd part was that this would only happen in IE. I've since noticed a pattern that these pages are all some variation of ASP.

After going to Novell I've found that indeed BorderManager and ASP do not like each other.

Here's where I'd like a little extra help.

Thus far I've gone into HTTP Proxy settings and de-selected "Enable Persistent Connections to Browsers" and "Enable Persistent Connection to Origin Servers".

I'd like to setup something in the "Caching" area to ensure that the problem is taken care of and here is my question. What's the best way to setup a rule to cover all ASP pages? I've not had a lot of luck or experience with toying with the caching settings. (The first time I did I managed to abend the server...go me! Perhaps I should unload the proxy first?)

Please give as much detail as possible since I honestly don't know exactly what I'm doing in here...I just know enough to be dangerous. :-) Any other things that I need to adjust to allow for ASP?

Many thanks in advance.
0
Sebastien47136
Asked:
Sebastien47136
  • 9
  • 8
1 Solution
 
ShineOnCommented:
A rule... Hmmm.  Dunno. :\

I haven't worked with BorderManager for a couple of years, now, but I remember having this issue with certain sites that wrote their web pages to IE-only browsers, and I remember having to put an exception in for each site, to bypass the cache.  Darned if I remember how. Age is a bitch.

I don't know how you'd do a rule.  Have you checked the Novell knowledgebase to see if anything is there on how to work around the ASP/IE/persistent connection thing?  Or maybe coolsolutions?
0
 
Sebastien47136Author Commented:
I've tried the creating a rule for certain websites....I guess the correct terminology is "Cachable Object Control". That didn't seem to resolve the problem, though I never specified anything to do with ASP I just referenced the domain.

I just followed the followed the TID below.

http://www.novell.com/support/search.do?cmd=displayKC&docType=kc&externalId=10050773&sliceId=&dialogID=2781603&stateId=0%200%202785888

Seems to be the closest thing that I could find, but I wonder if it covers aspx pages, or https for asp pages. Ugh. So many variables...damn you Al Gore!
0
 
ShineOnCommented:
It might, but you may need to have another one for aspx perhaps?  Of course, if you're not caching https pages, the secure ASP should already be bypassing cache, no?
0
Upgrade your Question Security!

Add Premium security features to your question to ensure its privacy or anonymity. Learn more about your ability to control Question Security today.

 
Sebastien47136Author Commented:
Well I've done all the configuring to caching and BorderManager and I still haven't found a way to make it work.

I've found myself more and more walking around the school yelling "I just LOVE Microsoft Products." *blick*

Thus far I've gotten a couple of the staff to use FireFox. I'm seriously considering making the big push this summer and getting it rolled out on everyone's machine so when they run up against this I can just ask them to try it in FireFox.

At any rate all I know is:

IE 6, ASP pages, and BorderManager do not get along very well. Any other ideas? Anybody? *lipwobble* Please?
0
 
ShineOnCommented:
Have you tried setting IE6 to use HTTP/1.1 over proxy connections?  I know IE6 defaults to not use HTTP/1.1 over proxy...

How 'bout read-ahead?  Did you try turning that off?  

After you made your changes, did you clear cache, to make sure there weren't leftover ASP pages in cache?
0
 
Sebastien47136Author Commented:
Oops. Sorry for the delay, I'd forgotten I had this question still open.

Our IE6 settings already have the HTTP/1.1 over proxy connections setting enabled. Should I disable it and see what happens?

The read-ahead thing confuses me. As best I can tell read-ahead is part of the ASP page? Unfortunately these aren't ASP pages that we house they are hosted elsewhere on the internet and I've just now noticed that the pages that we have problems with are all ASP pages.

Yep, cleared my cache on the server and my machine and the problem still happens.
0
 
ShineOnCommented:
Read-ahead is a feature of the BorderManager FastCache, that you should turn off for ASP pages.  It pre-loads images and forms from pages you're already viewing, to speed up access, and with ASP code that can hose things up, so you don't want the read-ahead to happen.  

I would check into that first, before changing the HTTP/1.1 proxy setting.
0
 
Sebastien47136Author Commented:
Ah. Thanks for that tid-bit. Read-ahead is already disabled. (Glad the person who set this up knew what they were doing.)
0
 
ShineOnCommented:
aargh.

I suppose it's out of the question to enable dynamic NAT and bypass proxy altogether for these problem sites, by adding them to the "don't use the proxy" list in IE?
0
 
Sebastien47136Author Commented:
ROFL. Well it's an idea. :-)

But seeing how I never know when one of these sites is going to come up I figure I should try to get it fixed instead of reconfiguring for each site.
0
 
ShineOnCommented:
Does it work if you access these sites using Firefox 1.5x?  Maybe enforce use of Firefox... ;)
0
 
Sebastien47136Author Commented:
Yep, works on FireFox just fine from 1.0.6 on up to current pages.

I'm seriously considering it, but considering that the state still doesn't support FireFox for it's applications I'm kind of stuck if FireFox doesn't work. Right now it's our back-up browser. Getting ready to do some school-wide testing tomorrow using FireFox because IE just won't work and I'm not gonna be in the building if IE is actually required to work. Should be interesting to say the least.
0
 
ShineOnCommented:
Hmm... ASP on IE doesn't work, ASP on Firefox does...

On IE6, what's the version/revision level, what hotfixes are applied (it shows in the help, about screen...) - like on mine, it shows:
6.0.2900.2180.xpsp_sp2_gdr.050301-1519
Cipher strength: 128-bit
Product ID: <blah>
Update versions:; SP2;

What do you have?  I wonder if you need to maybe uninstall a hotfix, or install a new cumulative update, or some such...
0
 
Sebastien47136Author Commented:
Yep. That pretty much restates the problem and why I'm so confused by it. FireFox loads the page just fine...IE Error 400

I'll do some further investigating to see what our labs have. Office machines like mine get Winders updates automatically, at this point in the year the images in the lab are getting to be about a year old.

The odd part is that both machines do it.

Something as simple as going to hotmail....IE you won't make it to a login page....FireFox...no problem. Hotmail wasn't really a problem site since we block it from students, but it is a site that consistantly does it. (Hmm, now that I look at the main hotmail page it not longer goes to a login.aspx. What's a SRF extension?) Any one appreciate the irony of not being able to access a MSN product with a Microsoft browser? *snicker*

0
 
ShineOnCommented:
It's probably a Microsoft marketing ploy - "Your web proxy is faulty, you need to buy ISA server.  See, yours makes it so IE can't get to Hotmail - there's your proof!"  

Never mind that it works with a non-Microsoft browser...  hehe...

Too bad too many folx will see it Microsoft's way rather than saying, "Well, it works with Firefox, so it's IE that's faulty.  Go pound sand."
0
 
Sebastien47136Author Commented:
In the labs we have:

6.0.2900.2180.xp.sp_sp2_gdr.050301-1519
Cipher Strenth: 128-bit
Update Versions:; SP2;

I'm kind of giving up on getting IE to work....any quick tips on locking down FireFox? There aren't any useful Group Policy things that I've found, and pushing the app out via ZEN doesn't really lock it down as so much set it up correctly the first go round. I'd prefer to prevent users from making any changes period....
0
 
ShineOnCommented:
Check out the addons and stuff.  Here's one I found with a quick search: https://addons.mozilla.org/firefox/2553/
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 9
  • 8
Tackle projects and never again get stuck behind a technical roadblock.
Join Now