Remote Desktop from XP pc to Server 2003 Will not Connect

Posted on 2006-05-03
Last Modified: 2013-11-21
I have a client with a new pc running server 2003. There is a client that needs remote access to this pc. The server is not in a domain, only a workgroup. The sole purpose of this server install is to have 2 concurrent remote desktop users. The client is not at the location or in the workgroup. There is a Linksys Router acting as a DHCP server and firewall.
  I would like someone to tell me the steps to installing and enabling remote desktop on the server 2003. We have already
setup the router for port forwarding according to the remote clients protocol. I am pretty sure that remote desktop is not setup properly on the server 2003. Ther error message is "The client could not connect to the remote computer"
The client is their tech support. They feel that the problem is on our end. These guys need this store up and running asap!
Therefore, 500 points for the info that gets us honkin. Thank you to all in advance.

Question by:gpfrank
    LVL 10

    Assisted Solution

    You can enable remote desktop on the Server by:

    Start, click Control Panel, and then click System.

    Click the Remote tab, click to select the Allow users to connect remotely to your computer check box, and then click OK.

    This will allow users who have Administrative rights on the server to connect to it.

    Users who are not administrators will not be able to connect unless you install Terminal Service License, which needs to be purchased seperately from Microsoft.

    If the server is behind firewall, port 3389 needs to be opened and mapped on the firewall/router and also opened on the windows firewall if it is running.

    LVL 77

    Accepted Solution

    A check list:
    On the server:
    1) Right click on My Computer and choose properties and then the remote tab. Check the box with "allow users to connect remotely to this computer"
    2) You have to add an existing user or create a new and add it to the Remote Users group. Administrators are members by default.
    3) If using server 2003 with SP1 there is a software firewall installed on your computer. You either need to disable it, or enable the exception for Remote Desktop. You can disable it by going to Control Panel and then Windows Firewall and check "off". Or, choose the Exception tab and then check the box for Remote Desktop to maintain the firewall but allow Remote Desktop connections.
    4) If there are any other software firewalls enabled they need to be disabled or configured for remote desktop connections
    3) On the firewall/router you need to enable port forwarding on TCP port 3389 to the IP address of the computer. You should assign the computer a static (fixed) IP address rather than getting one automatically from the router or a server using DHCP, as it may change from time to time and you will not be able to connect. Specific instructions for enabling port forwarding for most routers can be found at:
    4) Verify the port is open by logging on to from the server and testing for port 3389

    If you are still having problems, try the following :
    1-try connecting using the IP of the remote computer not the computer name
    2-Depending on the version, on the "Terminal Services Profile" of the users profile. Make sure it is checked appropriately. "Deny the user permission to log on to any terminal server", or "Allow Logon to Terminal Server"
    3-Verify the Remote Desktop User group has the rights to log on using Terminal Services. Go to Control Panel | Administrative tools | Local Security Policy | Local Policies | User Rights Assignments ...make sure Remote Desktop Users is included in "allow logon through Terminal Services"
    4-The terminal Services service must be running
    If you have access to the remote machine make sure it is "listening" for your connection. To do so at a command line enter (substitute port # if not using default 3389):
       netstat -an |find "3389"
    You should get the following result:
       TCP listening
    If not go to Start | Run | services.msc and see if Terminal Services is started and set to automatic

    LVL 77

    Expert Comment

    by:Rob Williams
    gpfrank, was the information provided enough to get you "honkin" ? If not let us know what we can do to assist further.
    LVL 77

    Expert Comment

    by:Rob Williams
    Thanks Glenn,

    Featured Post

    How your wiki can always stay up-to-date

    Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
    - Increase transparency
    - Onboard new hires faster
    - Access from mobile/offline

    Join & Write a Comment

    This is an article about my experiences with remote access to my clients (so that I may serve them) and eventually to my home office system via Radmin Remote Control. I have been using remote access for over 10 years and have been improving my metho…
    If you're not part of the solution, you're part of the problem.   Tips on how to secure IoT devices, even the dumbest ones, so they can't be used as part of a DDoS botnet.  Use PRTG Network Monitor as one of the building blocks, to detect unusual…
    Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
    Here's a very brief overview of the methods PRTG Network Monitor ( offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

    728 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    18 Experts available now in Live!

    Get 1:1 Help Now