Pop-up is blocked!

Dear Experts,
I've been driven nuts by this Pop-up blocker.
I am using Internet Explorer and under Pop-up blocker setting, i didn't check the box.
So in theory, i should be able to see all pop-ups right?

But no, all the pop-ups are blocked.
Please advise how do i get rid of this problem once and for all as it's affecting my online applications.

Thanks very much in advance.

Andrea
andreatAsked:
Who is Participating?
 
rvthostConnect With a Mentor Commented:
Also, do you have Google Toolbar, Yahoo Toolbar, things like that installed?  Many of those have pop-up blockers.
0
 
Nick DennyCommented:
You may have some further software blocking pop-ups - firewall for example.

Also, in IE, go to tools>pop-up blocker>turn-off pop-up blocker.
0
 
andreatAuthor Commented:

I have already turned off pop-up blocker but it still doesn't work.
Pls advise how can i check if i have any software blocking pop-ups.
Thanks
0
Improved Protection from Phishing Attacks

WatchGuard DNSWatch reduces malware infections by detecting and blocking malicious DNS requests, improving your ability to protect employees from phishing attacks. Learn more about our newest service included in Total Security Suite today!

 
Nick DennyCommented:
Do you have a firewall running?

e.g. Zone Alarm

Most have a pop up blocker which you can turn off.

Try downloading Firefox and using that instead on IE to isolate the problem area.
http://www.mozilla.com/firefox/
0
 
CyberGhostCommented:
It might not be a problem of MSIE.
Did you have po pup blocker active before? Or did you just updated your MSIE?
In Firefox, do your online applications work? Or in Opera?
If you did an update to MSIE, it might not be a pop up blocker problem. Maybe they just don't work as desired under this MSIE version.

note: MSIE = Microsoft Internet Explorer

regards
CyberGhost
0
 
andreatAuthor Commented:
hi rvthost,
you are correct, i have yahoo toolbar installed and i didn't know there's pop-up blocker.
i've changed the settings and it's working fine now.

for your info, i've gone to Microsoft website to search and it seems like a work-around solution to my problem is
to press Ctrl or Alt key whenever i am clicking on the link to a pop-up window.

Thanks for the advice.

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.