https://external_ip points towards our firewall web page rather than exchange OWA

Hi,

We have had OWA set up and working for a while now, with our firewall mapping the external ip across to the exchange server.

I had to add an SSL cert as a few of our staff members are going to be using mobile devices.

The cert set up went fine, but now when I type https://our_external_ip_or_domain_name it points us to the Firewall config page.

I tried setting up a rule to pass all SSL traffic to the exchange server but this didn't seem to help.

Our Firewall is a Fortigae 60.

many thanks.
LVL 1
LetterpartAsked:
Who is Participating?
 
jabiiiCommented:
have you changed the configuration port for the firewall AND setup forwarding for your 443? you will need to do both
0
 
Keith AlabasterEnterprise ArchitectCommented:
How have you forwarded the tcp port 443 traffic? Are you tunnelling the traffic?
0
 
LetterpartAuthor Commented:
doh

I had forgotten to disable the https access on the firewall!

But now, when I try https://mail.domain.com/ it checks the cert, asks if I want to accept which I do and say yes, then it redirects to http://xxx.xxx.xxx.xxx/exchange/

and errors with:

The page must be viewed over a secure channel
The page you are trying to view requires the use of "https" in the address.

Please try the following:

    * Try again by typing https:// at the beginning of the address you are attempting to reach.

Is this a setting in Exchange IIS?


thanks
0
The Firewall Audit Checklist

Preparing for a firewall audit today is almost impossible.
AlgoSec, together with some of the largest global organizations and auditors, has created a checklist to follow when preparing for your firewall audit. Simplify risk mitigation while staying compliant all of the time!

 
LetterpartAuthor Commented:
Ok,

me stoopid.

Ages ago I changed the default.htm in C:\Inetpub\wwwroot to show a customised page and then redirect to the owa. The link in this pointed to http.

thank you for all your help.
0
 
jabiiiCommented:
is the fw redirecting to port 80 ?
is the IIS listening on the 443? hmmm
0
 
LetterpartAuthor Commented:
jabiii,

the redirect points to http://ip_address. I just changed that to https and it worked fine.

Have split points between the two of you.

regards,

0
 
jabiiiCommented:
Ya I posted that before your email came in, hence didn't see your reply until after i posted hehe, glad you got it working!
0
 
Keith AlabasterEnterprise ArchitectCommented:
Thanks :)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.