[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 757
  • Last Modified:

Networked laser printer

Hi,
I have a Xerox Phaser 6100.
It works great over parallel or usb connection, but I can't get it to work
over ethernet.
When I plug it into my router, lights flash slowly on the printer but
nothing on the router, as it would for every other device.

I've followed all the instructions and settings but nothing seems to even be aware of it existing when
using the ethernet port.

The printer can be set to use DHCP or manual IP.  I have tried both.
There is a software utility which is supposed to set it all up if you type in the MAC address, but that can't find it either.

The connection page printout settings seem fine.

It's as though the network card in the printer is not doing anything. Or should I be trying something else?


I guess it probably means the ethernet port/card in the printer is broken, but how can I tell, is there a way to test its ethernet connection?

I bought it second hand but its only 18 months old and been well looked after.


Thanks for your help
0
steve0743
Asked:
steve0743
  • 3
  • 2
  • 2
  • +1
1 Solution
 
hdhondtCommented:
Can you ping the printer? If you print a configuration page, does it list the network i/f and IP address? Is the IP address on the same subnet as the PC?
0
 
hdhondtCommented:
You can try resetting the network i/f to factory defaults.

1. Press the Menu button until Network Setup is displayed.
2. Press the OK button.
3. Press the arrow button until Reset Network is displayed.
4. Press the OK button. After OK is pressed the front panel will briefly display RESET NOW then go to READY.
5. Wait at least one minute after the printer returns to Ready.       
6. Turn the printer off for 15 seconds, then turn it back on.

After that it will pick up a dhcp address again. Change it to a suitable manual address.
0
 
steve0743Author Commented:
Hi

The green led by the ethernet port on the printer blinks at a steady rate of twice per second.
No lights flashing on the router for the port.

My router gives the following details about my network:

Router
---------
LAN IP Address:       192.168.1.1  
Default Gateway:      195.166.128.53  
Primary DNS Server:   212.159.6.10  
Secondary DNS Server: 212.159.6.9

Network
----------
Subnet Mask:      255.255.255.0
Default Gateway:  192.168.1.1
DHCP Server:      192.168.1.2 - 192.168.1.254


I have just reset the network settings on the printer to factory default.
Then selected DHCP and printed a connection page, it reads:

IP Stack
--------
Status: On
Source: DHCP
IP: 169.254.45.202   (I can't ping this)
Mask: 255.255.0.0
Gateway: 169.254.1.1
DNS: 0.0.0.0
URL: http://169.254.45.202:631
MAC: 00:00:f0:ae:57:e0
WINS Name: XRX0000f0ae57e0
WINS Server: 0.0.0.0

UPNP
----
Auto IP: On
Multicast DNS: On
SSDP: On
SSDL TTL: 1

Port 9100: On
LPR: On
EtherTalk Stack Details: Off
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
FriarTukCommented:
FriarTuk wrote in http:Q_21837879.html#16612772 "Networked laser printer":
> If this printer has a built in ethernet port & corresponding menu system
> that allows configuring network settings, but sure to give it a static
> ip addr like 192.168.1.50 with gateway 192.168.1.1 with subnet
> 255.255.255.0 - you may also need to configure the workgroup name.  
> Then on your router enter in the mac addr of the prtr & tell is to
> provide a static ip addr instead of dhcp using same ip addr 192.168.1.50.
0
 
hdhondtCommented:
Port 169.254.45.202 is the port the printer assumes if it cannot get a dhcp address, and it can never be pinged. It looks as if you do not have a dhcp server. The fact that the config page shows all this implies (but does not guarantee) that the printer's network i/f is working fine.

Check the IP settings of your PC. Go to Start > Run, type CMD and press Enter. In the DOS window that comes up, type IPCONFIG /ALL and press Enter. The list of things that show up includes  the IP address of your PC, and whether it uses dhcp or not. Note this does not work under Win98/Me

Assuming your PC has an IP address of 192.168.1.a, give the printer an address 192.168.1.b where b is different from a. Then try to ping that address. If you can, create a Standard TCP/IP port for it and you should be able to print.
0
 
jonoakleyCommented:
Is the network connection known to be good?
A bad connection will produce your stated results.
Test the connection that the printer is using. This could be simply hooking up a laptop. If the connection is valid then a the printer network connection is suspect. This is reinforced by the "slow blinking" indicator light at the printer but not at the router or switch, assuming of course that what you are describing is actually the network link indcator.
If the network connection is broken, no DHCP will be available nor any other network traffic for that matter.
0
 
steve0743Author Commented:
Thanks for all your tips.
They are all good and valid answers.
I have tried everything and have concluded that it is probably the printer's network card that is at fault.

I have just noticed that the ethernet cable I got with my ADSL router is a cross over and the one I got with the printer is a straight cable.
I have tried both cables with no success.
Could it be that using the cross over cable has damaged the printer?
0
 
jonoakleyCommented:
Not likely a crossover would cause damage to a port. Sometimes the port simply goes bad. Also a crossover would not give a link indication.
Sadly there is no cheap way to test for a bad port other than to replace the equipment in the circuit. Unless of course you are a certified Xerox repairman,in which case i suspect you would just replace the network interface to test.  
You don't mention the load on the printserver but several external units are available for varying budgets and workloads.
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

  • 3
  • 2
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now