Switching Off Anti-Aliasing In KDE


    I am a systems administrator and run about twenty SlackWare 9 machines that are accessed remotely over the network via full desktop HummingBird Exceed sessions running on MS Windows desktops (not our choice and we are stuck with it:-( ).

    I am considering upgrading to RedHat AS4 PL 2 as this supports the full POSIX inter-process pthread library (as against intra-process) and we have a site licence for the OS anyway.

    The trouble is, unlike SlackWare which delivers all packages unmolested from their original source, RedHat have tweaked the KDE desktop to fit in with their Blue Curve theme. Also when switching off font anti-aliasing I can't get any decent fonts to display (either under Exceed or on a local X server).

    We want to be able to turn off anti-aliasing because 1) it looks dreadful on all but the smaller monitors (despite trying all the adjustment settings it looks blotchy and blurred) 2) the performance over the network is very slow.

    So to sum up, under RHAS4PL2's KDE setup:

1) Can one turn off anti-aliasing and still get a decent selection of useable fonts. If so how?

2) Whilst one can select one of the standard KDE themes and this works, the kicker bar at the bottom stubbornly retains the old theme. Is there a way to reset kicker to its original default theme style as from KDE?


Who is Participating?
This is the day to call RedHat support under your site-broad licensing.

1) Open Control Panel/Look&Feel/Fonts tickmark does that. You should append RedHat's fontserver to Exceed's FontPath or equivalent.
2) by moving away ~/.kderc and ~/.kde
aecooperAuthor Commented:
> This is the day to call RedHat support under your site-broad licensing.
Internal political thing: but the people that hold the licensing details submit the calls and they say that KDE is an unsupported desktop. I know nonsense, this is something for me to pursue and try and sort out - I won't bore you with the gory details! But in the mean time:-)

> 1) Open Control Panel/Look&Feel/Fonts tickmark does that. You
> should append RedHat's fontserver to Exceed's FontPath or equivalent.

You talking MS-Windows? The anti-aliasing is done by KDE at the Linux end and not by Windows or Exceed (if Windows did it then there wouldn't be the network performance issues). Font path stuff is already done.

>2) by moving away ~/.kderc and ~/.kde

The account was empty before logging into KDE. I know some systems set up KDE when creating  the account, but this is not the case here. However perhaps RH intercept KDE's standard `copy across default config files'. Anyway I will have another play with this.

Anyone else know for definite please comment...



>Font path stuff is already done.
Does not look like.
Cloud Class® Course: Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

.. different rendering engines take care of font display depending on antialiasing setting
With third one being ghostscript and all the stuff around it.
No comment has been added to this question in more than 21 days, so it is now classified as abandoned.
I will leave the following recommendation for this question in the Cleanup topic area:

accept gheist http:#16621217

Any objections should be posted here in the next 4 days. After that time, the question will be closed.

EE Cleanup Volunteer
aecooperAuthor Commented:
Yup sorry by all means clean up the question as it hasn't been answered WRT the problem I am seeing. I am aware of how font servers work, their configuration etc. I can query the system and see helvetica fonts and apps can use them , however KDE does not list them. I am stumped. However I have fiddled around with Mandrake and KDE on there does work as expected, i.e. you turn off anti-aliasing and then you can select helvetica. So I shall have a look into what is different between the two.

You have steered me in the direction I need to investigate (i.e. it probably is something to do with KDE or the font server - just less obvious). I will be happy to post another question with say 200 points that I will give to you for your guidance. Just post back to this question.
libXft uses different settings from xfs.
xfs: /usr/X11R6/lib/X11/fs/config
Xft: /usr/X11R6/etc/fonts/fonts.conf

Since you did not inquire, I did not post.
aecooperAuthor Commented:
Nope I did not get the answer I was looking for. However I have resolved the issue myself - sort of. Details:

1) Firstly the RedHat mucking around with the KDE theme. Under previous RH and RH like distros this has been the case but with RH4 it is much more vanilla. They are learning:-) So sorry this was a red-herring.

2) Anti-aliasing. I haven't found out how you successfully switch it off and keep a sensible selection of fonts (although Mandrake does this sucessfully - probably either a font rendering module in the X server and/or xfs config thing  - nothing obvious springs to mind though looking at the configs). However I have found out why the anti-aliasing looks absolutely terrible. This is down to an X driver issue. I would have thought it would be independent of the driver but which driver you use makes a tremendous difference. The default - auto detected driver rendered the fonts so badly that it was like I was drunk and seeing double. Now I have a more specific driver loaded, it is much crisper and perfectly usable.

Many thanks for all your help.

I have awarded the points to gheist just because he was so helpful.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.