[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Crosstab Percentages NOT balancing to 100%?? CR XI

Posted on 2006-05-04
6
Medium Priority
?
445 Views
Last Modified: 2008-02-01
Experts:

I have a cross tab that is based on COUNTS of a file number. But the display is a PERCENTAGE. I'm noticing that the percentages shown are NOT balancing to 100%.

They are 1% off.

ie.

DEPT          CH 7     CH13    TOTAL
1                  9%      90%     100%
2                 10%    89%      100%
ETC..

How can I correct this?
0
Comment
Question by:MIKE
  • 3
  • 2
6 Comments
 
LVL 42

Expert Comment

by:frodoman
ID: 16608768
Try right-clicking on the field and formatting on the number tab with decimal points to see what you really have - this may just be a rounding issue?
0
 
LVL 17

Author Comment

by:MIKE
ID: 16608808
I believe it is a rounding issue, but how do you correct it? If I try to format or add decimals it ignores what I try to format.

It is a percent of COUNT of FILE NUMBER.

I don't have many options?
0
 
LVL 42

Accepted Solution

by:
frodoman earned 2000 total points
ID: 16609066
Well that is a new development on me but I tried it on my system and got the same results.  I found some docs on the B.O. site that indicate this was a bug in CR9 which they claim was fixed in a hotfix but I'm wondering if the bug persists in other versions as well.  Basically the problem is that the "% of" values are truncated and stored as integers.

I did find a link to a document described as a workaround ( http://support.businessobjects.com/communityCS/TechnicalPapers/cr_percent_of_distinct_count.pdf.asp ) - hopefully this will work for you.
0
How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

 
LVL 16

Expert Comment

by:wykabryan
ID: 16609403
This has always been an issue with CR all the way back to CR 9.0.  I have spent many of hour looking for a solution.  And now Frodoman, you have solved the world's issues.  Thanks!!!  I have a couple of clients that will now be happy.
0
 
LVL 17

Author Comment

by:MIKE
ID: 16609471
Frodoman:


Whod a thunk??? Man this is an awesome assist. THANKS.

M
0
 
LVL 42

Expert Comment

by:frodoman
ID: 16630034
Glad to help.
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Crystal Reports: 5 Tests for Top Performance It is complete, your masterpiece report.  Not only does it meet your customer’s expectations, it blows them out the water, all they want is beautifully summarised and displayed in a myriad of ways. …
Hello everyone, Hope you find this as helpful as we did. We have on the company I work for an application built in Delphi V with Crystal Reports 8. We all know that Crystal & Delphi can be temperamental sometimes and the worst thing is, nearly…
This video shows how to quickly and easily deploy an email signature for all users in Office 365 and prevent it from being added to replies and forwards. (the resulting signature is applied on the server level in Exchange Online) The email signat…
With just a little bit of  SQL and VBA, many doors open to cool things like synchronize a list box to display data relevant to other information on a form.  If you have never written code or looked at an SQL statement before, no problem! ...  give i…
Suggested Courses

831 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question