• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3411
  • Last Modified:

Cannot successfully format HDD in External USB Hard Drive Enclosure (Cypress AT2LP)

Hi all,

I'm having a problem with a HDD in an External USB enclosure. The enclosure is manufactured by Mad Dog Multimedia (MEGAVAULT 3.5" USB Anodized Aluminum Enclosure) and, up until a few days ago, it was working perfectly. Then, all of a sudden, XP starts asking me whether I want to format the drive every time I try to access it.

The HDD itself is fine - I verified it using SeaTools Desktop Edition and it passes all tests when installed internally on a PC.

I have tried to re-partition and format the HDD while it is in the USB enclosure. Partitioning seems to work fine - both Windows and Partition Magic do not report any errors when I partition the drive. However, I cannot format the drive successfuly when it is connected to my computer via the USB enclosure. I have tried formatting with Windows Disk Manager, the FORMAT command and through Partition Magic (v8) - all to no avail. I have also formatted the drive internally on a PC and then tried to access it via the External USB enclosure, but all I get is a XP's kind offer to format my drive.

-= Error Codes & Observations =-

Windows Disk Manager formats the drive to 100% and then returns the following error message: "The format did not complete successfully."

Partition Magic returns error code 626 - stating that it cannot access the drive at boot time.

Both Windows Disk Manager and Partition Magic are able to make partitions on the drive (I have verified the successful partition creation by re-installing the drive internally on a PC and checking with FDISK)

Just to reiterate - the drive does appear in My Computer and I can click on it.

Also, I believe my USB enclosure uses a Cypress AT2LP high-speed USB controller. I have checked with the manufacturer and there are no firmware updates.

-= My Specs -=
HDD in Question: Seagate Barracuda 80GB (IDE/ATA interface)
Ext. USB Enclosure: MEGAVAULT 3.5" USB Anodized Aluminum Enclosure by Mad Dog Multimedia

Sony VAIO PCG-GRT815M
Intel Pentium 4 (wow! almost wrote Pentium Pro! FLASHBACK!!!) 3.0GHz (not HT enlightened)
512MB RAM
3 USB2.0 ports
SiS 7001 PCI to USB Open Host Controller
SiS PCI to USB Enhanced Host Controller

Please let me know if I can provide more useful information.

Thanks for your time!

0
naoy
Asked:
naoy
3 Solutions
 
Expert4XPCommented:
I've had experiences (both good and bad) with USB2 drives.  Sometimes the fault is in the motherboard firmware that supports USB drives.  

So first check for any bios updates to your Sony PC.

Secondly, if that looks ok, I have still solved several "mysterious" problems like you describe by purchasing a PCI USB2 card which costs typically about $15 to $25 depending upon brand, store vs. internet vs eBay.  Using the USB in the PCI slot (usually there are 4 ports) often made them work when they were getting errors directly plugged into the motherboard.

I'm assuming you are not using a USB2 hub.  If so, stop using it, and cable directly to the PC.

0
 
naoyAuthor Commented:
Hey Expert4XP,

Thanks for your input! Here is my feedback -

> So first check for any bios updates to your Sony PC.

I am using all of the latest drivers and firmware from Sony (I cross-checked the driver versions installed on the laptop with the ones on the vaio-link site.)

> I have still solved several "mysterious" problems like you describe by purchasing a PCI USB2 card

I apologize for not making this clear in my initial post - I am running a Sony VAIO Laptop. Also, there is no hub involved, the drive is connected directly to the USB port on the back of the laptop.

Thanks again for your suggestions!

0
 
Expert4XPCommented:
OK.  With a laptop though the same principle would apply.  You could test a pccard USB2 adapter and plug into that.  I don't think they are very expensive if you can't find one from a friend.
0
Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

 
naoyAuthor Commented:
Expert4XP,

Thanks again for your prompt reply. Unfortunately, I don't know anybody here with a PCMCIA USB card and I want to avoid spending money if possible. The thing is, I have an Iomega 80Gb and a LaCie 250Gb drive and they both continue to work on my VAIO laptop - I've tested the drives on all USB ports and everything is in order - so I highly doubt it's a problem with my onboard USB controllers.

By deduction I think I can assume with some certainty that the problem is probably with the enclosure itself. I have no way of testing it and although I have been in contact with the manufacturer, it seems they don't have or don't want to give me diagnostic tools. In all fairness, I did not register the enclosure.

What I find very odd is that I can access the drive enough to create a partition on it, but I cannot format it. I have tried all jumper positions on the drive (Master|Slave|CSel) and I can create partitions in all modes, but still the formatting fails in all instances. What is more, I have run SeaTools (Seagate's Diagnostic) from my laptop and it performed a surface scan of the Seagate HDD while inside the enclosure via USB. Is that crazy or what?!

Cheers!
0
 
Expert4XPCommented:
OK.  If you have tested other USB drives in your laptop, that rules the laptop out.

Did you ever try plugging your usb2 drive into a different pc?  See if you get the same results.  That would pretty much cinch it one way or another.

Does the MadDog documentation say how large of hard drive their enclosure supports?

>up until a few days ago, it was working perfectly. Then, all of a sudden, XP starts asking me whether I want to format the >drive every time I try to access it.

That makes it sound like an electronics problem with either the hard drive itself or the enclosure.
0
 
naoyAuthor Commented:
Thanks,

MadDog's documentation is rather sketchy, but the documentation I found on the USB controller (Cypress AT2LP) says that it works with drives up to 300GB in size. Mine is only 80GB.

Yes, I tested the drive /w USB enclosure on a PC at a local repair shop - everything is in order - the drive formats correctly and it works like it should.

It's such a crazy problem, no? My USB ports work fine, the hard disk is in good health and the enclosure works on another PC. I've tried uninstalling the Mass Storage Device drivers for the enclosure and re-installing (uses regular Microsoft drivers) ...

Can anybody recommend a generic diagnostic utility for external IDE-USB devices? Maybe it's a voltage problem on my laptop? I am almost tempted to get my multimeter out and start measuring Vout  and resistance on my USB ports.

Thanks again Expert4XP
0
 
rindiCommented:
I don't think you said whether formatting the disk worked while connected internally to the PC. If that didn't work the disk would be at fault and not the USB case. If that worked it would be the USB case. Is this case powered extra? a lot of laptops don't supply enough power through the USB ports alone, and with most HD's you need extra power. Sometimes a powered USB Hub can help.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now