Exchange 2000 cluster reverse DNS

Posted on 2006-05-04
Last Modified: 2008-10-15
I am trying to match my reverse DNS entry to my public mail server ip
address. All incoming mail comes in fine to my cluster's smtp ip address. However,
outgoing mail uses the active node's ip address (not the cluster ip address),
so in effect I have two possible ip addresses I am sending email from (active
+ passive node). Under the SMTP Server properties in ESM the IP address is
the same as the cluster ip address. Is there a way to match all outgoing
mail to the cluster ip address? Any other suggestions? Thanks.

Question by:nstefanov
    LVL 104

    Expert Comment

    Normally with a cluster I recommend a frontend server. Gets round these problems by providing a single point of entry.

    However with Exchange 2000 a frontend has to be an Enterprise Edition license, so is very expensive.
    Another option would be a mail relay server to sit in front of the two servers. A standalone Windows 2003 box can do the job, so could a Linux machine. All you need to do is ensure the server announces itself correctly.

    You would use an SMTP Connector to route email through the relay box.


    Author Comment

    Any special configurations on this relay server or just out of the box installation?  Thanks.

    LVL 104

    Accepted Solution

    You need to configure the Windows SMTP service... these two articles will help.
    The first one is for Windows 2000 as there isn't an equivalent for Windows 2003 (I probably need to write one as I do the setup very frequently).


    Author Comment

    Ok thanks for the great info.  Installed the SMTP service on a 2003 box and added a new remote domain that matches my domain name.  Under properties, I checked allow incoming mail to be relayed to this doman and forward all mail to smart host I set to my Exchange 2000 server.  Then on my Exchange cluster connector i selected forward all mail through this connector to the following smart host [ip address of SMTP server].  
    When I try to send mail I get:

    You do not have permission to send to this recipient.  For assistance, contact your system administrator.
                <mail.whatever #5.7.1 smtp;550 5.7.1 Unable to relay for external hosts.

    I was looking for some relay persmissions on the smpt server but I can't find any relay options on the SMPT server.  There are only 2 tabls General and Advanced.  Please advise.



    Author Comment

    Never mind. Found it.  Thanks for your help.


    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    How to run any project with ease

    Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
    - Combine task lists, docs, spreadsheets, and chat in one
    - View and edit from mobile/offline
    - Cut down on emails

    Email signatures have numerous marketing benefits. Here are 8 top reasons to turn your email signature into a marketing channel.
    Set up iPhone and iPad email signatures to always send in high-quality HTML with this step-by step guide.
    In this video we show how to create a Distribution Group in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >>…
    In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…

    779 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    15 Experts available now in Live!

    Get 1:1 Help Now