[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 234
  • Last Modified:

OWA SBS 2003 Problem - Changed IP, now cannot access OWA from Outside

Hello all...

Had to change the IP of the server from 192.168.1.2 to 192.168.7.2.

Everything is working fine except OWA.

This is all I know:
Very vanilla install of W2K3 SBS.  No other servers, just it and a firewall.
OWA functions properly when accessed on the host server.
OWA functions properly when accessed from a computer on the local subnet.

When visiting the site from outside:
I get the security warnings:

! The security certificate was issued by a company you have chosen not to trust
(check) The security certificate date is valid.
! The name on the certificate is invalid or does not match the name of the site.

I say 'Yes' to that, and get:

'The page cannot be displayed'

I have gone up and down the IIS Admin.  I found a few Directory Security restrictions were still on the .1 subnet, and changed them to .7.
I searched through the registry for .1, found a few, but nothing really specific to webmail or IIS.

I am not sure where to keep looking.  It doesn't look like a certificate problem to me, but I am open for suggestions.

Any assistance appreciated.

Thanks,

TN
0
tnorman
Asked:
tnorman
  • 3
  • 3
  • 2
2 Solutions
 
MNH1966Commented:
You could try running the "Configure E-Mail and Internet Connection Wizard" again.
This is the wizard that generates the original generic certificate.
0
 
cvanhoudtCommented:
The "errorr" you see is not that uncommon, especially when you have created the Certificate on your onwn Certificate server, which by default is not trusted.
Personally, I would start looking at the certificate (to assure this, temporarly disable the need to use SSL and test it without).

Did your setup work when the first IP address was still in place (192.168.1.2) or did you also encounter this problem then?
If you com from outside your network, you know that your external address needs to be routed to your internal address (NAT or whatever). I would check this routing is properly configured (if it was setup to route your external address to 192.168.1.2, you need to change this.

Is your OWA published via ISA or another reverse proxy server? Does this setup still point to the "old" ip-address.


Cheers,
Kris
0
 
tnormanAuthor Commented:
Thanks for your input on this.

Quick answers to Kris' questions:
- yes, it all worked fine with the old IP
- OWA is on the same server (i.e. ISA of the W2K3 SBS server)

The suggestion of turning off SSL was a good one.  I have turned it off on the 'exchange' page.  This is now what happens:

I get no certificate warning (as expected)
I log in, and the page starts to load.

However, the page looks 'very errored'.

There are no graphics.  I can see any emails.  All the Folder names are hyperlinks with 'error' image boxes beside them.

MHN, do you still think running the ICW would be a good idea?
Any other suggestions?

Thanks,

TN
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
cvanhoudtCommented:
I think somewhere in ISA you will still point to the old address - I'm not really an ISA or SBS experts, but I recall to indeed have read somewhere rerunning Configure E-mail and ICW could solve this (what MNH1966 suggested in the first place).
Also possible I think: open ISA Management Console and Expand Policy Elements and Highlite
Destination Sets and see if OWA lists your FQDN or the IPAddress? In Case of IP address, which one?

Kris
0
 
MNH1966Commented:
SBS is very wizard driven, which personally I find very annoying since you never know what's going on.
On the plus side, the wizards do seem to be able to fix things quite quickly, so yes, my suggestion still stands.

I've seen the same behaviour with turning off SSL, which I can't really explain. Only thing I can think off, is that the SSL settings are nested deeper than expected. If you still want to go for that option, you have to dig through the website with IIS Admin to find out where it's configured to use SSL. Downside is you'll lower your security.

Maurice
0
 
tnormanAuthor Commented:
No joy on the re-running of the wizard.

Cvan, can you elaborate a bit more on your steps?  I could not find Policy Elements in the IIS Manager.

Thanks,

TN
0
 
cvanhoudtCommented:
TN, I referred to ISA Management Console, not IIS.
Again, I'm not sure how it will show up on an SBS system.

Cheers,
Kris
0
 
tnormanAuthor Commented:
...one should never assume...

I thought it all had to do with changing the IP of the server.  Today, just to test, I put my old Linksys router back into the setup, and the OWA flies great.  It is an issue with my new Sonicwall router.  Wrong tree all this time.

Thanks everyone for their input, though!

I will split the points for the effort...

Thanks,

TN
0

Featured Post

Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

  • 3
  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now