?
Solved

ESM Gives Error Id No: c1038a21 when click on Folder Properties of General Object under Public Folder Store

Posted on 2006-05-05
7
Medium Priority
?
1,101 Views
Last Modified: 2008-01-09
Background: I was running Exchange 2000 and wanted to retire it.  I loaded a new server with W2K3 Server and Exchange 2003 Server, changed what I *thought* I had to in the ESM to point to new server.  I uninstalled Exchange 2000 off of old server and turned it off.  Mail tosses but when a client tried to access the Offline Address Book it would error out.  I created a second "Offline Address List", Set as New Default and then that error went away.

However, I still can't access my Public Folders (the folders and hierachy show but errors when I click on any folders).  Also, from the ESM, if I try and click on:

Public Folder Stores\Public Folder Instances\Default
Public Folder Stores\Public Folder Instances\exchangeV1
Public Folder Stores\Public Folder Instances\globalevents

I get this error:  The Mail Proxy for this server can not be found.  This may be due to replication delays.  The mail enabled pages will not be shown.  ID no: c1038a21.

Any ideas?


0
Comment
Question by:MarkWThompson
6 Comments
 
LVL 12

Expert Comment

by:aa230002
ID: 16612617
Did you check these links -->

You may receive a c1038a21 error message when you try to use Exchange System Manager to look at the properties of a public folder
http://support.microsoft.com/?id=328740

When you copy a public folder from Microsoft Outlook by using an Outlook client computer, the copy of the public folder may contain a reference to the original folder's Active Directory entry in Exchange 2000
http://support.microsoft.com/?kbid=888105

Thanks,
Amit Aggarwal.
0
 
LVL 12

Expert Comment

by:aa230002
ID: 16612624
Whenever you mail-enable a public folder, a directory object is created in "Microsoft Exchange system Objects" container in Active Directory. You can view this container by enabling "Advanced features" in Active Directory Users & Computers.
If you are not able to mail-enable a Public Folder. Check this container. It should be there at the root under your domain and check the permissions on the container too.

Thanks,
Amit Aggarwal.
0
 
LVL 35

Expert Comment

by:rakeshmiglani
ID: 16612713
Are you able to access Public folders when you view them via the public folder tree in ESM

Expand Folders
Expand Public folder tree
Over here you have your public folders
If you right click on public folders you get the option to view your system folders

Check the settings of the OAB server, RUS server in ESM. are they pointing to the new server or the old server?
Also check whether the routing master is set to your new server and not the old one

Did you replicate the public folders to the new server before removing the old exchange server?

Are you getting this error when you check the properties of all the folders or just the ones mentioned above?
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 

Author Comment

by:MarkWThompson
ID: 16613489
Amit,

The first link you provided I saw while trying to find the solution.  Unfortunately I can't find the setting they're asking about (the PR_PF_PROXY).  The Information Store Viewer isn't the most friendly application.  I'll keep trying though and let you know.

Rake,

Before I uninstalled Exchange 2000 off of my old server, I updated the OAB and RUS to the new server name (it wouldn't let me uninstall until I did).  HOWEVER, I did NOT replicate the public folders to the new server (doh!).  That's GOT to be my problem.  An I'm only getting the error on the folders mentioned above (no error on the others).

All,

I exported my Public Folders to a .pst before I did all this.  At this point I'm ready to just delete the old Public Folders and simply re-create them with the .pst.
0
 

Author Comment

by:MarkWThompson
ID: 16760688
Thanks for the help, but I ended up finding my own solution.  First, I deleted the Public Folders and re-creating them.  That did NOT solve the problem.  

Here is what DID work:

1) I stopped exchange
2) deleted the public folders (pub1.edb and pub1.stm)
3) restarted exchange
4) attempted to mount it (where it gave me an error and asked if I wanted to re-create them) everything then worked just fine
5) re-imported all my folders from a backup.

It had something to do with the GUID of that particular Private Store being lost or something.
A good article on how to fix this is here: http://searchexchange.techtarget.com/tip/1,289483,sid43_gci1057114,00.html?bucket=ETA (the difference between this article and Exchange 2003 is that you don't have to go change any GUIDs, I skipped that entire step and everything worked just fine.)

MODERATOR:  PLEASE DELETE THIS QUESTION OR CLOSE IT IF YOU THINK THIS ANSWER WILL HELP SOMEONE ELSE.


0
 

Accepted Solution

by:
GranMod earned 0 total points
ID: 16977684
PAQed with points refunded (500)

GranMod
Community Support Moderator
0

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

As much as Microsoft wants to kill off PST file support, just as they tried to do with public folders, there are still times when it is useful or downright necessary to export Exchange mailboxes to PST files. Thankfully, it is still possible to e…
This month, Experts Exchange sat down with resident SQL expert, Jim Horn, for an in-depth look into the makings of a successful career in SQL.
In this video we show how to create an Address List in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Organization >> Ad…
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…
Suggested Courses
Course of the Month16 days, 21 hours left to enroll

862 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question