?
Solved

Can't access servers behind VPN - PIX 501

Posted on 2006-05-05
9
Medium Priority
?
485 Views
Last Modified: 2008-02-07
I have a PIX 501, and I went through the VPN Wizard to set up remote access using Cisco's VPN Client v. 4.  Everything went fine, and I can connect to the VPN but I cannot see any machines behind the firewall.  

New to VPN config, so I don't know what tests to run.  When I connect through MSN Dialup, my ipconfig changes to the IP address, DNS, and WINS I setup in the VPN Wizard.  In the PIX PDM, I can see my connection.  I get no errors, I get nothing in the syslog other than I connected.  I cannot ping, I cannot tracert, just get time outs.

In the VPN config, it said if I left the NAT exclusion list empty it would allow access to all servers.  I also tried specifying servers to no avail.


Below is my PIX config (with some extraneous names removed)
: Saved
: Written by enable_15 at 07:17:39.157 EDT Fri May 5 2006
PIX Version 6.3(3)
interface ethernet0 10baset
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password oWV9oT4iPorTo.Vl encrypted
passwd oWV9oT4iPorTo.Vl encrypted
hostname pixfirewall
domain-name ciscopix.com
clock timezone EST -5
clock summer-time EDT recurring
fixup protocol dns maximum-length 768
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 192.168.1.101 dellserver
<some names removed>
name 192.168.2.10 vpntest
object-group service EMAIL tcp
  description POP3 and SMTP
  port-object eq pop3
  port-object eq smtp
access-list 100 deny tcp host AudioLogger any
access-list 100 deny udp host AudioLogger any
access-list 100 remark CC auth access for ClearCommerce
access-list 100 permit ip any host secure4x.clear
access-list 100 remark Allow outbound ICMP responses to DNS Stuff
access-list 100 permit udp host dellserver host NISTTIME eq ntp
access-list 100 permit tcp host dellserver host BackupVirusFTP eq ftp
access-list 100 permit ip any host NewDBanqueSQL
access-list 100 permit ip any host SQLDataBanque
access-list 100 remark Enable DellServer to send SMTP Mail
access-list 100 permit tcp host dellserver host DBResearchMail eq smtp
access-list 100 remark Other than our DNS servers and the BackupExec antivirus server,
access-list 100 remark DELLSERVER is not allowed on the Internet.
access-list 100 deny ip host dellserver any
access-list 100 permit udp any any eq domain
access-list 100 permit udp any any eq netbios-ns
access-list 100 permit tcp any any eq www
access-list 100 permit tcp any any eq https
access-list 100 remark REal player?
access-list 100 permit tcp any any eq 8080
access-list 100 permit tcp any any eq 8100
access-list 100 permit tcp any any eq 8000
access-list 100 remark Windows Media Streaming
access-list 100 permit tcp any any eq 7070
access-list 100 remark Windows Media Streaming
access-list 100 permit tcp any any eq 554
access-list 100 remark Windows Media Streaming
access-list 100 permit tcp any any eq 1755
access-list 100 remark Windows Media Streaming
access-list 100 permit udp any any eq 1755
access-list 100 remark Block all other UDP
access-list 100 deny udp any any
access-list 100 permit tcp any host ftpAlcoaCom eq ftp
access-list 100 permit tcp any host DataBanqueCom eq ftp
access-list 100 permit ip any host NewDatabanque
access-list 100 permit tcp any host MailDBanqueCom eq pop3
access-list 100 permit tcp any host MailDBanqueCom eq smtp
access-list 100 permit tcp any host Epiphyte
access-list 100 permit tcp any host MailDBanqueCom eq 8383
access-list 100 permit tcp any host DBResearchMail eq smtp
access-list 100 permit tcp any host DBResearchMail eq pop3
access-list 100 permit icmp any any echo
access-list 100 permit icmp any any traceroute
access-list 150 remark Allow PCAnywhere data
access-list 150 deny tcp any host 72.22.0.65 eq pcanywhere-data log 4 interval 2
access-list 150 remark Allow PCAnywhere status
access-list 150 deny udp any host 72.22.0.65 eq pcanywhere-status log 4 interval 2
access-list 150 remark Allow ping responses to come in.
access-list 150 permit icmp any any echo-reply
access-list 150 remark Allow TraceRt responses to come in
access-list 150 permit icmp any any time-exceeded
access-list 150 permit ip host vpntest any
access-list inside_outbound_nat0_acl permit ip any 192.168.2.0 255.255.255.192
access-list outside_cryptomap_dyn_20 permit ip any 192.168.2.0 255.255.255.192
pager lines 24
logging on
logging trap warnings
logging queue 1024
logging host inside dellserver
no logging message 106023
icmp permit any echo outside
mtu outside 1500
mtu inside 1500
ip address outside 66.37.61.126 255.255.255.224
ip address inside 192.168.1.1 255.255.255.0
ip verify reverse-path interface outside
ip audit info action alarm
ip audit attack action alarm
ip local pool VPNPool vpntest-192.168.2.50
pdm location DataBanque 255.255.255.240 outside
pdm location LinkSysPrinters 255.255.255.255 inside
pdm location dellserver 255.255.255.255 inside
pdm location snap51857 255.255.255.255 inside
pdm location SpecialOut-141 255.255.255.255 outside
pdm location InternetAccess 255.255.255.255 outside
pdm location DNS2 255.255.255.255 outside
pdm location DNS1 255.255.255.255 outside
pdm location BackupVirusFTP 255.255.255.255 outside
pdm location BadSite1 255.255.255.255 outside
pdm location DataBanqueCom 255.255.255.255 outside
pdm location SQLDataBanque 255.255.255.255 outside
pdm location ftpAlcoaCom 255.255.255.255 outside
pdm location MailDBanqueCom 255.255.255.255 outside
pdm location NISTTIME 255.255.255.255 outside
pdm location vpntest 255.255.255.255 outside
pdm location 192.168.2.0 255.255.255.192 outside
pdm logging warnings 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
global (outside) 2 66.255.96.140
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) 72.22.0.65 AudioLogger netmask 255.255.255.255 0 0
access-group 150 in interface outside
access-group 100 in interface inside
route outside 0.0.0.0 0.0.0.0 66.37.61.97 1
timeout xlate 1:05:00
timeout conn 0:05:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
tftp-server inside dellserver /
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map client authentication LOCAL
crypto map outside_map interface outside
isakmp enable outside
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup DataBanqueVPN address-pool VPNPool
vpngroup DataBanqueVPN dns-server dellserver
vpngroup DataBanqueVPN wins-server dellserver
vpngroup DataBanqueVPN default-domain databanque.com
vpngroup DataBanqueVPN idle-time 1800
vpngroup DataBanqueVPN password 987fhi876SDKFHJ7840jdjs
telnet 192.168.1.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.7-192.168.1.39 inside
dhcpd dns dellserver dellserver
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd enable inside
username jprice password TKSSDuuoWG5D3mtf encrypted privilege 15
terminal width 80
Cryptochecksum:0d1976909c3d164fcef28b36414767fd
: end
0
Comment
Question by:JohnBPrice
  • 4
  • 3
  • 2
9 Comments
 
LVL 3

Expert Comment

by:m1crochip
ID: 16615665
Try enabling "use lmhosts lookup" in client tcpip settings and add your domain controller to the LMHOSTS file:

sample:

192.168.1.13    CTS-SERVER  #PRE  #DOM:CTS
192.168.1.13    "CTS            \0x1b"  #PRE

where CTS-SERVER is the domain controller and CTS is the domain

keep the length of the strings the same.
0
 
LVL 16

Author Comment

by:JohnBPrice
ID: 16615796
Well, I'll give it a try, but I don't see how lmhosts could make a difference, I can't ping or tracert by ip address.  I also can't nslookup even though my DNS Server IP address gets set correctly when I connect.
0
 
LVL 3

Assisted Solution

by:m1crochip
m1crochip earned 400 total points
ID: 16616079
also try changing your virtual client interface to the 192.168.1.0 range.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 1

Expert Comment

by:SANG501
ID: 16616110


I believe this version and the 506e model can only do classful subnets. Also, is the VPN pool within the 192.168.1.X /24 network? If not you will need a route between the two.
0
 
LVL 16

Author Comment

by:JohnBPrice
ID: 16616556
Ah, that was one of my questions.  My VPN address pool should be in my LAN address pool (192.168.1.xxx)?
0
 
LVL 1

Expert Comment

by:SANG501
ID: 16616573
Correct - otherwise you got two different networks that cant talk to each other. Either add a route statement or change the pool to 192.168.1.1-254
0
 
LVL 16

Author Comment

by:JohnBPrice
ID: 16629731
>>Either add a route statement or change the pool to 192.168.1.1-254
OK, I don't understand that.  My LAN is 192.168.1.1-254, with a few hard coded devices, an internal DHCP pool of 192.168.1.10-40.  I was thinking you meant the VPN pool should be 192.168.1.60-70 (or so) so it wouldn't overlap with my internal DHCP pool.
0
 
LVL 1

Accepted Solution

by:
SANG501 earned 1600 total points
ID: 16631688


I can't recall the command for the route but I know it exists. I had that setup at my old company many years ago. Basically we used 192.168.0.0/16 on our network but because it is not a classful subnet, the PIX would assume that the 192.168.0.0 was a 255.255.255.0 mask. Thus any users that vpned in would get the mask of /24 and therefore couldnt talk to any of our servers on the domain. So I changed the vpn pool to 172.16.1.1-254 and created a route statement so that 172.16.1.1 could talk to 192.168.1.1/16.

Basically you only need to do the above if your envinroment isnt using a classful subnet, otherwise just make your vpn pool the same as your network. In your case, you can splice up your dhcp scope so it only hands out 192.168.1.1-200 and leaving your vpn-pool to hand out the rest. Hope this makes sense.
0
 
LVL 16

Author Comment

by:JohnBPrice
ID: 16667963
I haven't had time to get back to this, and since I've long ago fallen off the first page, I'll close it up.  Perhaps I'll put up another question when I have time.
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A 2007 NCSA Cyber Security survey revealed that a mere 4% of the population has a full understanding of firewalls. As business owner, you should be part of that 4% that has a full understanding.
How to fix a SonicWall Gateway Anti-Virus firewall blocking automatic updates to apps like Windows, Adobe, Symantec, etc.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
There's a multitude of different network monitoring solutions out there, and you're probably wondering what makes NetCrunch so special. It's completely agentless, but does let you create an agent, if you desire. It offers powerful scalability …

809 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question