[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 259
  • Last Modified:

Change DNS (or whatever) so when users go to intranet.company.com it points to servername

I have SharePoint installed on a server (let's call it servername).  To get to the top level application we have to go to http://servername.

I want to make it so users can go to http://intranet.company.com and have it point to http://servername (company/domain wide)

How do I do this?

Thanks

Doug
0
dougshepard
Asked:
dougshepard
  • 3
  • 3
  • 2
3 Solutions
 
dougshepardAuthor Commented:
Also, my domain is called oldcompany.com but I want people to go to intranet.company.com.

In other words, the domain name is not the same as the company name anymore.

Thanks

Doug
0
 
ksearchCommented:
In  DNS, add an "A" record for INTRANET and give it the same IP address as SERVERNAME.  that should do it.

You can have more than one record with the same IP address. You just can't have the same record with more than one IP!
0
 
feptiasCommented:
To use the company name instead of the domain name you will need to create a new forward lookup zone in DNS and give the new zone the name company.com. Then add a new Host (A) record into the new zone and set it as "intranet" with the IP address of the target server. However, if you do create a new forward lookup zone with that name then it will impact on any LAN user trying to access any other URL that ends with company.com. For example, users trying to access your web site which might be www.company.com. So you need to think it through carefully and look at what else is already hosted within that company.com name space and who on your LAN might be wanting to use it.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
ksearchCommented:
Yikes! sorry, I missed that the domain was OLDCOMPANY and you wanted to use company.com.   My bad. Still snoozin' I guess.

You could put an entry in each users host file for intranet.company.com that points to the IP you want.  A manual solution, I know, but it won't affect all entries for company.com, anyway.

Just another thought.
0
 
dougshepardAuthor Commented:
feptias,

I did as you said and it works.  There is a problem however.  When I go to "sever" it resolves to http://server/default.aspx and loads the SharePoint site.  When I go to "intranet.company.com" it asks me for a username and password.  Once I enter a valid username and password, it loads the SharePoint site.  Why the difference?  

Also, if I go to the server IP address (instead of the server name) it also asks for a username and password.  I don't understand why it would act different.

Thanks

Doug
0
 
feptiasCommented:
I know my DNS stuff, but don't know about sharepoint so am reluctant to offer suggestions that might mess it up, but I can take a guess at the general area where you need to look:
Take a look at the setup for the IIS web sites and see if the sharepoint one is using host headers with the name "server" in them. That would at least explain why a request to the same IP address would get a different reponse from the web server. You could add another host header in there that matches the new intranet name. Then, if it is making sense from there you could start looking at the authentication settings for that web site on IIS.

I guess this is an opportunity for another expert to add some comments, please.
0
 
feptiasCommented:
Hi Doug

Have looked into this a bit more. The same authentication issue happens with any web site on IIS, so it is not exclusively a sharepoint issue. The integrated windows authentication seems to be linked to the domain name used to access the web site - so changing the URL you use to get to the site has invalidated the default windows authentication and you have to enter the user name and password every time you access it (ticking remember my password doesn't help). I've tried some other tricks with alias UPN suffixes for the domain but that didn't work.

That seems to leave only two options, but if anyone else reading this knows another, please add a comment:
1) go back to using oldcompany.com instead of company.com
2) lower the security on the IIS web site that is the gateway into sharepoint.

Option 2 carries obvious risks and you will have to make your own judgement on whether it is viable or not. Depending on who needs to access the sharepoint web site and where they are located on your network, there are alternative security options in IIS. For example there is an option to grant access only to computers on a specified network/range of IP addresses. The option that is triggering the name/password prompt is the Integrated Windows Authentication under IIS | Web Site Properties | Directory Security | Authentication and access control (the button labelled Edit...).

Frankly, this issue deserves to be posted as a completely new question.
0
 
dougshepardAuthor Commented:
I posted it as a new questions.  An answer has already been given and looks good.

http://www.experts-exchange.com/Networking/Sharepoint/Q_21839793.html

Thanks

Doug
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 3
  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now