Send mails to the outgoing mailbox (when offline)

A user doesn't have connection to the network all the time but he writes mails even if he is offline. But when he click the send button he get the error message:

"The server is not rewsponding. The server may be down or you may be experiencing network problems."

The user uses the Remote Location. (we have a remote and a server location in Lotus notes)

I thought that when a user is offline and he sends a mail, it will be send to the outgoing mailbox and after he connected to the network the mails will be delivered.

I tried it myself and saw following:
When I selected a name from my own Addressbook and clicked send the mail was sent to the outgoing mailbox indeed. (without network connection)

When I selected a name from the Company Addressbook on Local and clicked send the mail wasn't sent to the outgoing mailbox, and I got the above error message.

Do you now why?
 
didier20Asked:
Who is Participating?
 
marilyngCommented:
>>When the Location type is "Local Area Network", replication enabled and the interval is 10 minutes - it works fine since years.
>>Then I pull out the network cabel and send a mail to e.g. xxx@gmail.com. The mail will be sent to the outgoing mailbox. (it's fine as well)

>>Then I leave the network cabel unplugged and send a mail to a user inside the domain e.g.
>>testuser/Server/Company (LN Address) and I get an error message like Server not a TCP/IP ....or Couldn't connect to the server...


When you're trying to send to a notes domain, the code under the email send checks to see if the notes address is a valid one, so it tries to connect to names.nsf on the server, and validate the notes.name.  If you wanted to avoid this, send to the user's smtp address rather than the Notes Name address.  

Without the cable plugged in, and the location document set to Network, notes will attempt to validate the send to names, because it assumes that you're connected and will return the error message.

It doesn't not check smtp mail names because it would have no way of knowing if the name was valid, and that's why they are non-delivery reports.
0
 
mbonaciCommented:
Hi didier20,
is your location type No connection?
It should be, if you expect it to behave as you said, otherwize the router'll try to send inbound mail (inside your domain) through server.

Marko
0
 
Steve KnightIT ConsultancyCommented:
Set location to Island.  It will create mail.box if ones doesn't exist and mail will wait there.

Steve
0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

 
marilyngCommented:
Let's provide a bit more detail, if the user has Island location, or an Off Line location, then click on the configuration tabs to make sure that the connect to is set to "No Connection", and that the user has mail.box configured and that it exists on his workspace.

Also, if go to replicator, you should see a replicator tab for send or get mail.

Then switch to island location,  create a few emails and send them.  They go to mail.box and wait until you are connected to send them.

Then switch to OFFICE location, and replicate.  That should send the waiting emails.  If you look at the replicator tab when you're replicating it will tell you that it is sending emails.

I usually configure users for island, internet (so they can send SMTP mail) and Office locations.
0
 
didier20Author Commented:
Yes, you're right. I f the Connection type is "No Connection" then the mails are sent to the outgoing mailbox. But...

When the Location type is "Local Area Network", replication enabled and the interval is 10 minutes - it works fine since years.
Then I pull out the network cabel and send a mail to e.g. xxx@gmail.com. The mail will be sent to the outgoing mailbox. (it's fine as well)

Then I leave the network cabel unplugged and send a mail to a user inside the domain e.g.
testuser/Server/Company (LN Address) and I get an error message like Server not a TCP/IP ....or Couldn't connect to the server...

In both cases the cabel is unplugged but in the first case I get no error in the second I get an error.




0
 
mbonaciCommented:
didier20,
that's the whole purpose of location docs - to be able to switch to another setting when your connection state changes, instead of changing the values in one doc.

The difference is because of the fact that the router thinks that the person you're sending mail to is ("directly", so to say) reachable (since you're connected, according to your location doc).
In the case of outbound mail (your gmail example) it works differently - router just checks whether the doc exists in mail.box and if it does it sends it - that's all.

Hope this helps,
Marko
0
 
Steve KnightIT ConsultancyCommented:
Just an idea but try it with a user you have copied from public address book to your local one (or chosen from a local replica of domino directory etc.) and chosen from there? Sounds like it is trying to do a lookup of the address in the domino directory?

But as above use the Island location when offline... that's what it's for. I always have and haven't got Notes on me at the moment to check whether the above does go to mail.box.  Of course normally for laptop users and the like you turn on the user preference "Choose location at startup".

Steve
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.