• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 430
  • Last Modified:

Remote Web OWA access

I have Remote Web Workplace working and users can sign in, access the server, access workstations and the such but when I click on Outlook Web Access it ask me for a login. Typcially from this interface it just signs you in. I can not get any combination of domain/username and password to work for this. I get "You coudl not be logged on to Outlook Web Access. Make sure your domain\user name and password are correc, and then try again." I am using SBS 2003 w/ SP2 applied to Exchange. I should not need a domain name and have not had to use it on the previous installs I have done with this. I'm guessing I've got something messed up in security somewhere but don't know were else to look.
0
itsupportcci
Asked:
itsupportcci
  • 13
  • 10
1 Solution
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Service Pack 2 modifies the forms based authentication for OWA.  Please see this  KB to fix: http://support.microsoft.com/kb/843539

Jeff
TechSoEasy
0
 
itsupportcciAuthor Commented:
That is for Service Pack 1 I believe. I'll look more into it.
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Yes it originally was for SP1, but SP2 breaks it again.  See this if you want and opinion from another source:  http://snipurl.com/q36g

Jeff
TechSoEasy
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
itsupportcciAuthor Commented:
I tried to load this fix and I get the following error.
"Exchange Server 2003 Service Pack 1 is not installed. To install this update, you must first instal Exchange Server 2003 Service Pack 1."

Exchang Server 2003 Service Pack 2 is installed on this server.
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Have you installed SBS SP1 yet? Which included these 5 components?

Windows Server 2003 SP1
Exchange Server 2003 SP1
Windows SharePoint Services SP1
Windows Small Business Server 2003 Update KB891193 for Windows XP Service Pack 2
Windows Small Business Server 2003 SP1

If you did not install all of these prior to installing Exchange SP2, then you need to go back and do so... you may need to uninstall Exchange SP2 in order to accomplish this.  Details are at http://sbsurl.com/sp1

Jeff
TechSoEasy
0
 
itsupportcciAuthor Commented:
Yes I installed SBS SP1 and then Exchange SP2. I'm checking on the other ones. Doing a quick Windows Update check there were none listed. I didn't have this problem until I got Remote Web Workplace running, probably should have thrown that in there.
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
None of those come from Windows update.

Service packs must be manually updated.

Jeff
TechSoEasy
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
How did you get it to run?  I mean, what steps did you take?

Jeff
TechSoEasy
0
 
itsupportcciAuthor Commented:
OK, SBS SP1 and Exchange 2003 SP1 came pre-installed. I then put Sharepoint SP1 on it and then Windows SBS 2003 SP1. After that I installed Exchange SP2.

Do you mean what steps did I take to get RWW running?
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
What you just stated can't be right... you said SBS SP1 came pre-installed and you then put Windows SBS 2003 SP1 on it???

Jeff
TechSoEasy
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
y'know I missed something in your initial question,

>>"I should not need a domain name and have not had to use it on the previous installs I have done with this."

You most definitely have an INTERNAL domain name, and that is what the error message was referring to.  Although the hotfix should make it so you don't need to use DOMAIN\Username, but did you try to enter your credentials that way anyhow to see if it would work?

Jeff
TechSoEasy
0
 
itsupportcciAuthor Commented:
Shoot, I meant Exchange SP2, sorry. Too many things going on at once. I did 3 of these in the same week and this is the only one I'm having issues with. I think I messed something up in security when setting up RWW myself.
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Well, that's what I'm trying to figure out about RWW... you don't "set up" RWW it sets up automatically during the installation process when you finish all the items on the To-Do list.  Specifically it's configured via the Configure Email and Internet Connection Wizard.

Jeff
TechSoEasy
0
 
itsupportcciAuthor Commented:
Yes, originally they did not have the domain name and did not want to set it up. So I ran wizard and set it up. During that time I modified the directory security on OWA to allow outside access.

I was getting a 440 timeout when i went to OWA. I fixed that and now am back to just the login screen that I can't get to.
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
You don't need to modify directory security on OWA to allow outside access.  It's done with the CEICW as well.
So, whatever you modified, you need to change it back and rerun the wizard.

Jeff
TechSoEasy
0
 
itsupportcciAuthor Commented:
I keep getting this error.

Logon Failure:
  Reason: Unknown user name or bad password
  User Name: IUSR_Servername
  Domain: DomainName
  Logon Type: 8
  Logon Process: Advapi
  Authentication Package: Negotiate
  Workstation Name: CLCSERVER1
  Caller User Name: NETWORK SERVICE
  Caller Domain: NT AUTHORITY
  Caller Logon ID: (0x0,0x3E4)
  Caller Process ID: 5936
  Transited Services: -
  Source Network Address: -
  Source Port: -
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
The IUSR_<servername> is the builtin account used for anonymous access to IIS.  You've apparently removed this account from the directory security that you modified.  You may have also removed other important settings.  

Can you explain what you specifically did per your comment: "During that time I modified the directory security on OWA to allow outside access"?  

Jeff
TechSoEasy
0
 
itsupportcciAuthor Commented:
I was following directions I had found in a whitepaper somewhere. I fixed it though, the box was not checked to use windows authentication.
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
On the Default Web site, you should have Anonymous Access Checked, and Integrated Windows Authentication checked.

However, on the Exchange virtual directory you should have Anonymous Access Unchecked, and then BASIC authentication checked.  There should also be a single backslash \ in the Default Domain box.

Is this how you now have things set?

Jeff
TechSoEasy
0
 
itsupportcciAuthor Commented:
Yes. It was set on Exchange to Allow Anonymous Access and nothing else. so I change it to Basic authentication and it worked. Thanks.
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
No problem... you don't want to keep the anonymous access enabled on Exchange, btw.

Jeff
TechSoEasy
0
 
itsupportcciAuthor Commented:
yeah I turned it off. thanks. SBS is a different creature. I've done about 7-8 installs now and everyone seems to want a different feature turned on.
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
It will only act that way if you try to manually configure things instead of using the wizards.  (which are really just GUI scripts).  Because SBS is a PRE-CONFIGURED system, and because SBS has Server functions that you would normally NOT put into one box, it is mandatory that you follow the best practices methodology and to use all wizards that are available.  Only after you get a completely installed and configured functioning properly should you attempt any custom modification.

See http://sbsurl.com/itpro which describes some of this.

Jeff
TechSoEasy

0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 13
  • 10
Tackle projects and never again get stuck behind a technical roadblock.
Join Now