?
Solved

Out of office Agent seems not working

Posted on 2006-05-05
10
Medium Priority
?
279 Views
Last Modified: 2013-12-18
Our out of office mail does not seem to be working.  Users can go in and turn on out of office, and set the time they are to be out, but when someone emails them, that person does not get a response back saying they are out. Any ideas on what to check?
0
Comment
Question by:Enrique040897
  • 4
  • 3
8 Comments
 
LVL 18

Accepted Solution

by:
marilyng earned 200 total points
ID: 16621661
Yes, on the user's client, open their mail file and select view>>agents.    Right click on the out of office agent and select "test" and see what the agent test says.

Here is a good article:
http://www-128.ibm.com/developerworks/lotus/library/ls-Out_of_Office_agent/
0
 
LVL 1

Expert Comment

by:abelv
ID: 16643205
It sounds like the out of office agent is set to run at the default intervals...ie it runs every 6 hours.....so you need to up that...but I warn you up it only for certain individuals. Hope this helps
0
 
LVL 18

Expert Comment

by:marilyng
ID: 16643997
.....so you need to up that... << depends on what version of notes.  IF this is R5, then DO NOT UP THE VALUE, doing this really screws up the agent.

R6 is already set to run a few times a day, so there should be no reason to "up" or "change" the value until you discover what is wrong to begin with.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:Enrique040897
ID: 16648606
according to the test, it seems that the allow restricted agent is not selected in my email database.  I am testing it now.  Apparently, this setting is not by default on the mail6 template.
0
 
LVL 18

Expert Comment

by:marilyng
ID: 16653768
The default is #1- which is correct.   You should have on your local preferences, (File>>Preferences>>User Preferences>> Allow local scheduled agents should be enabled)

YOu can only enable your out of office agent on the server where the mail file is located.  If you use an administration ID to enable, then that ID must have a mail file on that server, or the server INI file has to have a parameter to bypass this localization.

Users must have permission to run the out of office agent on the server in the server doc.  So, if yours is the only one that doesn't work,and everyone else's out of office agent works, then it's your mail file.. replace the design.

Tell us what you've tried.
0
 

Author Comment

by:Enrique040897
ID: 16657708
The local preference setting was not enabled or checked.  I will perform some test.

The problem is with all the users.
0
 

Author Comment

by:Enrique040897
ID: 16708539
This is the result of the test.  No errors on the server nor in the client.  But the system does not send the e-mail to the sender. Please assist.

The following will occur when this agent is run:

'CN=Enrique Morales/O=My Org' has unrestricted rights to run LotusScript/Java agents on 'CN=My Server/O=My Org'.
Allow restricted operations flag is selected. Restriction operations will be allowed.
Full administrator rights will be granted on server 'CN=My Server/O=My Org'.
Agent scheduled to run on 'CN=My Server/O=My Org'.

Started running agent 'OutOfOffice|OutOfOffice' on 18/05/2006 09:23:09 a.m.
Running on new or modified documents: 5321 total
Found 5321 document(s) that match search criteria
Testing:  Ran LotusScript code
Done running agent 'OutOfOffice|OutOfOffice' on 18/05/2006 09:23:09 a.m.
0
 
LVL 18

Expert Comment

by:marilyng
ID: 16714325
Ok, so, now make note of the scheduled run times in the agent properties, i.e. when is it scheduled to run.  Then enable the out of office agent using the front end out of office agent tool.   Then, go back to view>>Agents  to see that it is enabled.    It should run every 6 hours between 4:00 AM and 12:00 AM.   So, start sending mail to this database before 10:00 AM, 4:00 PM, and 10:00 PM.

Then open the mail log (log.nsf) on the same server as the mailfile, and confirm the times when the mail arrived.  Then open the misc log for that day and time and do a search for "AMGR:"  and see what errors are being recorded, if any.

At 12:00 AM every day, AMGR logs statistics (unless you don't have agent statistics turned, I think) so you should see a list of Scheduled agents and errors for each.

Check these and let us know what results you get.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

For users on the Lotus Notes 8 Standard client, this article provides information on checking the Java Heap size and adjusting it to half of your system RAM in attempt to get the Lotus Notes 8.x Standard client to run faster.  I've had to exercise t…
You’ve got a lotus Domino web server, and you have been told that “leverage browser caching” is a must do. This means that we have to tell the browser everywhere in the web to use cache. In other words, we set (and send) an expiration date in the HT…
this video summaries big data hadoop online training demo (http://onlineitguru.com/big-data-hadoop-online-training-placement.html) , and covers basics in big data hadoop .
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an anti-spam), the admin…

809 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question