• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 184
  • Last Modified:

How Do You Make Windows Network Shares Invisible To Network Clients

Hello,

I havre some windows shares that I do not want to be visible to anyone.  I have not published them in the AD, yet they still show up to all PCs.  Please advise.  Thanks.
0
rstuemke
Asked:
rstuemke
1 Solution
 
pjedmondCommented:
I seem to remember that if you change the name of the share from say "SHARE" to "SHARE$"

then the share is not 'broadcast' in the same way, and will not appear by default in the network neighbourhood, although I suspect that this might be a client filtering issue rather than the share not being broadcast, because smbclient -L <hostname> still displays it.

Beyond that, I'm not aware of any options available with a windows share to compare with the samba 'browseable' directive.

HTH:)
0
 
Cyclops3590Commented:
pjedmond is exactly right,
by adding the dollar sign to the end of a share name, that will make it so it won't show up in listing on Windows clients ONLY
linux clients don't pay attention like that so they'll see all the shares regardless
0
 
rstuemkeAuthor Commented:
$ was the answer.  However, Fedora Core 5 ignored the share with a $ also.  Added bonus.  Thanks.
0

Featured Post

Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now