SCO Openserver 5.0.5 ftp user cannot see any files or cd out of his home directory

Posted on 2006-05-05
Last Modified: 2013-12-23
I have a system running SCO Openserver 5.0.5 and a user who needs to ftp some files from it to his Windows XP system.

From a command prompt on his XP system he can ftp to the SCO box, provide his user name/password & he lands in his home directory (/u/lem) but he is unable navigate out of (above) his home directory to get to the directory where the files he needs are located.  Also, once he connects to the server, if he types "ls" at the ftp prompt, it lists the files in his home directory, but if he types "dir" it lists nothing.  This seems strange.  If he does "pwd" at the ftp prompt it reports that the current directory is "/" although uploading a test file reveals that the file lands in /u/lem, as expected.
He wants to use ws-ftp as his ftp client, and testing it, it connects fine, but he is still "trapped" in his home directory and cannot, for example, cd to /u/source to retrieve files or even list the files that are there.  It also does not show any files in his home directory.   So when he tries "cd /u/source" it fails because there is no /u/source UNDER /u/lem.

The permissions on /u are drwxrwxrwx.  There is a /u/source directory.  Same permissions.

Connecting to the server as root of course all files & directories are visible & I can navigate up and down the directory tree with no problem.

I need him to be able to navigate up through the directory tree to find the files he needs, without giving him root access.

Thanks in advance for any help.
Question by:vancelxix
    LVL 61

    Accepted Solution

    This is chroot facility of FTP server.

    telnet to your server port 21 and type following commands:

    USER username
    PASS password

    And post responses.

    Author Comment

    Thanks for your response.  Actually, I've already solved this turned out that the user was a member of several groups, including "guests" so when he connected to the ftp server it treated him as a guest user instead of a real user.  I removed him from the guests group and everything is working as it should now.

    Even though I have solved this problem, in consideration of your taking the trouble to respond and attempt to help, I am going to accept your answer and award you the points.  Thanks.

    Featured Post

    Highfive + Dolby Voice = No More Audio Complaints!

    Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

    Join & Write a Comment

    Why Shell Scripting? Shell scripting is a powerful method of accessing UNIX systems and it is very flexible. Shell scripts are required when we want to execute a sequence of commands in Unix flavored operating systems. “Shell” is the command line i…
    #Citrix #Citrix Netscaler #HTTP Compression #Load Balance
    Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
    Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…

    730 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    17 Experts available now in Live!

    Get 1:1 Help Now