• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 522
  • Last Modified:

Windows Remote Desktop behind 2 Routers

I have a cable connection to a router on the 192.168.10.0 network and another router on that network with a subnet of 192.168.0.0. The PC i am trying to reach is on that subnet 192.168.0.25. How can i configure my routers to forward the Remote Dewsktop request to the proper LAN IP from the Internet.

I've tried a combination of port forwarding and DMZ zone but i cannot get to the PC successfully.

I am using a Linksys router and a Hawkings router.

BTW, i've used DynGate and Teamviewer to remotely access the PC from the internet, but this trial has a 30-min timeout.

Thanks
0
JNMarks
Asked:
JNMarks
  • 7
  • 6
  • 2
  • +3
1 Solution
 
Lee W, MVPTechnology and Business Process AdvisorCommented:
Why do you have two routers on the network?
0
 
Craig_200XCommented:
enable port forwarding port 3389 on all routers involved, make sure the computers are configured properly for RDC

Heres a full setup instruction guide for remote connection:

http://www.microsoft.com/windowsxp/using/networking/expert/northrup_03may16.mspx
0
 
Craig_200XCommented:
also being you are ROUTING between subnets.. (I assume you have different subnet masks) you have a static route to each subnet? can you ping the other machine? as Leew says why 2 routers-  does you network warrant the use of different subnets?
0
Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

 
JNMarksAuthor Commented:
i have two routers because the connection is shared. The main network 192.168.10.0 is used by another company, my subnet off of that network is where my PCs are.

I've tried port forwarding on both for port 3389 with no success.

The static routing i've lookied intoand tried, but was unsure about the config.

The IP addressing is as follows:
router1 WAN IP 24.229.196.xxx
router1 LAN IP 192.168.10.1
router2 WAN IP 192.168.10.5
router2 LAN IP 192.168.0.1
my PC IP 192.168.0.25

I can ping PCs on the 192.168.10.0 network successfully (e.g i can ping 192.168.10.10)
0
 
Craig_200XCommented:
from the web... are you trying to access the 24.229.196.xxx:3389 address (or the listening port configured...also if you are using a different listening port- is it port forwarded on both routers as well)?

can you setup rdp on another machine in the local subnet and access the .25 machine?

can you ping from the 10.0 subnet to your machine? if not you need a static route on the 10.1 router to point to the 10.5 router - and this could be one reason its not working.




0
 
JNMarksAuthor Commented:
from the remote desktop client i type in the 24.229.196.xxx address

Ive connected via RDP from a PC on the LAN 192.168.0.0 successfully.

and i cannot try to ping from the 10.0 to the 0.0 because i have no access to a pc on that LAN

What would the static route config be, i can web admin the router to setup/test this.
0
 
Craig_200XCommented:
"from the remote desktop client i type in the 24.229.196.xxx address"  -- do you add the port? otherwise it thinks your trying to connect on port 80....

"BTW, i've used DynGate and Teamviewer to remotely access the PC from the internet, but this trial has a 30-min timeout." -- if you are able to do this, the static route should not be an issue as it is crossing the first network to the second ok.....(I forgot about this.)


0
 
JNMarksAuthor Commented:
I'm not using the web interface, i'm using the built-in client, which by default uses port 3389. I will try the port on the end of the address to be sure.

I think TeamViewer works because DynGate somehow allows it to traverse the NAT.

I am also trying the static route.
0
 
brwwigginsCommented:
This may be a silly question but when you do the port forwarding on the first router do you forward to the IP address of the machine or the other router's WAN IP?
0
 
JNMarksAuthor Commented:
yes, I forward to the other router's WAN ip. The settings for port forwarding only allow me to forward to a 192.168.10.x address.

From there i port forward on the second router to the LAN IP of the PC.
0
 
JNMarksAuthor Commented:
Still having an issue with this, any comments welcome.
0
 
edkayCommented:
Hi there,

Just to add that I too am experiencing the same problem as JNMarks, but have been unable to find a solution? Could it be the Win Remote Desktop Connection cannot work over more than one port-forward?
0
 
Craig_200XCommented:
Edkay
no, it is possible..Im doing it here... but the difference is IM using one subnet ... still going across 2 routers... and it can be used across the internet, so this shouldnt be an issue.


JNMarks,

Can you use the web browser to connect? as the tutorial link I gave at the top instructs?


0
 
edkayCommented:
I've found out the problem with my setup. It was nothing to do with the routers, rather that Zone Alarm was blocking access. It worked internally as both local subnets were in it's trusted zones. Opening up port 3389 in it's config means it is all working fine now.
0
 
JNMarksAuthor Commented:
I tried by Ip and port number through web browser, and still didnt work

0
 
JNMarksAuthor Commented:
OK,

I got my Windows remote desktop to work....

I put Router 2 in Router 1's DMZ, then i port forwarded 3389 from Router 2 to the internal IP of my PC.

Now I can access My Desktop by the external IP of Router 1, no port number needed.

So I can finally sit down at home, open the Remote Desktop Client, type in the current External IP address of my office and get to work.

Thanks for all the suggestions, i'm sure they led me in the right direction!

-Joe
0
 
Craig_200XCommented:
Cool!.. glad you didnt give up!.. thanx for posting the solution too!
0
 
Computer101Commented:
PAQed with points refunded (500)

Computer101
EE Admin
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 7
  • 6
  • 2
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now