?
Solved

SMTP Connector for smarthost on Front-End Exchange 2000

Posted on 2006-05-05
14
Medium Priority
?
1,344 Views
Last Modified: 2008-01-09
I have a single Exchange 2000 front-end server and a single back-end server. The front-end Default SMTP Virtual Server has been configured to forward messages to a smart host. I am having problems with messages sitting in the queue(retry connection state). I would like to configure an SMTP Connector to forward all inbound messagesl to the smarthost and remove the smarthost configuration from the Default VS.

I have created the SMTP Connector as follows:
Forward all mail to smarthost [IP]
Local Bridgehead is back-end server
Address Space Type: SMTP
Address: Local domain
Outbound Security: Anonymous

The mail is still coming in through the Default SMTP Virtual Server instead of the SMTP Connector. Why is it not using the connector?
0
Comment
Question by:ncsc2006
  • 5
  • 4
  • 3
  • +1
14 Comments
 
LVL 18

Expert Comment

by:amaheshwari
ID: 16617217
What is the cost of this connector?
0
 
LVL 18

Expert Comment

by:amaheshwari
ID: 16617233
Please refer this article for solution:
http://support.microsoft.com/kb/265293
0
 
LVL 22

Expert Comment

by:kristinaw
ID: 16617335
you have to restart the routing engine and the smtp service before the new config will get picked up. Did you remove the smart host setting on the virtual server? it's best not to have smart hosts configured there anyways.

kris.
0
NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

 

Author Comment

by:ncsc2006
ID: 16617750
The cost of the connector is 1 and it is the only connector configured.  I did follow kb265293 to configure the SMTP Connector. I also rebooted the server after making the changes (changes included removing the smart host from the default VS). The address space is suppsoed to indicate my local domain if I only want the connector used for inbound mail, correct? All other outbound mail appears to be going straight from the back-end server to the Internet through it's Default VS.
0
 
LVL 22

Expert Comment

by:kristinaw
ID: 16617794
i'm a little confused about what you're trying to do. an smtp connector will always be for mail going out, not coming in. perhaps you can re-explain what it is you're trying to accomplish?

if you want all your mail to go to the smart host, then the address space should be *. setting your local domain in there will essentially have no effect as that mail will never be 'routed' to the connector, it will be delivered to the mailbox.

kris.
0
 
LVL 18

Expert Comment

by:amaheshwari
ID: 16617821
In smtp connector are you using smarthost in [Smart Host IP] bracket.
0
 
LVL 18

Expert Comment

by:amaheshwari
ID: 16617832
SMTP connector is outbound .
0
 

Author Comment

by:ncsc2006
ID: 16617885
Inbound mail is coming in to the front-end server, being fitered for SPAM by GFI and then delivered to the smarthost through the configuration of the smarthost entry in the Default SMTP Virtual Server on the front-end box. I have messages which intermittently pile up in the Default SMTP VS queue with a connection state of Retry. As you stated previously, It is best not to have smart hosts configured in the virtual server. I have read that the problem I am having can be resolved by creating an SMTP Connector and configuring the smart host there. If I place the asterisk (*) in the address space, the back-end server will route outbound mail back through the smart host as well. I do not want that. I want inbound mail to route to the smart host and outbound mail to go straight to the internet. Is this possible?  
0
 
LVL 22

Expert Comment

by:kristinaw
ID: 16617925
in the configuration you describe i don't understand why you need a connector or smart host entry at all. while i will admit i don't know GFI, this is not how any normal setup would work. have you tried not having any connector or any smart host configured on vs? this is how you would typically have something set up without GFI.

Kris.
0
 
LVL 18

Expert Comment

by:amaheshwari
ID: 16617926
You can not Use Smart Host for inbound mail.
0
 
LVL 104

Expert Comment

by:Sembee
ID: 16618227
What is the smart host being pointed at?
A server outside of your network?

If you just want email to go through the frontend server then you need to remove the smart host setting from the SMTP virtual server, and configure an SMTP Connector with the frontend server as the bridgehead. As long as both servers are in the same routing group then they will use the SMTP Connector.

Simon.
0
 

Author Comment

by:ncsc2006
ID: 16618518
Hi Simon, The smarthost is pointing at a server inside my network which scans mail for virus and then forwards to the back-end Exchange server. I will reconfigure the SMTP Connector with the frontend server as the bridgehead. Should the address space be (*) or the local domain?  
0
 
LVL 104

Accepted Solution

by:
Sembee earned 750 total points
ID: 16618583
An SMTP Connector deals exclusively with outbound email. Plays no part in inbound email.
Furthermore, as soon as the email hits the Exchange org, you cannot direct the email back out again for scanning.

Therefore your email flow for inbound email...

Internet ---> AV Scanner ---> Frontend Server ---> Backend Server.

Outbound email can probably go straight out.

The SMTP Connector needs to be * otherwise email will go straight out. You should have no smart host on any of the SMTP virtual servers (frontend or backend).

Simon.
0
 

Author Comment

by:ncsc2006
ID: 16618684
Well for the time being, it sounds as if I need to go back to the way it was already configured and let it limp along until I can find the right app to handle both AS and AV on the Front-End.
Right now, the config looks like this...
Internet --> AS Scanner (GFI) on Front-End with Default SMTP VS smarthost ---> AV Scanner ---> Back-End

This config does work (just not very well).
Sorr folks, I am awarding all points to Sembee as his answers helped me most.
0

Featured Post

NFR key for Veeam Agent for Linux

Veeam is happy to provide a free NFR license for one year.  It allows for the non‑production use and valid for five workstations and two servers. Veeam Agent for Linux is a simple backup tool for your Linux installations, both on‑premises and in the public cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Eseutil Hard Recovery is part of exchange tool and ensures Exchange mailbox data recovery when mailbox gets corrupt due to some problem on Exchange server.
There can be many situations demanding the conversion of Outlook OST files to PST format and as such, there is no shortage of automated tools to perform this conversion. However, what makes Stellar OST to PST converter stand above the rest? Let us e…
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…
This video discusses moving either the default database or any database to a new volume.
Suggested Courses
Course of the Month15 days, 19 hours left to enroll

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question