Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 183
  • Last Modified:

Publish Free/Busy Times to Intenet Location OL2003

Hi all

I have followed instructions on publishing my IFB times to my server. I use the following addresses

ftp://ID:password@myserver.com/public_ftp/incoming/name.vfb

ftp://ID:password@myserver.com/public_ftp/incoming/%NAME%.vfb

for my Publish and Search locations respectively.

To test I have set my publish time to 1 minute. I have closed and reopened Outlook. I have shut down and restarted my PC. But try as I may nothing seems to be published where I am asking. I know my ftp security details are correct.

Can anyone please tell me what I am doing wrong or what I am not doing?

cheers

Verdy
0
verdante
Asked:
verdante
  • 8
  • 7
1 Solution
 
David LeeCommented:
Greetings, verdante.

Are these the instructions you followed?  http://support.microsoft.com/?kbid=291621

Cheers!
0
 
verdanteAuthor Commented:
I tried but got stuck at the point where the instructions say:

Note For FTP servers that require authentication, you must follow these steps to configure the FTP site in Outlook:
1. Start Outlook.
2. On the File menu, click Open, and then click Outlook Data File.
3. In the Look in box, select Add/Modify FTP Locations.  


I couldn't find a 'Look in' box. So I went back to the top of the page and found the instructions are for OL2002.  Given that I have already provided an FTP address in my Free/Busy Times setup I'm not sure whether I need to register the FTP address in another location or not - and if so - how!

cheers

Verdy
0
 
David LeeCommented:
I'm on 2003 also.  The "Look in" box, really a pulldown, is at the top of the dialog-box.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
verdanteAuthor Commented:
Thanks BDF, I'm sure I'm being dumb but I'm not exactly with you. In my OL2003 view I have the menu bar and underneath it my toolbars. Underneath that I have my mail folders on the left and the expanded view of the selected folder on the right.

Where does the "Look in" box or pulldown exist in relation to this layout?

cheers

Verdy
0
 
David LeeCommented:
When you click File->Open->Outlook Data File a dialog-box titled "Open Outlook Data File" pops up.  Look right below the word "Outlook" in the dialog-box's title and you'll see "Look-in".  TO the right of it is a combobox.
0
 
verdanteAuthor Commented:
Yes OK I was being dumb. Interestingly enough the ftp site was listed in the locations. I have ensured the site details are correct but I still have had no luck with publishing a .vfb file.  

I'm a little confused about the ftp location. When I visit my site through ftp I use the following location ftp://myid:mypassword@myserver.com. That puts me in the root folder. From here I can navigate through the site's folders. There is a folder in the root folder called public_ftp and a folder under it called incoming (as shown in my original posting). I originally nominated this as my .vfb destination. However when I register a ftp location in Outlook I can only nominate the domain name (ie no subfolders). Does Outlook know how to resolve this apparent difference? As a trial I have modified my IFB file location to be in the root folder. This has not made any difference. My file is still not publishing.

Where to?

cheers
Verdy
0
 
David LeeCommented:
Hi, Verdy.

First off, forget about the article I linked to earlier.  This is the correct guidance for 2003: http://office.microsoft.com/en-gb/assistance/HA011959481033.aspx

It took several trys before I was successful, but I finally published.  The key seems to be determining how to present both the username and the ftp path to Outlook.  I was finally successful with this:

ftp://username:password@ftp.mindspring.com/freebusy/%name%.vfb

Once I figured out what to pass for the username and took off the portion of the path to my personal area I was successful.  
0
 
verdanteAuthor Commented:
Hey BDF

That was a great URL you sent.
I modified my IFB details; specified a local file location; and used the Update Send/Receive Free/Busy Information to make sure I had the thing working. I managed to publish a file of 2 bytes. Then I tried to publish on my website. I tried in two directories where I believe my ftp account has write privileges. As it happened I wrote the file but it was 0 bytes in length. I received a 'write' error using the test method.

I can write to these locations using my ftp account through IE, so I don't believe it is a permissions issue. Any ideas what might be going wrong?

cheers

Verdy
0
 
David LeeCommented:
> I  can write to these locations using my ftp account through IE
That's the same problem I was experiencing when I was testing.  I could write from other apps, but Outlook kept giving errors.  In my case the username that worked is a trimmed down version of the username I normally have to pass and the location portion I had to use is only part of the actual URL.  Are you publishing to an ISP internet location or to a spot on a web server you own?
0
 
verdanteAuthor Commented:
Hi

I've experimented with several locations. The following location publishes the vfb file in the apropriate folder but it is still 0 bytes.

ftp://ID:PW@ftp.healthinnovators.com.au/public_ftp/incoming/%name%.vfb

As far as username in concerned are you referring to the email username or ftp username? I am using my main ftp account name. I am handling the email account name with the convention comtained in your earlier comment.

What was the logic you applied in trimming down the username and location?

Verdy
0
 
David LeeCommented:
> What was the logic you applied in trimming down the username and location?
It wasn't logic as much as trial and error.  Like you I tried connecting from IE and then used the same address line in Outlook.  That didn't work, so I started trying different variations until I found the one that worked.  During that process I also tried using the www version that Microsoft article shows in its example.  
0
 
verdanteAuthor Commented:
I have tested several different location options. I can't get anything to work using www. I have managed to publish a file and not get an error message. However the file is still 0 bytes. It also takes forever to deliver the 'success' message.

I have seen a posting in another forum on transfer method suggesting that I would need to use FTP in PASV mode. Could this be a difference between your success and mine?

cheers

Verdy

PS I've upped the points to reflect the complexity of the problem
0
 
David LeeCommented:
Verdy,

Any progress?  
0
 
verdanteAuthor Commented:
BDF
I'm sure you have given up on me by now but I was having significant problems with the website I was using. I have since attempted this on a different website and it worked! I'm not sure what the difference was. I tried the same syntax I was using on the first site???

Anyway thx for your help

Verdy
0
 
David LeeCommented:
No problem, Verdy.  Glad to hear you got it working.
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

  • 8
  • 7
Tackle projects and never again get stuck behind a technical roadblock.
Join Now