Backup Failed

Posted on 2006-05-05
Last Modified: 2013-12-01

It's been already a week that my backup is failing every single days.
Nothing has change on my server .
I have search online for the error but with no success.
The error that I get is the following:
Final error: 0x45d - The request could not be performed because of an I/O device error.

I have cleaned the tape drive already 4 times and I still get the error.

I have veritas Backup exec 9.1 Rev. 4691
Windows 2003
Nothing has changed on the server since last good backup
Does anyone know where it is coming from?

Question by:taverny
    LVL 39

    Assisted Solution

    The link below is some explaination regarding the error code. Please just follow recommends see if it helps you.

    Author Comment

    Thanks for your reply ,

    I will check the link in the morning, I will post some comments
    LVL 44

    Expert Comment

    Why not try ERASING the tapes before a backup?
    This is a setting in the backup scheme, click the checkbox -- erase tape before backup/
    You see BUexec has a flaw that it wont write correctly to tapes with data on them.
    The way to get around this is ALWAYS erase before a backup.
    Sure it is silly and should not need to be done, but that is BU exec for you.
    LVL 5

    Expert Comment

    I would also suggest using a cleaning cartridge for your tape drive.  They recommend cleaning the drive once a week if the tape drive is used more than 1 hour each day, or once a month if the drive is used less than 1 hours each day.  They also recommend cleaning the drive after the first time you use a brand new tape.  I know it seems like a lot, but regular cleaning has helped me with a Travan-40 tape drive in the past

    (Taken the above information from the link:
    LVL 10

    Accepted Solution

    Hi there, an I/O device error has many cause's in Backup Exec but the most common solution I have found to resolve this issue is to replace the SCSI cable and Terminator that is connecting the backup drive to the SCSI controller. You could first try to just reboot the server though if you haven't tried that already.

    Also, if neither of the above resolve the problem, you could try updating the firmware in your tape drive - you should find instructions for how to do this on the drive manufacturer's website. Make sure that you try the backup job with a brand new tape as well just to rule out any issues with media.

    I agree with scrathcyboy on the issue of Backup Exec having a problem with overwriting tapes but as far as I recall,  version 9.1 doesn't have an 'erase tape before backup' checkbox, you need to edit your media set instead to allow the job to overwrite the tapes, here's how to edit the media set:

    Click on the "Media" tab
    Go to "Media Sets"
    Right click on the Media Set you are using and go to "Properties"
    Assign the Overwrite Protection accordingly. - You may need to assign the overwrite protect to the smallest amount of time - such as 1 hour.

    Hope this helps!
    LVL 9

    Assisted Solution

    BE doesn't have a problem overwriting tapes but this isn't an overwrite problem anyway. Quite possible it is the SCSI cable but it is as likely to be a faulty drive. Could be worn out media. Look at the statistics under the drive and also the individual media, tell us how many soft and hard errors there are and as previously suggested run manufacturer's diagnostics on the drive. It would help if you told us what type of drive it is.

    Cleaning the tape 4 times isn't a good idea although you might want to clean it a single time with a new cleaning cartridge, they have a limited life. I'm also wondering who "they" are in "They recommend cleaning the drive once a week if the tape drive is used more than 1 hour each day", possibly the recommendation is from some company that makes its money from replacing heads worn out by over cleaning. Someone recommended to me to clean my car with T-Cut every week and for the first year it was always a shiny red colour, it's still shiny now but rather than red it's now shiny steel color :(

    Author Comment

    Hi Everyone,

    First of all , thanks for all your post.

    I have tried to erase the tape and then do a backup , I still get an error . I also tried with 2 new tapes and I get the same problem.
    sometimes it fails after 4 hours and sometimes it fails after 2 min.
    I did defrag the harddrive.
    Also, I am not really familiar with the Windows Error Checking Utility , so I went under the properties of the disk and run an error checking on it. and Everything was fine.

    I did reboot the server but still with no success.
    The tape drive is a SuperDLT1 Firmware: V085/CPQ-2
    The server is a HP ML370 G3

    The stats for the Media are :
    Seek errors:    0
    Soft read Errors:  197
    Hard read Errors: 0
    Soft write errors: 326260
    Hard write errors: 5

    The stats for the drive
    Seek errors:    0
    Soft read Errors:  2315
    Hard read Errors: 0
    Soft write errors: 109588
    Hard write errors: 20

    I will try this evening, after business hours,  to replace the scsii cable.

    I really hope this will work. Let me know if you want me to try anything else.
    Thanks again for all your help guys.

    Author Comment

    Hi everyone,

    Ok, I opened the server to replace the cable, but the one that I had was too short. So I had to used the same one, I unplugged it and plugged it back into a different empty connector;
    And now it’s been working fine, my backup has been successful 3 days in the row.

    So, I am not sure if the cable was loose, but now it’s working fine again.  

    I would like to thank everyone for your help.

    Featured Post

    IT, Stop Being Called Into Every Meeting

    Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

    Join & Write a Comment

    I previously wrote an article addressing the use of UBCD4WIN and SARDU. All are great, but I have always been an advocate of SARDU. Recently it was suggested that I go back and take a look at Easy2Boot in comparison.
    The Delta outage: 650 cancelled flights, more than 1200 delayed flights, thousands of frustrated customers, tens of millions of dollars in damages – plus untold reputational damage to one of the world’s most trusted airlines. All due to a catastroph…
    This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…
    This tutorial will walk an individual through the process of installing of Data Protection Manager on a server running Windows Server 2012 R2, including the prerequisites. Microsoft .Net 3.5 is required. To install this feature, go to Server Manager…

    745 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    15 Experts available now in Live!

    Get 1:1 Help Now