[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 8577
  • Last Modified:

DHCPD authoritative

Dear Experts,

I have a problem..... I config the DHCPD as the following:-


       ddns-update-style ad-hoc;

subnet 192.168.0.0 netmask 255.255.248.0
{
        option routers                  192.168.1.2;
        option subnet-mask              255.255.248.0;

        option domain-name-servers      192.168.1.4;
        option domain-name-servers      192.168.1.5;
        option domain-name-servers      212.0.159.66;

        authoritative;
        range 192.168.4.1 192.168.5.254;
        default-lease-time 21600;
        max-lease-time 43200;
}

But I still get below messege in log file?????

necfw dhcpd: DHCPINFORM from 192.168.1.47 via eth0: not authoritative for subnet 192.168.0.0

Can you plz help.

Osama
0
princeofsudan
Asked:
princeofsudan
  • 3
  • 3
1 Solution
 
Cyclops3590Commented:
make this the first line of your config

authoritative;
0
 
DonConsolioCommented:
verify the subnet mask on eth0 - is it 255.255.0.0 or is it 255.255.248.0 ?
dhcp range and your interface should be in the same subnet.
0
 
princeofsudanAuthor Commented:
I did...it is same range.... but still no thing!!
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
Cyclops3590Commented:
please post your dhcpd.conf file,

prince, you did try my suggestion, right?
0
 
princeofsudanAuthor Commented:
I did..... find below my config file


        ddns-update-style ad-hoc;
        authoritative;
#       boot-unknown-clients false;



subnet 192.168.0.0 netmask 255.255.248.0
{
        option routers                  192.168.1.2;
        option subnet-mask              255.255.248.0;

        option domain-name-servers      192.168.1.4;
        option domain-name-servers      192.168.1.5;
        option domain-name-servers      212.0.159.66;

        range 192.168.4.1 192.168.5.254;
        default-lease-time 21600;
        max-lease-time 43200;

}
0
 
Cyclops3590Commented:
i can't believe it makes that much of a difference, but everywhere I've read says put the authoritative line at the top.
Can you switch those two lines and restart dhcpd just to make sure.
0
 
princeofsudanAuthor Commented:
it is work !!!!

:S

one line up....... is that make sense ???

Any way..it is working.

Thanks for help.
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now