How do you unlock a SATA Drive

I pulled 24 SATA Hard Drives from our Fileserver (WD2500JD) they were connected to 2 X 3ware SATA raids controllers (3ware 9000 series). I replaced the 24 250GB drives with 24 500GB drives. The raid is up and operational with the new 500GB drives and is in production.

My problem is with the remaining 250GB SATA hard drives. I intended to reuse them in our linux and windows PC workstations.  When I intall one in a linux machine it ask for a password to unlock the drive.
On windows systems, it see them but will not allow access. I cannot format these drive.
It appears that the 3ware raid controller locked the drives to prevent them from being over written.
I can not replace them into the fileserver with the raid cards, due to it is in production.

Has anyone been succesfull in unlocking and formating SATA's that have been locked by 3ware controllers?

LVL 2
Ryan RowleyAsked:
Who is Participating?
 
CetusMODCommented:
PAQed with points refunded (500)

CetusMOD
Community Support Moderator
0
 
ridCommented:
HD passwords are almost impossible to get around (in normal circumstances). Try hooking them back up to the old controller and see if you can reset them. Otherwise, get new drives. If they are PW protected, it's a lost case unless, of course, you know the PW.

There are several threads here about this sort of problem. If I understood them correctly, it is a combination of firmware instructions and info on the platters themselves (in sectors that are inaccessible to the user). You can't format or zero-fill these passwords away, you won't be helped by a new logic board for the HD - you need the PW.
/RID
0
 
Visual3DMayaCommented:
As i know, a total wipe of the first track will erase the lock data. (as i know)
So fill 00H in the first sectors, in phizical mode, and it's like new.
Norton Diskedit or WD formatting program should do that.
I'm here if i can help...
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
Gary CaseRetiredCommented:
If these are ATA-secure drives, you're out of luck, but I don't believe WD2500JD's are.   I think they simply have traditional passwords protecting the data -- in which case a complete wipe of the drive will eliminate them.  

Run dban (http://dban.sourceforge.net/) on one of the drives and see if it helps.   I believe that will resolve this -- if so you can simply run it against all of the other drives as well.
0
 
ridCommented:
If the HD is locked with a HD password, you can't do any write operations - not even wipe the first sectors. In this case it might be something else, as suggested, on a higher level and the software suggested might do the trick.
/RID
0
 
scrathcyboyCommented:
If the controller wrote to the FIRMWARE on the drive (i.e. the PCB board BIOS under the drive platters) you will HAVE to put it back on the controller to get it unlocked.  If it did not write to the PCB BIOS firmware, then a low level format utility made by the drive Mfg will work, but it all depends on how the RAID controller wrote to the drives.  If it did a PCB firmware write, you might email the controller maker, they may have an easier fix than reattaching to the controller.  Keep in mind, anyone locking anyone out of hardware is under legal liability for "theft of user equipment", so if they really did this, they are OBLIGED to help you -- else report them to the FTC for theft of hardware value.
0
 
computerfixinsCommented:
If its a true sata lock then most manfacturers have a "master" password for situations like this.  
0
 
Ryan RowleyAuthor Commented:
3ware made a number of suggestions.
I was able to replace the drive in the correct order on the 3ware 9500S-12 controller card from which the came.
They suggested that once I got them back onto the controller I would be able to delete the raid, then turn the disks into JBODs. I would then be able to remove them and use them any way I pleased.

I attempted to perform this operation with no success. The raid controller refuses to delete the raid.

3ware's other suggestion was to install the drives onto a 3ware 8500 series controller and run a program of thiers that will unlock them. This program will ignore all other controllers except the 8500 series. The problem with this plan is that all of my 3ware controllers are from the 9500 series. I do not have any 8500 series cards.

I have tried Western Digital's utilities to low level or return drive to factory defaults with no success. This lock must have been written to the drives firmware.

3ware says that they lock the drives to prevent you from accidentally overwriting your disk.
Perhaps they are holding my disk hostage so that I will have to buy more of their controllers. :(

0
 
Ryan RowleyAuthor Commented:
I have successfully unlocked the drives.
I did it by doing something I wanted to avoid doing. I bought a older 3ware 8506 controller and ran the software 3ware supplied.

Now I have a older controller that has only one purpose, to unlock drives that the 9500 controllers locked and I spent my own cash to do it. :(

None of the previous suggestions from others worked in this situation. So, I'm not sure on how to point this.

I was hoping for a solution that didn't need another 8500 series controller. The solution I used just made 3ware a little cash and took a little cash out of my pocket. :(

Not a happy camper here. :(
0
 
Gary CaseRetiredCommented:
Since you solved this yourself you can simply post a note in Community Support and ask that the question be closed and your points refunded.   ... I wouldn't be too happy with 3Ware either :-)
0
 
NightOpsCommented:
Note: 3Ware now has clarified that there is another available option, which seems somewhat obscure:

In the 3DM or CLI utilities, configure the drive as a Single Disk.  Then you can remove the drive and attach it to any other controller.  I had the same problem with a 9500S-4LP and a 1TB ES.2 drive.  Following those steps, I was able to move the drive to a new system and use the onboard SATA ICH107R controller with the drive just fine.

From http://tweakers.net/reviews/557/7/comparison-of-nine-serial-ata-raid-5-adapters-pagina-7.html
"A very irritating feature of the Escalade 9500S-8, which nagged us horribly during testing, was the habit of this adapter to lock hard disks, as a result of which they could no longer be used by other controllers. There are two ways to make the hard disk accessible for other controllers. The first way is to reconnect the drive to the Escalade 9500 and configure the drive as a single disk in the management tool. The second method of unlocking the drive is by using the obscure hotkey -r in the management tool."
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.