• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2198
  • Last Modified:

Changing a port forwarding setting in Redhat 9.0

I have a linux Redhat 9.0 box running as a firewall on predominantly Windows network. The company that setup the router used port 81 to be forwarded to the internal firewall IP address to allow for a webadmin gui to be used through internet explorer. A recent new banking software requires port 81 be forwarded through the firewall for their software to function properly so I need instruction on how to change the webmin software to use a different port other than 81 so that I can then allow port 81 to pass through the firewall for the software. Need this changed in the next day or so in order for banking issues to take place this week.
  • 3
1 Solution
Gabriel OrozcoSolution ArchitectCommented:
Changing the Webmin Port from the Command Line

Another problem after installation may be that a firewall prevents access to the Webmin port from across a WAN link (if, for example, you are remotely maintaining your Webmin server). If this is the case, you will want to consult with the firewall administrator to find out whether port 10000 can be opened, or if not, what port you can use for your Webmin installation. Changing the port on which Webmin runs after installation is also a pretty simple process. Simply edit the file miniserv.conf in the /etc directory where your Webmin configuration files were installed (this is likely one of the following: /etc/webmin, /usr/local/webmin/etc, or /opt/webmin/etc). You'll find a port directive. Change this to whatever port you need Webmin to listen on, and then restart the Webmin web server.

so change
port 81

port 10000

which is the standard webmin port
You can set up the port that webmin listens to in Webmin Configuration -> Port and Address.

But is the webmin running on port 81 or is the port 81 redirected to webmin?

You can change the port forwarding settings in Linux Firewall module in webmin (if you have it installed). Otherwise you must change the iptables settings manually - a common place to do this is to edit /etc/sysconfig/iptables file.
kingsvilleAuthor Commented:
I am a Linux newbie so please bear with me here - Logging into the firewall from internal address - I have the option of entering the internal IP address:81 or IP address:10000 - I get prompted to login in with root and required pw. The :81 page allows me to look at things like syswatch log files, look at port forwarding rules already in place, open ports, running services and allow for shutdown or restart through the GUI rather than command line. This is the page I need to go to another available port so that 81 can be used for banking software. I am thinking I need to do this through command line as I have nothing that I can see in the GUI for Webadmin Configuration under the :81 site. I will look in the :10000 site to see if it is there.
Gabriel OrozcoSolution ArchitectCommented:
okay, put here the output of

iptables -L -vn | grep 81

and of

iptables -L -vn -t nat | grep 81

I suspect you have both: usermin and webmin since you tell us they are different. so also put here the output of

ps -aux | grep min

Gabriel OrozcoSolution ArchitectCommented:
any news?

Featured Post


Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now