[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Can't ping from the router but can from the switch

Posted on 2006-05-08
7
Medium Priority
?
779 Views
Last Modified: 2008-01-09
Ok guys a little help here....i have had to do some odd design here to make things work and i am close but need some help......

i have a device that i can ping from the switch but not from the router.....i will put the switch config first then the router ........you you see anything please let me know.....thanks


BTW the device i need to ping is off of VLAN 199 on the switch...

thanks again


______________________________________________________________________________________________
Switch Config

sh run
Building configuration...

Current configuration : 3678 bytes
!
! Last configuration change at 14:44:21 UTC Mon May 8 2006 by ncte
! NVRAM config last updated at 14:32:35 UTC Mon May 8 2006 by ncte
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname _3550
!
aaa new-model
aaa authentication login default group radius local
aaa accounting exec default start-stop group radius
aaa accounting network default start-stop group radius
enable password 7 120E074605120F067964373F3A21211B
!
username password 7 045C0E071D734016
ip subnet-zero
ip dhcp excluded-address 192.168.206.0 192.168.206.15
!
ip dhcp pool PNW_Unclass
   network 192.168.206.0 255.255.255.0
   next-server 192.168.100.131
   default-router 192.168.206.1
!
no ip domain-lookup
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
interface FastEthernet0/1
 description Lantronix Console Server
 switchport mode dynamic desirable
!
interface FastEthernet0/2
 description Unclass laptop
 switchport mode dynamic desirable
!
interface FastEthernet0/3
 description ASX
 switchport mode dynamic desirable
!
interface FastEthernet0/4
 switchport mode dynamic desirable
!
interface FastEthernet0/5
 switchport mode dynamic desirable
!
interface FastEthernet0/6
 switchport mode dynamic desirable
!
interface FastEthernet0/7
 switchport mode dynamic desirable
!
interface FastEthernet0/8
 switchport mode dynamic desirable
!
interface FastEthernet0/9
 switchport mode dynamic desirable
!
interface FastEthernet0/10
 switchport mode dynamic desirable
!
interface FastEthernet0/11
 switchport mode dynamic desirable
!
interface FastEthernet0/12
 description Trunk to 3745
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,199
 switchport mode trunk
!
interface FastEthernet0/13
 description
 switchport access vlan 199
 switchport mode dynamic desirable
!
interface FastEthernet0/14
 description
 switchport access vlan 199
 switchport mode dynamic desirable
 speed 10
 duplex half
!
interface FastEthernet0/15
 switchport access vlan 199
 switchport mode dynamic desirable
!
interface FastEthernet0/16
 switchport access vlan 199
 switchport mode dynamic desirable
!
interface FastEthernet0/17
 switchport access vlan 199
 switchport mode dynamic desirable
!
interface FastEthernet0/18
 switchport access vlan 199
 switchport mode dynamic desirable
!
interface FastEthernet0/19
 switchport access vlan 199
 switchport mode dynamic desirable
!
interface FastEthernet0/20
 switchport access vlan 199
 switchport mode dynamic desirable
!
interface FastEthernet0/21
 switchport access vlan 199
 switchport mode dynamic desirable
!
interface FastEthernet0/22
 switchport access vlan 199
 switchport mode dynamic desirable
!
interface FastEthernet0/23
 switchport access vlan 199
 switchport mode dynamic desirable
!
interface FastEthernet0/24
 description Trunk to ASX
 switchport access vlan 199
 switchport mode dynamic desirable
!
interface GigabitEthernet0/1
 switchport mode dynamic desirable
 shutdown
!
interface GigabitEthernet0/2
 switchport mode dynamic desirable
 shutdown
!
interface Vlan1
 ip address 192.168.206.2 255.255.255.0
!
interface Vlan199
 ip address 205.67.230.201 255.0.0.0
!
ip default-gateway 192.168.206.1
ip classless
ip route 205.67.230.0 255.255.255.0 192.168.206.1
ip http server
!
logging 192.168.206.9
snmp-server community pub RO
snmp-server host 192.168.206.9 1
!
line con 0
 password 7 0826494F1B4B094F
line vty 0 4
 password 7 10490C1817451E53
line vty 5 15
 password 7 0114030549590A57
!
ntp clock-period 17180223
ntp server 192.168.100.3 prefer
ntp server 192.168.204.7
!
end
-----------------------------------------------------------------------------------------
router config

Current configuration : 5235 bytes
!
version 12.3
service nagle
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname 3745
!
boot-start-marker
boot-end-marker
!
no logging buffered
enable secret 5 $1$/B5L$WsrsO7mdU/ZrNMOuCZRpD.
enable password 7 04080D020B28641C59
!
username password 7 0826494F1B4B094F
no network-clock-participate slot 1
no network-clock-participate slot 2
no network-clock-participate slot 3
no network-clock-participate slot 4
no network-clock-participate wic 0
no network-clock-participate wic 1
no network-clock-participate wic 2
no network-clock-participate aim 0
no network-clock-participate aim 1
aaa new-model
!
!
aaa authentication login default group radius local
aaa accounting exec default start-stop group radius
aaa accounting network default start-stop group radius
aaa session-id common
ip subnet-zero
!
!
no ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
bridge irb
!
!
!
interface FastEthernet0/0
 no ip address
 ip mtu 1430
 no ip route-cache
 duplex auto
 speed auto
!
interface FastEthernet0/0.1
 encapsulation dot1Q 1 native
 ip address 192.168.206.1 255.255.255.0
 no ip route-cache
!
interface FastEthernet0/0.199
 encapsulation dot1Q 199
 no ip route-cache
 bridge-group 2
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface ATM1/0
 no ip address
 no atm ilmi-keepalive
 pvc 0/5 qsaal
 !
 pvc 0/16 ilmi
 !
!
interface ATM1/0.148 point-to-point
 description
 ip address 192.168.200.22 255.255.255.252
 pvc 0/148
  protocol ip 192.168.200.21 broadcast
  ubr 1400
  encapsulation aal5snap
 !
!
interface ATM1/0.153 point-to-point
 description link
 bridge-group 2
 pvc 0/153
  ubr 6200
  encapsulation aal5snap
 !
!
interface FastEthernet4/0
 no ip address
 shutdown
!
interface FastEthernet4/1
 no ip address
 shutdown
!
interface FastEthernet4/2
 no ip address
 shutdown
!
interface FastEthernet4/3
 no ip address
 shutdown
!
interface FastEthernet4/4
 no ip address
 shutdown
!
interface FastEthernet4/5
 no ip address
 shutdown
!
interface FastEthernet4/6
 no ip address
 shutdown
!
interface FastEthernet4/7
 no ip address
 shutdown
!
interface FastEthernet4/8
 no ip address
 shutdown
!
interface FastEthernet4/9
 no ip address
 shutdown
!
interface FastEthernet4/10
 no ip address
 shutdown
!
interface FastEthernet4/11
 no ip address
 shutdown
!
interface FastEthernet4/12
 no ip address
 shutdown
!
interface FastEthernet4/13
 no ip address
 shutdown
!
interface FastEthernet4/14
 no ip address
 shutdown
!
interface FastEthernet4/15
 no ip address
 shutdown
!
interface FastEthernet4/16
 no ip address
 shutdown
!
interface FastEthernet4/17
 no ip address
 shutdown
!
interface FastEthernet4/18
 no ip address
 shutdown
!
interface FastEthernet4/19
 no ip address
 shutdown
!
interface FastEthernet4/20
 no ip address
 shutdown
!
interface FastEthernet4/21
 no ip address
 shutdown
!
interface FastEthernet4/22
 no ip address
 shutdown
!
interface FastEthernet4/23
 no ip address
 shutdown
!
interface FastEthernet4/24
 no ip address
 shutdown
!
interface FastEthernet4/25
 no ip address
 shutdown
!
interface FastEthernet4/26
 no ip address
 shutdown
!
interface FastEthernet4/27
 no ip address
 shutdown
!
interface FastEthernet4/28
 no ip address
 shutdown
!
interface FastEthernet4/29
 no ip address
 shutdown
!
interface FastEthernet4/30
 no ip address
 shutdown
!
interface FastEthernet4/31
 no ip address
 shutdown
!
interface FastEthernet4/32
 no ip address
 shutdown
!
interface FastEthernet4/33
 no ip address
 shutdown
!
interface FastEthernet4/34
 no ip address
 shutdown
!
interface FastEthernet4/35
 no ip address
 shutdown
!
interface GigabitEthernet4/0
 no ip address
 shutdown
!
interface GigabitEthernet4/1
 no ip address
 shutdown
!
interface BVI2
 mtu 1430
 ip address 205.67.230.200 255.0.0.0
 ip directed-broadcast
!
interface Vlan1
 no ip address
!
ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.200.21
ip route 192.168.206.0 255.255.255.0 Null0 254
!
!
logging 192.168.206.9
access-list 10 remark UNCLASS VTY ACL
access-list 10 permit 192.168.1.0 0.0.0.255
access-list 10 permit 192.168.100.0 0.0.0.255
access-list 10 permit 192.168.200.0 0.0.0.255
access-list 10 permit 192.168.203.0 0.0.0.255
access-list 10 permit 192.168.204.0 0.0.0.255
access-list 10 permit 192.168.205.0 0.0.0.255
access-list 10 permit 192.168.206.0 0.0.0.255
access-list 10 permit 192.168.207.0 0.0.0.255
access-list 10 permit 192.168.208.0 0.0.0.255
access-list 10 permit 192.168.209.0 0.0.0.255
access-list 10 permit 140.32.68.0 0.0.0.255
!
snmp-server community pub RO
snmp-server enable traps tty
snmp-server host 192.168.206.9 1
!
radius-server retransmit 0
radius-server timeout 1
bridge 2 protocol ieee
bridge 2 route ip
!
!
!
!
!
!
line con 0
 password 7 045C0E071D734016
 logging synchronous
 transport preferred all
 transport output all
line aux 0
 transport preferred all
 transport output all
line vty 0 4
 session-timeout 30
 access-class 10 in
 exec-timeout 30 0
 password 7 0114030549590A57
 transport preferred all
 transport input all
 transport output all
!
ntp server 192.168.100.3 prefer
ntp server 192.168.204.7
!
end

0
Comment
Question by:mcguires13
  • 3
  • 3
7 Comments
 
LVL 4

Expert Comment

by:CKWT
ID: 16631633
interface Vlan199
 ip address 205.67.230.201 255.0.0.0

ip default-gateway 192.168.206.1
**ip route 205.67.230.0 255.255.255.0 192.168.206.1**

ip route= when you ping 206.67.230.x device it will go to 192.168.206.1

BTW what is 192.168.206.1?

adding a proper routing rule on both would probably work

take out the iproute to test and make changes accordingly..

Hope to help

CKWT

0
 
LVL 4

Assisted Solution

by:CKWT
CKWT earned 750 total points
ID: 16631666
sorry I just looked back at your post, it was so long**

I was pretty close, you need to add the ip route rule to router

ip route 205.67.230.0 255.255.255.0 **switch**

Your are forwarding from switch to router.. so the switch sends back 192.168.201.1 when it receives a request...

Router---switch---VLAN199
ping?? it wouldn know where to go...

hope I make anysense..

CKWT
0
 

Author Comment

by:mcguires13
ID: 16631904
i tried that but that does not get it done.....also if you look those intfaces are bridging on the router not routing......although i was still thinking along the same line as you....it does not look like the router is getting everything from the switch since the switch can ping and not the router...on you first question the router is the .1

thanks
0
Get quick recovery of individual SharePoint items

Free tool – Veeam Explorer for Microsoft SharePoint, enables fast, easy restores of SharePoint sites, documents, libraries and lists — all with no agents to manage and no additional licenses to buy.

 
LVL 9

Accepted Solution

by:
kfullarton earned 750 total points
ID: 16632712
Try using a vlan interface instead of the BVI interface with ip 205.67.230.200.  Or add the ip address to interface FastEthernet0/0.199.  You don't need a route statement as the network is directly connected.  You should be able to see that by doing a "sh ip route".

Another thing to check is to make sure that the client's default gateway is the router and not the switch.
0
 

Author Comment

by:mcguires13
ID: 16632803
I'm with you i have done that as well ....here's the thing from the router I can ping the vlan on the switch from the router so there is a path from the switch to the router over that subnet so i just don't get it....i could staticly route it but i should not have to do that and i want it to bridge not route........

it's a long day
0
 

Author Comment

by:mcguires13
ID: 16636428
ok i almost don't want to put this down...it seems we were all on the same page with the troubleshooting steps....but in the end 3 commands....

conf t

ip routing

can you believe it.....
0
 
LVL 4

Expert Comment

by:CKWT
ID: 16636442
sure can...
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article is in regards to the Cisco QSFP-4SFP10G-CU1M cables, which are designed to uplink/downlink 40GB ports to 10GB SFP ports. I recently experienced this and found very little configuration documentation on how these are supposed to be confi…
This month, Experts Exchange’s free Course of the Month is focused on CompTIA IT Fundamentals.
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…

834 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question