• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 323
  • Last Modified:

Allocate Cache to CD/DVD drive?

I have a good decent laptop 2GHz, 700MB memory, and a puny 30 GBhdd.  The only problem I am having with it is that I am trying to run a series of video training in the cd/dvd player.  I can allocate all the memory I want to the C drive but not the D drive.  The audio skips and since this is going to be about 20 hours of training, it's going to get annoying quick.  Is there a way to allocate cache to the cd/dvd player?  thanks.

0
texastwostep
Asked:
texastwostep
1 Solution
 
Nemesis09Commented:
What exactly do you mean by allocate memory? What memory are you allocating to "C"?
Are you talking about Virtual Memory? Because thats not really how it works...

You could try making sure DMA is enabled, if supported this can speed up transfers between storage drives and memory. I assume you are running windows xp?
Open Device Manager
Expand the "IDE ATA/ATAPI controllers" section
Double click the "Primary IDE channel"
Click the "Advanced Settings" tab
Set both transfer mode dropdown boxes to "DMA if avaliable"
Repeat for "Secondary IDE channel"
Restart the PC

Hopefully this should speed it up a bit and stop the skipping.

On the other hand it is possible that the 20 hours of video is just too much for the system/codec/playing software you are using. This could be the case especially if the video is one huge file which is the size of the cd/dvd and highly compressed. Either way, I dont think you can "assign" RAM to a cdrom OR a hard drive.

Hope this helps.
0
 
garycaseCommented:
XP automatically allocates buffers for all read/write operations; and the optical drive has a small buffer of its own.   Your audio should NOT be skipping -- so I'd look for the cause of that rather than worrying about how the I/O is being buffered.

Check to see if the DVD player may have reverted to PIO mode transfers.   Look in Device Manager at the IDE/ATA/ATAPI controllers, and right-click "Properties" on each of the IDE channels.   Click on the Advanced Settings tab and see what the "Transfer Mode" (should be "DMA if Available") and "Current Transfer Mode" (should be "UDMAx" where x is a number) indicate.

If one of these shows "PIO" as the "Current Transfer Mode" then that's what's causing your skipping.   If that's the case, just do this (this is a harmless registry mod that simply causes transfer modes to be redetected on the next boot):

Load RegEdit (Start - Run - Regedit)

Go to the following keys:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\ Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\000x

The last four digits will be 0000, 0001, 0002, 0003, and so on.

Under each key, delete all occurences of the following values:

     MasterIdDataChecksum
     SlaveIdDataChecksum

Now just reboot.
0
 
dbruntonCommented:
Or try this product

http://www.dvdidle.com/dvd-idle.htm

30 day trial before you buy
0
What Security Threats Are We Predicting for 2018?

Cryptocurrency, IoT botnets, MFA, and more! Hackers are already planning their next big attacks for 2018. Learn what you might face, and how to defend against it with our 2018 security predictions.

 
texastwostepAuthor Commented:
I'll look at both these when I get home, back to my laptop and get back on this post.  Thanks for the timely responses.
0
 
texastwostepAuthor Commented:
Unfortunately none of this worked.  Neither did simple maintenance like downloading patches, defragging or cleaning to DVD drive..... apparently I have all the proper specs...memory, hdd space, quick time version, etc."  Any more ideas appreciated.  Obviously the DVD works find in my desktop.
0
 
garycaseCommented:
Did you make the registry modification I suggested above?   ... it never hurts to force a mode redetection.

... are the DVDs you're having this issue with commercially pressed ?  ... or burned DVDs?

If they are burned DVDs then these can make a big difference:

(1)  Use the highest quality blank media ==> personally I only use Taiyo-Yuden DVD "+R" blanks.

(2)  Burn at a conservative speed -- never faster than 8x

(3)  Try the "opposite" media type => if you're using "-R" try "+R" & vice-versa
0

Featured Post

 The Evil-ution of Network Security Threats

What are the hacks that forever changed the security industry? To answer that question, we created an exciting new eBook that takes you on a trip through hacking history. It explores the top hacks from the 80s to 2010s, why they mattered, and how the security industry responded.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now