• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 745
  • Last Modified:

multilingual not showing in popup

Greeting, I'm working a multilingual web app (Eng & Chinese).

So far so good, however I have a particular problem on some testers' machine. I have few javascript alert to popup message in the proper lingual text as well. But they all getting box-box showing! Even when I view the source, those lingual text also appear as box-box, but they showing correctly in the browser ! (Except the popup)

I have no problem with any of this on development machine (obviously)....

Anyone know what need to work up the client PC to get the popup to show the multilingual text as well?
0
Kelmen
Asked:
Kelmen
  • 6
  • 2
  • 2
2 Solutions
 
CyberGhostCommented:
Do they use same browsers as you use on your devel machine?
What about HTML in that JavaScript pop up? Does it have a charset specified as the main site has?
0
 
KelmenAuthor Commented:
"Does it have a charset specified as the main site has?"

Don't understand this. I suspect some special HTML tag need to be include in the file to indicate something?

Can give a simple sample, as I may do so research?

as about ver: my is 6.0.2900.2180 , same as the user.
0
 
KelmenAuthor Commented:
ok, I did some self research on that charset stuff. I guess you mean this:

<html>
<head>
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; CHARSET=gb2312">

My web app is rendering some zh-SG (Chinese, Singapore) text to the output, so I use the charset gb2312

I tested on both machine, no problem\difference on my, but still the same on the user.

And I tried manual set the encoding to others like UTF-8\Unicode, Windows** to no avail.

Viewing the source in the tester PC, the Chinese text are box-box. But they appear correctly in the web page (ASPX) ?!!!
0
Upgrade your Question Security!

Add Premium security features to your question to ensure its privacy or anonymity. Learn more about your ability to control Question Security today.

 
bhanukir7Commented:
hi there

first of all in the client system install the chinees fonts if ur using chinees traditional the code is (big5)
if ur using chinees simplified the font code is (GB2312).

check if the fonts are there by clicking on the view (Character encoding : mozilla firefox) (Encoding : Internet explorer).


if these fonts are not installed go the control panel and click on  "regional and language settings"

then click on "languages" and select install files for east-asian languages


this be enable u to see the chinees font automatically. sometimes the browser may set the language as chinees traditional while it may be chinees simplified so u have to manually click on the view and change the encoding.

bhanu
0
 
KelmenAuthor Commented:
I have no problem seeing the intended text in the browser on all machines.

The problem is a client-script ( javascript:alert(xxx) ) can't show the proper text, only sum-up square-square thingys.

That's the weired part. :(
0
 
CyberGhostCommented:
Sorry for the wierd comment from me - I did not browse through your question very carefully and thought that it's actually a new window (pop up) rather than javasciprt alert. That's why I thought charset might be a problem.
Apparently, it's the alert box that shows those boxes.
What browser do you use? MSIE, Firefox or something else?
If you specify your browser, that might help a bit.
Also, did you test this alert "bug" in other browsers?

There has been a simmilar question asked in EE here http://www.experts-exchange.com/Web/Web_Languages/JavaScript/Q_21666085.html but it was never resolved. However, it still might help you a bit.

Other possible solutions:
http://www.webdeveloper.com/forum/archive/index.php/t-15525.html
http://www.webdeveloper.com/forum/showthread.php?t=79262
0
 
KelmenAuthor Commented:
One of the tester PC after tinker by my PM, the problem is resolved.

According to him, its the chkbox for "install files for East Asian languages" not enable. After he did that and install with something from the XP CD as prompted, the problem solved.

** the setting can be reach (in XP) by Control Panel -> Regional and Language Options -> Languages

However, if my memory recall correctly, I believe this option is already enabled when I initiating my troubleshooting. However that's on another tester machine. Since she's on leave today, I will clarify this out on next day.

stay tune...
0
 
bhanukir7Commented:
hi there

kelmen i have given u the same advise and u said its not that and now u are saying that  your PM has done that and resolved .
had u carefully read what i posted i think u could have done it by your self

******this was what i posted****
irst of all in the client system install the chinees fonts if ur using chinees traditional the code is (big5)
if ur using chinees simplified the font code is (GB2312).

check if the fonts are there by clicking on the view (Character encoding : mozilla firefox) (Encoding : Internet explorer).


if these fonts are not installed go the control panel and click on  "regional and language settings"

then click on "languages" and select install files for east-asian languages


this be enable u to see the chinees font automatically. sometimes the browser may set the language as chinees traditional while it may be chinees simplified so u have to manually click on the view and change the encoding.

******************************************

anyhow happy that u got it solved by some body else

bhanu
0
 
KelmenAuthor Commented:
bugged me. I chk the other tester PC. the problem is resolved as well. According to the user, she didn't explicitly perform and installation by anyone else, apart from the regular windows auto update. And the support for the East Asian languages is already enabled.

Hello bhanu, I'm appreciate for your help and input.
But base on my past experience, if the PC didnt enable the support for East Asian languages, the text wont appear at all. The page is likely show all box-box texts. I have this experience on Win2k b4, though not on XP.

Well, for the summary of this problem, the support for the East Asian languages of course is needed (this I already knew in my exp on the W2k, fyi ).
What I likely suspect, if the IME (input method) for the relevant languages is not enabled or installed properly, its likely will cause the problem mentioned.
As I recall during my troubleshooting, the East Asian languages is on. The only difference compare with my PC at that time is there's option to enable the same IME as my (Chinese PRC - Keyboard - Microsoft Pingyin 3.0 IME).
However this time after I through the tester PC, the option is avail there!??

Beat me....

Anyway, thx for all the helps.
0
 
KelmenAuthor Commented:
typo error, the last part I mean the tester PC at that time don't have the same IME as my.
0

Featured Post

Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

  • 6
  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now