• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 896
  • Last Modified:

usb drive keeps changing letters

hi  i  am  running  windows  xp, and  i have  a  external  hard  drive plugged  into a  usb  port.. since   dec/05 the  letter  assigned  to  it  was   USB-HDD(F:) now  it  is   labeled  as  a local  drive  and  the  letters  keep  changing  every time  i  turn  the  HD  on  and  off   g,  h,  i,  etc  i  went  into control panel, administrative  tools, computer management,  disk management, clicked on  the  drive,  change  drive  letter  and  path, reset  it,  but when i  turn on and  off  the  HD,  it  changes  again...how  can i put  the  letter F  back  and  make  it  stay  that  way?   and how  can i  change  the  name  back  to  USB-HDD...or  does  this  even  matter and  i  can  leave  it  change  all  the  time  with  no  problems?  thanks  markE
0
markE
Asked:
markE
  • 7
  • 3
  • 3
  • +2
1 Solution
 
LFC1980Commented:
Take it you haven't installed any new hardware apart from that. A memory card reader..etc
0
 
markEAuthor Commented:
no  memory  card  reader  installed
0
 
UnexplainedWaysCommented:
" turn  the  HD  on  and  off   g,  h,  i, "

When it's I, do you have a drive H?  So does it skip, and if so, does it incriment each time?
0
Upgrade your Question Security!

Add Premium security features to your question to ensure its privacy or anonymity. Learn more about your ability to control Question Security today.

 
markEAuthor Commented:
also i noticed everytime  it  changes  letters   i have  all  the  other letters  listed  as  drives  also  f,g h, and  the  latest....hmmm  markE
0
 
UnexplainedWaysCommented:
Do you "safely remove hardware" or just pull it out?

And if it keeps going up a letter, when does go back to normal?
0
 
markEAuthor Commented:
i  just  use  the on  off  switch..... don't  know   just keeps  going  up  a letter...  markE
0
 
LFC1980Commented:
"also i noticed everytime  it  changes  letters   i have  all  the  other letters  listed  as  drives  also  f,g h, and  the  latest....hmmm  markE"


What happens when you click on the new ones that pop up....does it say "no disk"/"insert disk"


But think UnexplainedWays may be onto something with the safely removing the drive.

When you attach devices like removable drives, you shouldn't just pull them out. There is a icon in your system tray that when clicked will have a list of devices connected. You should stop the device you want to disconnect before removing it.
0
 
markEAuthor Commented:
the  latest letter  opens  up  the  HD  the  other   letters  before  say   no disk/insert  disk   when i  close  HD  i  use  on off  switch,  if  i  remove  the  HD  i  always  safely  remove  markE
0
 
UnexplainedWaysCommented:
" when i  close  HD  i  use  on off  switch"
"if  i  remove  the  HD"

Either way you should use the safe remove, try that and see what happens.  I'm thinking it might be something to do with it having it's own power suply and not like a usb stick that draws it from the usb.
0
 
markEAuthor Commented:
i  used  the  safe  remove, and  still have  the  same  problem..letters  changing    markE
0
 
nobusCommented:
i would assign a drive letter towards the alphabet's end , like X, Y or Z. that should take care of it
0
 
NerdxCommented:
To make a drive letter permanent, just right-click on My Computer and select Manage -> Disk Management. In the bottom-right pane, right-click the bar representing the drive whose letter you want to set. Click Change Drive Letter and Paths, Change (Edit in 2000). Select a drive letter from the menu, and choose OK and Yes.

This is for Windows XP only though, I don't know about Win 95-2000.

Hope this helps - GL

~ Nerd
0
 
NerdxCommented:
Sorry, the above is for Windows XP and Windows 2000. It's not for Windows 95, 98 and below.

P.S. When are you going to reply to this solution?

~ Nerd
0
 
NerdxCommented:
I have read your submission clearly now and notice that you have already tried this way. This is the only way it can be done on Windows XP, I'm afraid, so you must be doing something wrong during the process.

Windows will automatically tell you if the changing of the drive letter has failed, so if it didn't you could get it done this way. I have tested this way myself, on my USB Stick, by changing the drive letter from F:\ to N:\, so it should hopefully work for you too.

Make sure that you have disabled access to the USB HD first, as this can cause it to deny the access from changing the letter. If you do this correctly, restart your computer and it should be fine.

Hope this works

~ Nerd
0
 
markEAuthor Commented:
i assigned  z  to  the  hard  drive, and  lately   when i  turn  on  the  hard  drive  it  is  f,  like  in  the  first  place,  hope  it  stays  that  way  lol  thanks , nobus.......    markE   :))))))))))))))))))))
0
 
nobusCommented:
if you have more problems, look also here :   http://www.uwe-sieber.de/usbdlm_e.html      
0
 
markEAuthor Commented:
thanks  for  all  your  help...markE  :))))))))))
0
 
nobusCommented:
no problem - have a nice day !
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

  • 7
  • 3
  • 3
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now