• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1524
  • Last Modified:

WSUS and IIS causing HTTP 401.1 eror

We have a Win 2K3 Server DC, running Trend IMSS and Officescan. These both have web based management consoles hosted using IIS.

We wanted to take a look at Microsoft WSUS so installed it on this server, since we did this everytime we try to access the Trend management consoles or the default website we get:-

HTTP Error 401.1 - Unauthorized: Access is denied due to invalid credentials.
Internet Information Services (IIS)

I have uninstalled WSUS and we still get the same error.

Any ideas?
0
landislund
Asked:
landislund
2 Solutions
 
dnojcdCommented:
were you accessing the default web site with any username/password earlier? Is trend management we interface a virtual directory under IIS sites. Can you check what kind of authentication is there for the deafult web site now?
0
 
landislundAuthor Commented:
Yes we could access the default website using any username/password and from any workstation before installing WSUS.

One of the two Trend consoles is under the default website and the other is a virtual directory.

When I look in properties of the default website under directory security and then authentication methods, only "enable anonymous access" is ticked.

0
 
rrusteanCommented:
Is there a user specified in the ' use the following user account for anonymous access' box?

This should be you IUSR_servername user.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
landislundAuthor Commented:
Yes and the password is already filled in, I don't know what the password is though??
0
 
landislundAuthor Commented:
The IUSR_servername user's account was locked out, does WSUS change the password? Is it possible to reset the password?
0
 
dnojcdCommented:
You can change the password by going to User Management console under the Manage Your Computers.After resetting i t go to IIS Manager , there also you have to change the password

go through this article for resetting password using script.
http://support.microsoft.com/default.aspx?scid=kb;EN-US;297989
0
 
landislundAuthor Commented:
I ran out of time and had no choice but to reload IIS and the applications that were causing the problem.

Thank you to those who posted.

0
 
dbassealCommented:
If you need to find the password for the IUSR_<SERVER> account copy the follwoing into a script file and run it on the IIS Server:  It will output the credentials.

Set objFSO = CreateObject("Scripting.FileSystemObject")
Set objFile = objFSO.OpenTextFile("output.txt", 8, True)
Set IIsObject = GetObject ("IIS://localhost/w3svc")
objFile.WriteLine "According to the metabase, the anonymous credentials are:"
objFile.WriteLine "AnonymousUserName = " & IIsObject.Get("AnonymousUserName")
objFile.WriteLine "AnonymousUserPass = " & IIsObject.Get("AnonymousUserPass")
objFile.WriteLine "WAMUserName = " & IIsObject.Get("WAMUserName")
objFile.WriteLine "WAMUserPass = " & IIsObject.Get("WAMUserPass")
objFile.Close
Set objFile = Nothing
Set objFSO = Nothing
Set IIsObject = Nothing

Works like a charm.
0

Featured Post

Fill in the form and get your FREE NFR key NOW!

Veeam is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now