Giving everyone permissions

I have a win 2003 server set up and the e:\ shared. There is no domain.

When the users type the unc path into run (\\192.168.1.259) I want it to open the shares of the server, instead it prompts for a username and password.
I have given "Everyone" full control and it still does this.

Anyone know the fix?
LVL 1
drdingo21Asked:
Who is Participating?
 
Lee W, MVPConnect With a Mentor Technology and Business Process AdvisorCommented:
Create a domain.  Read what is necessary for a domain so you don't have problems, but create a domain.

By the way, 102.168.1.259 is not a valid IP address.  Why are they typing IP Addresses at all, why not names?

The only way to get around this is to create usernames on the server that match the user names on the clients.  You then also need to have the passwords match.  If you have a domain, this is not a problem.  Without a domain, you could have headaches getting everything setup like this.
0
 
drdingo21Author Commented:
This is a home network. I don't want to create a domain.

The correct address is 192.168.1.250. I'm on a laptop so I fat fingured the 9.

There are 3 of us, creating user accounts on the file server is no problem.
0
 
drdingo21Author Commented:
Creating the user accounts doesn't work.

It still prompts for a user name and password when you try to connect. .
0
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

 
Lee W, MVPTechnology and Business Process AdvisorCommented:
The passwords have to match for the accounts as well.  Simply having the same accounts will not cut it.

The BEST way around this is to have a domain.  I don't know why you won't consider it - the server is licensed with 5 CALs to start with.  You just need a little basic knowledge on how it works and you'd be fine.
0
 
glenn_1984Commented:
On Server...

Name1, Password1
Name2, Password2

On workstaion
Name1, Password1 (identical as above, including CAPS and lowercase)


On Server...
Share Folder, Give all rights to everyone in Permissions AND Security

------------------------------------------------------------------------------------

What happens when you type the unc path and it prompts for user name and password...does that work?

Without a domain to log into you may need to:

1. Create a map drive with the option reconnect at login.  This too may ask for a username and password, but should allow the command to automatically execute itself.

2. With a batch file create a net use command that includes the username and password.
See net use /? for syntax

--------------------------------------------------------------------------------------

However, leew is right.  If you create a domain and join it, you can map the drives and folders from the server and have everyone automatically get them.
0
 
Jay_Jay70Commented:
Hi drdingo21,

a couple of times i have backed this same argument with leew, the amount of time you spend trying to troubleshoot a P2P, you can have afully functional domain running, it is SOO much easier, efficent and secure trust us :)

theres a link if you will consider it

http://www.petri.co.il/how_to_install_active_directory_on_windows_2003.htm
0
 
drdingo21Author Commented:
I'm well aware of how to create a domain.

And no. I don't want to consider it.
0
 
drdingo21Author Commented:
To get around this, you create the account and login once and click "remember password".

After that it doesn't prompt anymore.
0
 
isd503Commented:
That is a bad idea, you do not want to force the system to start caching all your passwords!  What you need to do is authenticate users using pass-through authentication.  To do this you create identical local accounts (same password too) on both the server and workstation and give the local account on the server NTFS permissions to the UNC path.  Make sure both machines are in the same workgroup to avoid those issues.
0
 
Jay_Jay70Commented:
pretty sure leew nailed this above

>>The passwords have to match for the accounts as well.  Simply having the same accounts will not cut it.

A domain solution would have fixed everything simply and easily but author wasnt interested -  such is life
0
 
drdingo21Author Commented:
Creating the user accounts and then clicking "remember password" worked.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.