• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2842
  • Last Modified:

OSPF -' redistribute connected subnets'



   What does the command 'redistribute connected subnets' in OSPF really means ?.

       Any respose with describing examples are highly appreciated

   Thanks
0
dinkon4u
Asked:
dinkon4u
1 Solution
 
nodiscoCommented:
Hi there

You are telling the router/layer 3 switch to redistribute all of the connected interface networks into the ospf routing table.

e.g.

interface FastEthernet 0/0
ip address 192.168.1.1 255.255.255.0

interface FastEthernet 0/1
ip address 192.168.2.1 255.255.255.0

interface Serial0/0
ip address 192.168.3.1 255.255.255.0

router ospf 10
network 192.168.3.1 0.0.0.0
redistribute connected subnets

In the above example, you are advertising ospf out the 192.168.3.1 interface - and not out any other interface.  The redistribute connected subnets command sees the 192.168.1.0 255.255.255.0, 192.168.2.0 255.255.255.0 etc networks and adds them into the ospf routing table.  That way, the ospf enabled device that 192.168.3.1 is routing with knows about these networks.

You can also use redistribute static to distribute static routes into the ospf table - or redistribute a different routing protocol into ospf - bgp, eigrp for example.

hope this helps
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now