DNS forward zone nameservers not updating.

Hey experts!
I have a forward zone lookup for 'mycompany.com'. I have a host A (www) record for my website that is hosted by (let's say) 'webhostingcompany'. I have added 2 NS records, ns1.webhostingcompany.net and ns2.webhostingcompany.net as athoritative nameservers for this forward zone lookup (yes, the actual nameservers are correct, given to me by my webhosting company). My webhosting company often does upgrades. Due to these upgrades the IP address almost always changes. This past week, again my webhosting company did upgrades and the IP changed. However, My host A (www) record did not change. I have contacted my webhosting company for the correct ip address and can fix it for now. Basically what i'm asking is how do i set this up correctly so whenever my webhosting company changes there servers IP address, my host A (www) record also gets updated automatically.

I thought i had this set up properly to pull from the webhosting authoriative nameservers for the particular domain.....apparently not!

Any ideas why this isn't working? (as i'm writing this I'm thinking a firewall or permissions issue maybe?)
What should the 'Start of Authoritive' record point to? It's currently pointing to my 2003 SBS.

I have a 2003 SBS doing DNS and a hardware firewall on the perimeter.

Thanks in advance
LVL 12
Who is Participating?
You may want to seriously consider changing the internal namespace to something like "ourcompany.local" or "local.ourcompany.com".  Or perhaps chaning web-hosting companys to one that will issue you a static IP

The problem is that DNS authority is somewhat absolute.  For a domain to function, your DCs need to be authoratative for that namespace for the internal clients.  If your DCs are configured for "ourcompany.com", then they will consider that they are authoratitve and will not forward any requests or look elsewhere for any DNS records for that namespace.  I am not aware of any way around this.  If the external website has the same domain namespace as your internal network, you're internal DNS server will need a valid 'A' record for it, or your internal clients will not locate it.  Unfortunately, since the website is external, a change in IP address will not be able to register itself with your internal DNS servers.
Is the webserver not under your physical control?  Does it have the same namespace as your local network?
NetAdmin2436Author Commented:
Correct, It's not under my physical control and yes, it has the same namespace as my network. I didn't set this up.
Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

NetAdmin2436Author Commented:
*sighs* That's what i'm afraid of....

Changing namespace requires running DCPROMO and removing active directory, changing namespace and adding back active directory. Correct?

they will only update if you tell them and they support sending your a address change update.

The delegation starts with the most authoratiative DNS server for the domain, which is the one with a glued A record, which is the providers, not your server.  The delegation can move downstream but only if setup on thier server.
NetAdmin2436Author Commented:
Thanks guys, i appreciate the quick responses. Points for you both. It's not really what i wanted to hear....but can't argue the facts.....

We are getting a new DC sometime by the end of the year, so I will wait till then to change the namespace to something other than "mycompany.com". I'll just have to put up with manualy changing the A record for a the time being.

Thanks again!
Sorry I couldn't be more help.  Thanks.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.