• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 937
  • Last Modified:

No cdrom drive detected!

There is no cdrom drive listed in my computer. I replaced the cdrom drive and booted, i got the bubble saying it found new h/w for the cdrom drive but in device manager it says that the driver has been installed but no h/w detected!

One thing thats bothering me is that under disc drives, as well as the hdd, there are two entries: oei-usb compactflash usb device and oei-usb sm/ms/sd usb device. I uninstalled these two devices and went to add/remove h/w in cp, the two devices were detected and installed again, even though no external devices were connected to the pc, but no cdrom drive was detected?

Im running xp home.

Any ideas?
0
aaronmcl
Asked:
aaronmcl
  • 4
  • 2
  • 2
  • +2
1 Solution
 
aaronmclAuthor Commented:
Just to add, the pc will boot from a bootable cd.
0
 
CallandorCommented:
I think there are a couple of possibilities:
- You have a registry entry for "upper and lower filters" that needs to be removed: http://support.microsoft.com/default.aspx?scid=kb;en-us;314060

- You need to go into Control Panel->Admin Tools->Computer Mgmt->Disk Mgmt and change the drive letter.
0
 
aaronmclAuthor Commented:
What could these be though: oei-usb compactflash usb device and oei-usb sm/ms/sd usb device?
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
Gary CaseRetiredCommented:
I'd agree the first thing to try is removing the Upperfilters & Lowerfilters.   These can become corrupted for more reasons than those listed in the Microsoft Knowledgebase article.

... If you don't want to read through the whole KB article, all you're doing is running RegEdit (Start, Run, Regedit) and removing the Upperfilters and Lowerfilters values from the following registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}

Then just reboot your computer.
0
 
Gary CaseRetiredCommented:
"... What could these be though: oei-usb compactflash usb device and oei-usb sm/ms/sd usb device ..." ==> do you by any chance have an all-in-one printer attached that has a multi-function card reader?
0
 
CallandorCommented:
>What could these be though: oei-usb compactflash usb device and oei-usb sm/ms/sd usb device?

Do you have a smart card reader in the PC?  That is what I think they are.
0
 
aaronmclAuthor Commented:
Yes. Thats it. I read the article, just going to try the suggested steps now.
0
 
nobusCommented:
if the above does not help, try this :

http://www.dougknox.com/xp/scripts_desc/xp_cd_dvd_fix.htm
0
 
burrcmCommented:
XP is prone to muck up allocating drive letters when USB devices are involved. Go to Control Panel, Administrative Tools, Computer Management, Disk Management, find and right click the CD and click change drive letter and path. Select an available letter and OK out. Now you should see it.

Chris B
0
 
aaronmclAuthor Commented:
Bang on with the upperfilters/lowerfilters fix Callandor...thx all for the help as always.

Cheers
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 4
  • 2
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now