• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 238
  • Last Modified:

Please help! Upgraded from 2.0.53 to 2.2 and Apache service crashes and burns.

Hello everyone!  I hope you can help me today, because we're in a bit of a bind.

The two computers we're dealing with are a Windows XP SP2 workstation and a Windows 2000 Server.

The WinXP machine had Apache 2.0.53 installed originally and the initial configuration worked perfectly.  Then we upgraded to Apache 2.2.  Suddenly, the Apache service will not start and crashes when it tries to start.  The crash only happens when the documentroot is set to a remote location on the Win2000 Server (for example: //ServerName/htdocs).

When documentroot is set to a local directory on the XP machine using 2.2, everything works fine.  But, when the documentroot is changed to a shared location on our Win2000 Server, then the service fails and crashes.  Crazy thing is, when 2.0.53 was installed, having the documentroot set to the Win2000 Server location caused no problems at all.  The problem only started when we upgraded.

Any help would be GREATLY appreciated!
Thank you so much.
-Mike
0
mlamartina
Asked:
mlamartina
  • 2
1 Solution
 
mlamartinaAuthor Commented:
I have a mini update...  I didn't even think to checked the service login and entered the proper domain, login, and password.  I had accidently left it as local login, which obviously doesn't work when accessing a network location.  I entered in the correct login and password.

However, I'm still getting a crash screen that asks me to debug, send error info to MS, or don't send info.  This time, I got a few new things.  I received an error in the System Event Log this time.  Error ID 7024.  Microsoft says that's an error due to the firewall being on and says to exclude File and Print Sharing.  But, it is already checked and so is Apache Server.  Interesting note, I also had two entries for Apache Server in the exclusions tab.  I removed one and rebooted and received this error at startup:

The instruction at "memory address" referenced memory at "0x0000".
The memory could not be "read"

Thank you for your help.  Hopefully this info helps in the resolution.
0
 
mlamartinaAuthor Commented:
I found the solution.  Don't all rush to help!  ;-)  Just kidding.  I'm just happy it's fixed.  Here's what happened.  We uninstalled 2.0.53 and installed 2.2 overtop.  In the Services manager, there was a disabled service for 2.0.53 and an automatic service for 2.2.  Went into regedit, HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Services, and deleted both Apache 2.0.53 and 2.2 services.  I reinstalled the Apache server.  Went into the service manager, manually stopped the service, and changed the login for the Apache 2.2 service for a valid domain login.  Then, changed the config file for the documentroot to "//servername/htdocs".  Rebooted and life was happy once again!

I guess the uninstall for 2.0.53 wasn't a very good uninstaller and the service that it left behind messed things up.  I'm not sure why, but I know it works beautifully now!

Thanks,
Mike
0
 
EE_AutoDeleterCommented:
mlamartina,
Because you have presented a solution to your own problem which may be helpful to future searches, this question is now PAQed and your points have been refunded.

EE_AutoDeleter
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now