• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 352
  • Last Modified:

little bit problem with PHPMyAdmin...

Hey Experts,
                 I have installed PHP 4.3.6 and also installed MySQL and PHP is successfully configured with MySQL. Then i installed PHPMyAdmin it's also running well.
   but when i go to PHPMyAdmin(C:/phpmyadmin/index.php) the page browses successfully but gives a red error message at the bottom of the page. The error message is:

"The $cfg['PmaAbsoluteUri'] directive MUST be set in your configuration file!
The mbstring PHP extension was not found and you seem to be using a multibyte charset. Without the mbstring extension phpMyAdmin is unable to split strings correctly and it may result in unexpected results."

                  I guess that it will not effect big on my PHP working. but i wana know that what's the problem and where is the problem and what's it's solution?
0
RizwanAbasi
Asked:
RizwanAbasi
  • 14
  • 11
1 Solution
 
str_kaniCommented:
The $cfg['PmaAbsoluteUri'] directive MUST be set in your configuration file!

you fix this by setting the vlaues in the configuration file (config.inc)
0
 
RizwanAbasiAuthor Commented:
i've given the user =root
                    password=pass
 but i  was wrong PHP is not working with my SQL when i run a page , gave the following errors,
Warning: mysql_connect(): Access denied for user 'root'@'localhost' (using password: NO) in E:\websites\php\_add.php on line 3

Warning: mysql_select_db(): supplied argument is not a valid MySQL-Link resource in E:\websites\php\_add.php on line 4

Warning: mysql_query(): Access denied for user 'ODBC'@'localhost' (using password: NO) in E:\websites\php\_add.php on line 12

Warning: mysql_query(): A link to the server could not be established in E:\websites\php\_add.php on line 12

Warning: Cannot modify header information - headers already sent by (output started at E:\websites\php\_add.php:3) in E:\websites\php\_add.php on line 13
0
Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

 
str_kaniCommented:
Ok, before running your files... try this

<?php
$link = mysql_connect('localhost', 'root', 'pass');
if (!$link) {
   die('Could not connect: ' . mysql_error());
}
echo 'Connected successfully';
mysql_close($link);
?>
0
 
RizwanAbasiAuthor Commented:
i 've previously checked this and it is ok.
        Connected successfully.
0
 
RizwanAbasiAuthor Commented:
last time i installed PHP manually and this time i used PHP installer to install PHP.
 after installing through installer i can't find the file config.inc-dist in PHP folder.
0
 
str_kaniCommented:
It's not recomented to install PHP using the installer, It's better to remove the current installation and install php manually...
0
 
RizwanAbasiAuthor Commented:
let me remove the current installation and install it manually.
0
 
RizwanAbasiAuthor Commented:
what should be it's value?
$cfg['PmaAbsoluteUri'] = '';

in config.inc.php

in line#39
0
 
str_kaniCommented:
the url by which you are going to access php myadmin,

example http://localhost/phpmyadmin/index.php
if you are running this from your local machine...

$cfg['PmaAbsoluteUri'] = 'http://localhost/phpmyadmin/index.php';
0
 
RizwanAbasiAuthor Commented:
I have reinstalled PHP by installer but can't solve my problem.I've entered this value you told me but fruitless.
0
 
RizwanAbasiAuthor Commented:
Can some one help me?
0
 
str_kaniCommented:
are you getting the same old error message? or something new?
0
 
RizwanAbasiAuthor Commented:
The following error appeared.

"The mbstring PHP extension was not found and you seem to be using a multibyte charset. Without the mbstring extension phpMyAdmin is unable to split strings correctly and it may result in unexpected results."
0
 
str_kaniCommented:
you copy the php_mbstring.dll to your windows dir (c:\windows\system)
and uncomment the following from your php.ini (in c:\windows\php.ini)

;extension=php_mbstring.dll

After that, restart your webserver IIS/Apache then you should no longer see the problem.
0
 
RizwanAbasiAuthor Commented:
last time i had encountered the same problem and posted also a question.

http://www.experts-exchange.com/Web/Web_Languages/PHP/PHP_Databases/Q_21753520.html

and i am increasing the points bcz i have not much points.
0
 
str_kaniCommented:
no problem with the points...
let me know what happens when you follow my last comment...

you copy the php_mbstring.dll to your windows dir (c:\windows\system)
and uncomment the following from your php.ini (in c:\windows\php.ini)

;extension=php_mbstring.dll

After that, restart your webserver IIS/Apache then you should no longer see the problem.
0
 
RizwanAbasiAuthor Commented:
HTTP 400 - Bad Request

this message appeared.
0
 
RizwanAbasiAuthor Commented:
i think i should reinstall php and phpmyadmin may be it can solve my problem.
0
 
str_kaniCommented:
are you working on your local machine or internet? can i have a look if it's on the internet...?
using IIS or apache...?

before going to the next step, take a look at this...

http://codewalkers.com/forum/index.php?action=displaythread&forum=phphelp&id=562&realm=default

same problem as yours, but on a linux machine.

0
 
RizwanAbasiAuthor Commented:
I am working on a local machine using IIS and WIndows XP Professional.
0
 
RizwanAbasiAuthor Commented:
Ah still unsuccesfull after visiting the link even this method worked with most of the users. I don't know why it's unsuccessful to me.
                             Let me uninstall n reinstall PHP.
              let's see what happens.
0
 
str_kaniCommented:
are you installing php manually or with installer? donot try with installler.
0
 
str_kaniCommented:
php_mbstring is not enabled by default

For Windows users php_mbstring can be added as follows:-

if you have dowloaded  the "short" version of PHP, (php-4.3.10-installer.exe), download the full version . (php-4.3.10-Win32.zip)

unzip it, find php_mbstring.dll in f:\php-4.3.10-Win32\extensions, and copy it across to your php\extensions directory

use Notepad to open your PHP.INI

change the extension_dir line to read extension_dir = "e:\php\extensions\"  (or whatever your directory is called)

remove the semi-colon on line
 ; extension=php_mbstring.dll

save PHP.INI,  restart webserver.... this should do that.
0
 
RizwanAbasiAuthor Commented:
Dear  str_kani ,
                    Before posting the question, I did all the above processing while and after installing PHP but these two errors were still there. I came to know that i can work having these errors. However i have to work on PHP MYSQL because i don't have time. MySQL works approx fine.
                 However, I am really thankful to you that you helped me alot. I appreciate your efforts.
              Thank you very much.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 14
  • 11
Tackle projects and never again get stuck behind a technical roadblock.
Join Now