• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 242
  • Last Modified:

ISA 2000 - trouble accessing OWA externally

(Note: I have this open as a question in the Email area - http://www.experts-exchange.com/Networking/Email_Groupware/Exchange_Server/Q_21841800.html - but I'm now fairly sure it is an ISA related query so am also opening this one)

Hello,

I have been having terrible trouble accessing OWA from outside the building. This all started after our proxy server (which runs ISA server 2000) was restarted. Other than this, to the best of my knowledge, nothing else changed in regards to the OWA server or the proxy server.

I am quite unfamiliar with ISA server so it's been a very steep learning curve and I still feel like I'm groping around in the dark. I'll try to summarise as best I can: -

 - If someone from outside the building tries to access webmail.domainname.com/exchange, they get a 404 error. This 404 error is physically coming from the ISA server - I know this because I added some custom text to the actual 404 page and it shows up in the browser of the computer trying to access OWA.
 - There is a web publishing rule in ISA server that specifies anything from the destination set of webmail.domainname.com with a path of /exchange/* (and /exchweb/* and /public/*) gets forwarded to ldnexch1.domain.com. I can ping ldnexch1.domain.com from the ISA / proxy server just fine - there don't seem to be any other connectivity issues.
 - In IIS on the proxy server, if I stop the default website, I don't get the 404 error anymore. I get a generic error page that finishes with "Cannot find server or DNS error".
     - (I'm not even sure that IIS should be running on the ISA server - or, not a default webpage anyway. We have nothing hosted on it - does it need to be there?)

It appears that instead of the request being forwarded to the email / OWA server, it's just looking locally for /exchange/. I confirmed this by creating a folder called /exchange/ and got a different error - it complained that directory listing was not enabled. I then put an index.html file in there and typed webmail.domainname.com/exchange/index.html and it brought up the index file I'd just created. But if this is the case, I don't know how to STOP it from looking for the file locally and pay attention to the web publishing rule again.

Anyway, I hope this is enough to garner some help from someone, I'm really quite stuck and been battling with this for a while now. I hope the above makes sense but if it needs clarification or you think you might be able to help more if I provide further information, please post to let me know.

Thank you very much in advance.


0
dyl666
Asked:
dyl666
1 Solution
 
dyl666Author Commented:
Well, I bit the bullet and completely removed IIS. It has cleared up the problem. I will request that the question be closed but left here in case it helps someone in future.

I guess the moral of the story is: don't run IIS and ISA server together unless you actually know what you're doing and have to =)
0
 
Keith AlabasterEnterprise ArchitectCommented:
Sorry you didn't get a response from me but you have opened the call and dealt with it during my nighttime (UK).

http://www.experts-exchange.com/help.jsp#hs5

regards
keith_alabaster
ISA MCT
0
 
GranModCommented:
Closed, 500 points refunded.
GranMod
The Experts Exchange
Community Support Moderator of all Ages
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

How do you know if your security is working?

Protecting your business doesn’t have to mean sifting through endless alerts and notifications. With WatchGuard Total Security Suite, you can feel confident that your business is secure, meaning you can get back to the things that have been sitting on your to-do list.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now