?
Solved

Hyperlink error

Posted on 2006-05-10
7
Medium Priority
?
428 Views
Last Modified: 2012-06-27
I have a table that contains a hyperlink field.  The hyperlinks are all "TIFF" images on my in-house domain.  I've tried all the security settings, registry edits and I still receive the same error message.  "Some files can contain viruses or otherwise be harmful to your computer...."  There has to be an easy way to fix this without doing all this registry editing, creating digital signatures etc.  (isn't there?)
0
Comment
Question by:davcos
5 Comments
 
LVL 27

Accepted Solution

by:
jjafferr earned 536 total points
ID: 16652477
try

menu bar > tools > macro > security, then set it to low
0
 
LVL 77

Assisted Solution

by:peter57r
peter57r earned 532 total points
ID: 16652492
Hi davcos,
>  "Some files can contain viruses or otherwise be harmful to your

From the MS article on this subject:
------------------------------------------------------------------------------------------
CAUSE
The warning message described in the "Symptoms" section of this article is issued by Microsoft Office. This warning is referred to as the "open programs" warning, not the "macro virus protection" warning. It appears any time that you click a hyperlink to a program or run a program. You also receive this warning when you click a hyperlink to certain types of document files. You cannot disable this warning. Similar behavior occurs in other Microsoft Office programs that allow you to use hyperlinks.

This feature is designed into Microsoft Office to help protect you from malicious code.
----------------------------------------------------------------------------------------------------

Pete
0
 

Author Comment

by:davcos
ID: 16652532
Actually I had to perform those steps to even be able to open the database when we upgraded to MSA2003.  I have numerous macros, and I had to set the security to "low" to enable macros.  It seems there should be some way to trust a database that has been entirely built in-house.  I forgot to say that I am using MS Access 2003 (SP2)

Thanks,
0
 

Author Comment

by:davcos
ID: 16652603
This aticle from MS says that you can disable the message.  http://support.microsoft.com/?kbid=829072
It does not work.  Why would opening a tiff image from access be a problem.  I don't recieve an error when opening the file across the network.  The "TIFF" file extension is associated with another MS application.  Can't I "trust" my own domain?  Kriekie!
0
 
LVL 74

Assisted Solution

by:Jeffrey Coachman
Jeffrey Coachman earned 532 total points
ID: 16900530
davcos,

To "Trust" your own code you may have to create your own "Digital Signature", using the "selfcert.exe" utility.
(Try this on a test machine first!)

(The steps listed here are for excel 2000, but are virtually identical for Access 2003.)

Maks sure the security level is NOT set to "HIGH"

Create Digital Signature
http://www.overcomeemailoverload.com/outlook/OEOMacros.html
To use the macros safely, you need to create a digital signature for yourself and sign the macros. To do this, you need to have SelfCert.exe installed. If it is installed, it is probably at
C:\Program Files\Microsoft Office\Office

If SelfCert.exe isn't already loaded, here is how to install it:
1.      Go to the Start menu and select Control Panel.
2.      Click on the Add/Remove Programs icon.
3.      Make sure that the Change or Remove Programs icon in the upper left is selected.
4.      Select Microsoft Office 2000 and click on the Change button.
5.      Expand Office Tools by clicking on the plus sign (+).
6.      Select Digital Signature for VBA Projects and set it to Run from My Computer.
7.      Click on the Update Now button. (At this point, the installation program will probably ask you for your Microsoft Office 2000 CD-ROM installation disk.)
To create your certificate, start SelfCert.exe and enter your name. This will create a digital certificate for your personal use.
Sign the Macros
Finally, you need to actually sign the macro with this new certificate.
1.      Inside the Visual Basic window, select Tools->Digital Signature.
2.      Click on the Choose button.
3.      Select the certificate that you just created.
4.      Click on the OK button.
5.      Select File->Save.
That's it! You should be in business now.

I hope this helps as well
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Traditionally, the method to display pictures in Access forms and reports is to first download them from URLs to a folder, record the path in a table and then let the form or report pull the pictures from that folder. But why not let Windows retr…
Code that checks the QuickBooks schema table for non-updateable fields and then disables those controls on a form so users don't try to update them.
In Microsoft Access, learn how to use Dlookup and other domain aggregate functions and one method of specifying a string value within a string. Specify the first argument, which is the expression to be returned: Specify the second argument, which …
With Microsoft Access, learn how to start a database in different ways and produce different start-up actions allowing you to use a single database to perform multiple tasks. Specify a start-up form through options: Specify an Autoexec macro: Us…
Suggested Courses

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question