"Page Not Found" 404 Error with Outlook Web Access for Windows Server 2003 SBS

We recently tried to setup RPC over HTTP for a remote user to connect to our 2003 SBS Exchange Server from Outlook on his workstation. OWA is not powerful enough to handle everything he needs. RPC over HTTP is something we want to get setup, but right now this isn't our main problem. We made some changes on certificates to point to mail.domainname.com from just domainname.com. Once we made this change we lost access to every part of Remote Web Workplace and OWA. We reverted back and can now get to Remote Web Workplace (RWW) fine but Exchange OWA does not work. We get a 404 "Page Cannot be Displayed Error." Please Help! I tried restoring the metabase to earlier but can only go back to the original from 2 years which totally screwed everything up or an hour or less ago. Right now, everything is accessible with the exception of OWA. I don't think the problem lies with Certificates, because I still get the prompt to accept it and I've looked at security and permissions over and over, but I could have missed something. By the way, OWA does not work on the inside or the outside.

LVL 1
ndmtechAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ndmtechAuthor Commented:
Sweet! I got it working...Sort of! I went to the properties in the Default Web Site and Change the Authentication to Basic Only, restarted and Viola! Then I went to remote properties and turned on Basic as well as Integrated Windows Authentication.

CURRENT PROBLEM:

We can now go to https://mail.domainname.com/remote and login and then click on the link to Exchange, but we can't go to https://mail.domainname.com/Exchange like before. If you do, you get the same 404 Page Not Found Error. However, once you logout of Exchange and then try to go to https://mail.domainname.com/exchange it goes to https://mail.domainname.com/exchweb/bin/auth/owalogon.asp?url=https://mail.domainname.com/exchange&reason=2

What's the deal? It's like it doesn't know where https://mail.domainname.com/exchange points to. I'm pretty new at IIS, I understand the concepts, etc, but don't have enough experience to understand the virtual directorys, etc.

I need to be able to have my users go to http://mail.domainname.com/exchange without getting a 404 error.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
f_umarCommented:
However, once you logout of Exchange and then try to go to https://mail.domainname.com/exchange it goes to https://mail.domainname.com/exchweb/bin/auth/owalogon.asp?url=https://mail.domainname.com/exchange&reason=2


it shows that you have enable forms based authentication, it uses basic authentication with ssl.
change the link in remote from https://mail.domainname.com/Exchange to  https://mail.domainname.com/exchange and enable integrated authentication as well disable form based authentication.
to disable forms based authentication go to system manager - administrative groups - server - protocols - http in Exchange Virtual server properties select settings tab and then uncheck the check box Enable form based authentication

0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

LeeDerbyshireCommented:
If you can go to https://mail.domainname.com/remote , and then click on a working link to OWA, then try hovering your mouse over that link, and see what address is shown in the IE status bar.
0
ndmtechAuthor Commented:
Thanks guys! Due to the urgency of the matter, I had to open a ticket with Microsoft. Everything listed above was part of what needed to be done though! IIS and Certificate Services were totally out of whack. Microsoft was EXTREMELY knowledgeable and helpful. They had me up and running within an hour and assisted with MS Live Meeting.

Here are Her Notes:

---------------------------------------------------------------------------------------------------------------------
Issue : Unable to access OWA internally and externally.

 

Recreated Exchange Virtual Directories (Exchange, Exadmin, Public and Exchweb) by following steps :

 

Step 1: Enabled real-time editing of the metabase:

 

To do this, follow these steps:

a.  Click Start, point to Administrative Tools, and then click Internet Information Services (IIS) Manager.  

b.  Right-click ServerName (local computer), and then click Properties.

c.  Click to select the Enable Direct Metabase Edit check box, and then click OK.  

 

Step 2: Deleted the Exchange virtual directories (Exchange, Exadmin, Public and Exchweb).

 

Step 3: Modified the Metabase.xml file :

 

To do this, follow these steps: a.  Open the Metabase.xml by using a text editor such as Notepad. By default, the Metabase.xml file is located in the following folder:

%windir%\System32\Inetsrv  

b.  On the Edit menu, click Find.  

c.  In the Find what box, type 61472 , and then click Find Next to locate the following area in this file:  

d.  In this area of the Metabase.xml file, replace the Value entry with 0 .

e.  Save your changes to the Metabase.xml file, and then quit Notepad.  

 

Step 4: Restarted the Microsoft Exchange System Attendant service .

 

Step 5: Disabled real-time editing of the metabase:

 

Restore the default IIS setting to disable real-time editing of the metabase. To do this, follow these steps: a.  Click Start, point to Administrative Tools, and then click Internet Information Services (IIS) Manager.  

b.  Right-click ServerName (local computer), and then click Properties.  

c.  Click to clear the Enable Direct Metabase Edit check box, and then click OK.  

 

Ran CEICW (Internet connection Wizard) and made the default gateway point to internal ip address of router (192.168.0.1) and changed the web server certificate name -- made that point to external ip address of server.

 

Deleted all the files in C:\windows\IIS Temporary Compressed files.

 

Ran iisreset command at cmd prompt.

 

Unchecked the Form based Authentication under Exchange System Manager -- Protocols -- Http -- Exchange virtual server -- Settings .

 

Ran CEICW again.

 

Tried accessing OWA internally and externally -- It worked.

 

Issue  resolved.

 

Recommendation : Install hotfix 831464 -- reboot the server and then install Exchange 2003 SP2 on the server.

---------------------------------------------------------------------------------------------------------------------

GO MICROSOFT!!!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.