?
Solved

Kylix Application not Working on Fedora Core 5

Posted on 2006-05-11
4
Medium Priority
?
180 Views
Last Modified: 2010-04-16
I am trying to run an app compiled under linux using Kylix 3 but when I run it as follows ...


[root@localhost ~]# ./misimp

I get the error ...

Runtime error 230 at 08058961
Segmentation fault

Now if I run it on another RedHat 9 machine we have there is no problem it just works.

I have a feeling it is just a case of some required components or something are missing on the machine, but how would I find out what was required, where would I get the required files from, and how would I install them to get this app working again?

This is EXTREMELY urgent as I need to try and get a fix sorted within the next 3 hours or so. (Unlikely I know)
0
Comment
Question by:Terry Rogers
  • 3
4 Comments
 
LVL 1

Author Comment

by:Terry Rogers
ID: 16656807
Think ive found a fix for the above error ...

http://crosskylix.untergrund.net/execshield.shtml

I have run the patch on that page against my application ./misimp and now get the follow error ...

[root@localhost ~]# ./misimpnew
Exception EMyError in module misimpnew at 080A8BD6.
Client does not support authentication protocol requested by server; consider upgrading MySQL client.

However I have installed:
mysql-5.0.18-2.1 & 
mysql-server-5.0.18-2.1

And that app is connecting to localhost. I tryed changing this to a database running on another server, which is running mysql 4.1.1 and it worked fine. Appears to be an issue now with authentication against the localhost.

Ive tryed change the username/password to make sure that wasn't an issue and it returned with an incorrect username or password message. So username and password are ok.

Any help greatly appreciated :|
0
 
LVL 1

Author Comment

by:Terry Rogers
ID: 16656843
I have enabled the mysql configuration parameter old_passwords=1 and have not had any change. Still not working.
0
 
LVL 1

Author Comment

by:Terry Rogers
ID: 16658457
All Issues are now resolved. Will requested closure and point refund.

In order to enable the application to connect to the linux server I had to re-create users passwords using the old format then flush privilages.
0
 

Accepted Solution

by:
GranMod earned 0 total points
ID: 16711240
Closed, 500 points refunded.
GranMod
The Experts Exchange
Community Support Moderator of all Ages
0

Featured Post

New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A lot of questions regard threads in Delphi.   One of the more specific questions is how to show progress of the thread.   Updating a progressbar from inside a thread is a mistake. A solution to this would be to send a synchronized message to the…
Hello everybody This Article will show you how to validate number with TEdit control, What's the TEdit control? TEdit is a standard Windows edit control on a form, it allows to user to write, read and copy/paste single line of text. Usua…
Loops Section Overview
Despite its rising prevalence in the business world, "the cloud" is still misunderstood. Some companies still believe common misconceptions about lack of security in cloud solutions and many misuses of cloud storage options still occur every day. …
Suggested Courses
Course of the Month14 days, 18 hours left to enroll

840 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question