Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 480
  • Last Modified:

Remote Web Workplace - Cannot access the remote site.

Hi there,

I have a problem with the Remote Web Workplace (/remote) part in IIS.
I want to reinstall it to eradicate these errors and not sure what to do exactly?

I have re-run the ICW wizard, reset permissions on the site all to no avail.

The rest of the site works fine, just the remote part prompts for a username and password (in the IIS prompt box) and then, despite entering a Domain Admins credential it then displays the page as NOT AUTHORIZED.

Help!

0
utilize
Asked:
utilize
  • 6
  • 5
  • 3
  • +1
1 Solution
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Before reinstalling, how about checking the Directory Security Settings...

There are two levels to check, both the Default Web Site and the Remote Virtual Directory.

Open the IIS Manager and expand Web Sites > Default Web Site.  Right click on it to open Properties > Directory Security.  Then click the top Edit... (Authentication and access control).  You should have Anonymous Access enabled and Integrated Windows Authentication checked.

Then, open the same tab on the "Remote" virtual directory and on that one you should also have Anonymous Access enabled and Integrated Windows Authentication checked.

Then, see if you can access the site from your SBS by navigating to http://127.0.0.1/remote, if that works take it out a step further and try from a LAN workstation to http://<servername>/remote.

Finally when you try from a remote location make sure to use https instead of http (ie, https://<serverfqdnorip>/remote

Jeff
TechSoEasy

0
 
utilizeAuthor Commented:
Unfortunately i have tried all of this, including trying various other types of authentication.
Taking out the link from the SBS site, by simply typing SERVERNAME/remote has exactly the same consequences, remotely or from the server itself.

Hmmmmm, any other ideas?
0
 
hugheseCommented:
Do you have port 443 (TCP) and 4125 (TCP) opened on the server and external firewall?

0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
utilizeAuthor Commented:
yes, especially when it does'nt work whilst being on the server itself (through IE). It simply states, not authorised.
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Okay, so if it doesn't even work from the server itself, then you do need to reinstall.

One more thing though so that I know which set of instructions to provide.  Are you able to access http://companyweb as well as the Monitoring and Backup Snap-ins in your Server Management Console?  Please advise if all three are accessible or not.

Jeff
TechSoEasy
0
 
utilizeAuthor Commented:
I can confirm that the Monitoring and reporting and the backup snap-ins are working, as is the companyweb site.
All seems to be ok apart from /remote.

Thanks
0
 
hugheseCommented:
You could try removing and recreating the web application in IIS manager for the remote directory. Make sure you make a note of an settings before you do this. Check the default document is correct and that the directory permissions as as above (anonymous and integrated checked)
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
The process for reinstalling IIS on SBS is found here:  http://support.microsoft.com/kb/887305

That is the next logical step to take.  Please follow all steps explicitly (other than the ones it says you can skip regarding SharePoint )

Jeff
TechSoEasy
0
 
hugheseCommented:
IIS seems to be working it's something to do with the remote virtual directory? Would it not be worth looking at that first?
0
 
kgreeneitCommented:
hi there, i've seen this problem on a couple of my customer's sites. Its an issue with the way SBS sometimes erroneously sets up the permissions when the ICW is run. If you give the 'everyone 'group full access to the microsoft.net directory and its subfolders this should resolve the problem. the Microsoft.net directory is in the root directory  (usually C:\windows) of your server.

Hope this helps!!
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Hey kgreeneit... that could be it... you reminded me of a problem that does exist if the .Net 2.0 Framework was installed, or if other manual modifications have been made to IIS.

The actual folcer that gets permissions problems is this one:
C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\Temporary ASP.NET Files

But before making any changes lets see if that's the exact error.  Please follow these steps:

1. Make a copy of Inetpub\Remote\Web.config for backup purpose.
2. Open Web.config with Notepad
3. Replace <customErrors mode="On" defaultRedirect="error.aspx" /> with
<customErrors mode="Off" />
4. Save the file.
5. Go to command prompt, type "iisreset"
6. Logon to RWW using the administrator account, and also try it using a
regular user account.
7. Post back the error.

(this is a Microsoft recommended troubleshooting path)

Jeff
TechSoEasy
0
 
utilizeAuthor Commented:
I cant actually get to the remote page!
Simply says - Not Authorized - when trying to connect.......

You get the homepage normally by entering the server IP address.
All the links are working apart from the /remote link that prompts for the script installation, then a username and password (not the RWW login, simply a IIS dialog box). Whatever username/password you put in it will go to a page that says Not Authorized.

Nightmare!
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
If you modify the file according to the steps I listed above you will get a more detailed error message that is entirely why I asked you to do that.

Jeff
TechSoEasy
0
 
utilizeAuthor Commented:
Sorry, I have done exactly as you have said and it still comes back as not authorised.
I thought i may have miss represented the problem....

0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Please go to this Newsgroup posting and follow each of the troubleshooting steps.  If you need further help with any of them, please post back here with the details:

http://snipurl.com/qh6u

Jeff
TechSoEasy
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 6
  • 5
  • 3
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now