• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1144
  • Last Modified:

IE secure and not secure mode

I do not have a check mark in the IE advanced option, Warn if changing between secure and not secure mode, but I keep getting the warning dialog box

What do I have to do to get rid of the dialog box?
0
joemz
Asked:
joemz
  • 4
  • 4
1 Solution
 
venom96737Commented:
Next time it pops up there is a little box in the bottom left hand that says do not show this message again check that and then check ok and you will not see it again.
0
 
joemzAuthor Commented:
Nope, I keep checking that, and it keeps showing up
0
 
venom96737Commented:
ok then it can be done in the registry also by going to HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings and HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings
look for  WarnOnHTTPSToHTTPRedirect and set the value to 0
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
venom96737Commented:
doing this in both places in the registy will disable this message.
0
 
joemzAuthor Commented:
I don't have that key in the registry anywhere.  I looked in both those places and got nothing, then did a FIND and got nothing.  I added the key to Current_User, but did not add it to Local-Machine because I wasn't certain where to put it.  Does it go in the root of the string you provided (which it did for current_user and it was obvious since there were other related items there) or somewhere else.

When I just put it in current user there was no effect
0
 
venom96737Commented:
It must go inside both the internet settings I found a site that contains a batch file that will do it for you here http://www.jsifaq.com/SUBR/TIP8900/rh8935.htm copy it to a notepad save it as WarnOnHTTPSToHTTPRedirectOff.bat and then double click it and press c.
0
 
joemzAuthor Commented:
did it, checked the registry and both entries are there, but i still get the warning message.

fyi, its not a message about being redirected, its about the page containing both secure and nonsecure items, and do i want to display the nonsecure items
0
 
joemzAuthor Commented:
I found the answer on Microsoft, article 842779, which really addresses a different issue, but had enough info for me.

Ends up that IE treats pages that use the IFrame tag as non secure pages and that results in the error message

In IE tools/security I changed some (not sure which ones since I did several at once) of the options around prompt/enable, and it the message went away
0
 
CetusMODCommented:
PAQed with points refunded (125)

CetusMOD
Community Support Moderator
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 4
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now