• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 490
  • Last Modified:

Exchange public calender help

Hi,

A few users have been trying to access a shared calender with no success.  When they try to access the calender they get an error that says "Unable to display the folder.  The server mailbox cannot be opened because this address book is not a mail user."  I have verified that the public folder exists in "public folders" within exchange system mananger 2003 and everyone has access rights to it.

Anyone have any ideas here?

Another note, I can actually view the calender from within exchange system manager.
0
AzagThothe
Asked:
AzagThothe
1 Solution
 
JexPamCommented:
Is there a "HomePage" file specified in the Calendars properties? If so can all users access the path to file identified.

Are all the accounts in the same Microsoft Exchange Server organization? If not this is the root issue and there is no work around without some account moves.

Also Public Folders do not have a permissions inheritance. You will need to specify the access rights directly on the Calendar.  
0
 
northcideCommented:
You CAN recursively set permissions on pub folders.  right click on the pub folder, all tasks, manage settings.  run through the wizard and as a test add one of those users as a full owner of the folder tree.  See if that user can access the calendar.
0
 
AzagThotheAuthor Commented:
I dont know if I'm looking in the wrong place.  But I am accessing the public folders through Exchange System Manager.

Admin Group > Servers > SERVER > First Storage Group > Public Folder Store > Public Folders

When I right click properties on the folder in question, The only tabs I see are:

General, Replication, Limits, Exchange General, Email Addresses, Exchange Advanced, Details, Permissions, Member Of.

All the accounts appear to be within the same MS Exchange Server Organization.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
northcideCommented:
nope -

Admin group > Folders > Public Folders
0
 
AzagThotheAuthor Commented:
Ok when I go there, right click > all tasks.  Manage settings is greyed out =(
0
 
northcideCommented:
your logged on as a full domain admin?
0
 
AzagThotheAuthor Commented:
Manage Settings is greyed out, but if I click on the content tab in the right pane I can actually view the calender.  I just need to be able to view it through outlook 03
0
 
AzagThotheAuthor Commented:
Yes, I'm logged in as the domain Administrator account.
0
 
northcideCommented:
Try creating a new top level folder.  give your domain admin account owner client permissions on that folder, then move one of the other top level problem folders into the new folder.  test to see if client permissions are still broken.  if they are, then try Manage Settings option on the new top level folder you've create.

Also, here is a link to an EXTREMELY powerful utility from microsoft.  Take great care in using it.  It has propogation options and many things that can fix or easily break everything.

http://www.microsoft.com/downloads/details.aspx?FamilyID=635BE792-D8AD-49E3-ADA4-E2422C0AB424&displaylang=en

0
 
Leon FesterCommented:
You should look for another account. If installed as per microsoft then your domain admin account will NOT have admin access to the Exchange Server. Check the Exchange Services in Control Panel and see what account is listed for starting the service.

Find or create an account that exists in the Exchange Services group. Once you've got access to the Exchange System, you should be able to manage your permissions from there.

Also, Read up on the isinteg.exe utility. You may have some corruption in your datastore
0
 
AzagThotheAuthor Commented:
The domain admin account is a member of the following exchange groups:

Exchange Admins
Exchange Domain Servers
Exchange Services

0
 
AzagThotheAuthor Commented:
When I view Advanced Security for Public Folders there are 2 entries of exchange admin, domain admin, enterprise admin, and admin that are being denied "special permissions".  It says being inherited from parent object and is being applied to this object and subcontainers.  It will not let me remove these deny permissions and when I edit them and grant full control it does not set when I click ok.  I don't know what parent object public folders is inheriting permissions from.  I can uncheck "allow inheritable permissions" to remove the deny permissions but this does not achieve the effect of opening up "manage settings on my public folders.

I'm getting frustrated with this =(
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now