ActiveSync cant sync with exchange

Just got this treo700w with windows moible 5 on it and when I go to sync with exchange I get this error:

Synchronization could not be completed. Try again later.
Support code: 80072f17

I have Sync With SSL checked, and on my IIS-Exchange folder use SSL is checked. I have a certificate but it is not signed, so I turned off SSL on exchange folder, turned off use SSL on activesync, and uninstalled the server certificate and still got error messages.

Please help thanks!
LVL 3
JasonWinnAsked:
Who is Participating?
 
SembeeCommented:
You would have got a faster response in the Exchange Server TA, we deal with these issues all the time over there.

http://www.experts-exchange.com/Networking/Email_Groupware/Exchange_Server/

That error code is certificate related.
Ideally you should be using an SSL certificate, as that provides the most protection when sending across your credentials.
Either a purchased certificate that is supported by the device, or a home grown certificate or purchased certificate with the root certificate installed. (http://www.amset.info/pocketpc/certificates.asp)

If you have require SSL enabled on the /exchange , /Microsoft-Server-ActiveSync or /oma virtual directory, then Exchange Active Sync will fail. You need to disable those options.
If you have Forms Based Authentication enabled, then that can cause some problems. I have a work around documented on my web site: http://www.amset.info/exchange/mobile-omafba.asp

Simon.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.