Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

are static routes necessary with eigrp? 500 points

Posted on 2006-05-11
7
Medium Priority
?
584 Views
Last Modified: 2012-05-05
I have just setup a leased line where previous to the leased line  being built one of the routers had a default route to an adsl router. Now that the leased line is up I want to point the default route away from the adsl line and send it up the leased line through the serial interface. I am running eigrp on the network is it still necessary to add a static route?
Here is my current config!

interface FastEthernet0/0
 ip address 10.4.254.254 255.255.0.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip inspect basicfw in
 ip nat inside
 ip virtual-reassembly
 ip route-cache flow
 ip tcp adjust-mss 1460
 duplex auto
 speed auto
 no mop enabled
!
interface FastEthernet0/1
 ip address 192.168.1.2 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat outside
 ip virtual-reassembly
 ip route-cache flow
 duplex auto
 speed auto
 no cdp enable
 no mop enabled
!
interface Serial0/0/0:0
 ip address 192.168.4.2 255.255.255.252
!
router eigrp 10
 network 10.4.0.0 0.0.255.255
 network 192.168.4.0 0.0.0.3
 network 192.168.4.0
 no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.1
0
Comment
Question by:lowfell
  • 2
  • 2
  • 2
  • +1
7 Comments
 
LVL 28

Expert Comment

by:mikebernhardt
ID: 16661771
If 192.168.1.1 is sending you a default route, then you don't need the static route. If it isn't then you should ideally set it up a default route on the remote router and redistribute it into eigrp.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 16662360
>I am running eigrp on the network is it still necessary to add a static route?
The whole idea of running any dynamic routing protocol is to do away with statics, except in your case the one default route. If you advertise this default route through eigrp to all the other routers, they will not need any statics at all.

However, I don't see where you are advertising your local 192.168.1.x subnet to the rest of the network.

To redistribute your local lan and a default :
Given:
ip route 0.0.0.0 0.0.0.0 192.168.1.1
  router eigrp 10
    redistribute static  <== send default
    redistribute connected   <== advertise local 192.168.1.0 subnet

0
 

Author Comment

by:lowfell
ID: 16665394
Sorry, although ip route 0.0.0.0 0.0.0.0 192.168.1.1 is the current default, I want to drop this route because it points to the adsl line. I now want all traffic to  go down the leased line where the other side is 192.168.4.1. I still want to use the original default route as a backup. I suppose ican do this by adding a wait to it?
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
LVL 79

Expert Comment

by:lrmoore
ID: 16666761
OK, the router that is a .4.1 will have a default and redistribute it.
Your end can add a higher admin cost the current default.
I think you meant "weight" where you said "wait" ?

no ip route 0.0.0.0 0.0.0.0 192.168.1.1
ip route 0.0.0.0 0.0.0.0 192.168.1.1 120  <== 120 is higher cost than EIGRP's 90
                                                                   so it will only use this route if the other one goes away

0
 

Author Comment

by:lowfell
ID: 16669668
The default route that points to  
0.0.0.0 0.0.0.0 192.168.1.1

This points to an adsl line that I no longer wish to use!
I am no longer bothered about the the 192.168.1 network, as the adsl was only in place until we got the leased line working!

I now want ALL my traffic to go via the SERIAL 0/0/0:0
and only want to include the lan network
10.4.0.0 255.255.0.0      and the serial interface
192.168.40  0.0.0.3
The eigrp is set as
router eigrp 10
 network 10.4.0.0 0.0.255.255
 network 192.168.4.0 0.0.0.3
 network 192.168.4.0
 no auto-summary

If I "NO" the current default route, will my eigrp settings do the rest, or is a new default route still needed?

Also if i still wanted to use the adsl as a backup could I as you said put the old default route back on but change the admin distance to 120.

Does the fact that a default route has been added make the eigrp useless, as this default route will always be preferred over the eigrp?

Also for future reference. Does using default routes make eigrp invalid and
vice versa?
Isn't it right to say that by using eigrp it is not necessary to use default and static routes?

Thanks chaps I really appreciate the help

0
 
LVL 28

Accepted Solution

by:
mikebernhardt earned 1500 total points
ID: 16669973
As I said, you need to make sure that the router at 192.168.4.1 is sending you a default route. So on that router,

ip route 0.0.0.0 0.0.0.0 [the next hop address for default]

router eigrp 10
redistribute static
network blah.blah.etc.

Now that router will send you a default route and your router will forward all traffic to 192.168.4.1.

Now, in your current configuration
router eigrp 10
 network 10.4.0.0 0.0.255.255
> network 192.168.4.0 0.0.0.3
> network 192.168.4.0

There's no point having both of those. As the 2nd one covers the address space of the first one.
0
 
LVL 11

Expert Comment

by:PennGwyn
ID: 16686998
I like the idea of having a static default route, with a weight greater than any learned route.

You could have the ADSL also, with an even greater weight, as a backup.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this tutorial I will show you with short command examples how to obtain a packet footprint of all traffic flowing thru your Juniper device running ScreenOS. I do not know the exact firmware requirement, but I think the fprofile command is availab…
Quality of Service (QoS) options are nearly endless when it comes to networks today. This article is merely one example of how it can be handled in a hub-n-spoke design using a 3-tier configuration.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

577 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question