Netware 5.1 program access problem

Posted on 2006-05-11
Last Modified: 2012-08-14
Hi I would like to thank you for taking the time to look at this.

I have a mixture of 98 and XP workstations, they all use the same program to copy files back and forth. No problems, the program complains when the server is not there and tells them to log on so they will not lose the work.
Now on one machine I get runtime error 52. in the program the directory is being accessed as such "\\ServerName\VolumeName\Directory\Directory\" windows explorer throws a wooly bugger fit about not being able to access the directory. But it can access the directory all day long if it goes to "F:\Directory\" and of course the new machine is XP. All permissions are the same. Client is 4.09.

What is going on? and in conclusion what am I missing?

Frustrated, clueless, but I got a hammer!
Question by:Tommy Kinard
    LVL 35

    Accepted Solution

    4.09?  Do you mean 4.90?  Do you have the latest SP and patches applied?  Was it installed "custom" or "typical?"  Are they XP Home or Pro?  SP1a or SP2?  Firewall or not?  Is the client installed to use IP or IPX? (hopefully not both)  Is IP or IPX installed on the server?  Or both?

    When you say "the program complains when the server is not there and tells them to log on so they will not lose the work" what does that mean as far as logging on?  Do they not log in to NetWare when they first boot up, using NWGINA?

    The UNC path thing is a clue.  If the Novell client isn't the primary network redirector and you don't have the "UNC path filter" setting in the client32 properties, advanced settings tab, then Windows Exploder and the native Windoze redirector will search any UNC path for stupid things like NTFS DFS links and NTFS shares and check the server for printer shares and shared scheduled events and other BS like that, and since NetWare (5.1 and before, especially, since 6.0 and 6.5 have features like NFAP/CIFS and NSS DFS) don't have all the stuff Explorer is hunting for, it keeps asking until it times out.  The UNC path filter only works if the Novell client redirector is first-in-line - it intercepts all UNC path calls, and only allows the Windows BS to happen if it's a Windows share and not a NetWare volume; otherwise it takes over and forces use of the Novell redirector.

    Hammer is good, aim it at Redmond... ;)

    Also, in WinXP, go into Windoze Explorer, Tools, Folder Options, View, and make sure "automatically search for network folders and printers" is UN checked, and same with Stupid file sharing (only an idiot would recommend it) - I mean "Simple file sharing (recommended) of course ;) but it really is a bad bad stupid thing that should only have been automatic in XP Home.
    LVL 14

    Author Comment

    by:Tommy Kinard
    Yes 4.9 Sorry, ..   On workstation Yes on server no I found sp8 yesterday, ..  Custom (I didn't do it),  ..   Pro SP2 , ...  Yes I'll fix that, ....     ipx/spx/tcp/ip I uninstalled the ipx and will be installing using custom/ip only later,  ..   both on server because of some intel print servers.

    They are supposed to but sometimes forget (I don't understand that either) so the program copies the files to the server and copies some files from the server to the local hard drive. These file are used by DOS programs so I can't access them on the server. The message box that pops up complains if the volumes are not found. This is to tell them to log on or they may lose their work.

    I will check the client for the UNC that is where I was looking but I didn't know about that -"UNC path filter" setting in the client32 properties- Thanks.

    Another note is when selecting a volume in explorer I get an error "The filename, directory name, or volume label is incorrect."

    Redmond sent some help files for the hammer, said I didn't know how to use it. RTFM was on the front what ever that means.

    I'll be back soon with the results and/or more information.

    Thank you for your time and patience in this matter.

    LVL 14

    Author Comment

    by:Tommy Kinard
    An update: the UNC path filter is on, ...  on the Windoze the same switches that were recommended have been set the client is in the process of being installed custom/ip only. But as yet (client not reinstalled) it just takes longer to say filename, directory name, or volume label syntax is incorrect.

    If it is any help it doesn't matter who is logged on the computer. Even if it is Admin you can still only access the mapped drives. Looks like you are allowed to see the volumes but you can't touch.


    LVL 14

    Author Comment

    by:Tommy Kinard
    Installing the Netware client 32 with ip only has resolved this issue.

    Thank you very much for your advice and time



    Featured Post

    Highfive Gives IT Their Time Back

    Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

    Join & Write a Comment

    As with any other System Center product, the installation for the Authoring Tool can be quite a pain sometimes. This article serves to help you avoid making these mistakes and hopefully save you a ton of time on troubleshooting :)  Step 1: Make sur…
    Nothing in an HTTP request can be trusted, including HTTP headers and form data.  A form token is a tool that can be used to guard against request forgeries (CSRF).  This article shows an improved approach to form tokens, making it more difficult to…
    This video is in connection to the article "The case of a missing mobile phone (". It will help one to understand clearly the steps to track a lost android phone.
    Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…

    745 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    16 Experts available now in Live!

    Get 1:1 Help Now