[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1591
  • Last Modified:

My Documents, Offline files and Folder Redirection

Hello Experts,

I have done a search on EE, but haven't found the answer yet - so I thought I'd post - risking the chance of a repeat question.

I have an end user running XP Pro on a laptop. The "My Documents" folder has been redirected to the server. When she disconnects from the network, she receives an error about the folder not being found - as it should be. When I tried to enable offline files on her laptop, I noticed that the options for the settings have been "greyed" out, so that I cannot enable this.

The objective is to keep her "Documents" folder redirected (to assure a good backup) but set it up so that she can access her documents when offline and synch them when she gets back to her office.  

This sounds like a GPO issue, but I am not sure.

Any direction is appreciated.

Shawna
0
slangdell
Asked:
slangdell
  • 3
  • 3
1 Solution
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
When you run the Configure My Documents Folder redirection wizard (in the Server Management Console under Users, Backup or Shares) it creates a GPO to handle the redirection and configuration of Offline file caching.

You should first check to make sure that the GPO is actuall propagating to the laptop correctly... by running a gpresult at the command line on the laptop.  If its configured correctly you will see this in the COMPUTER section of the output:


  The following GPOs were not applied because they were filtered out
  -------------------------------------------------------------------
      Small Business Server Folder Redirection
          Filtering:  Not Applied (Empty)

Then in the USER seciton of the output you should see this:  


  Applied Group Policy Objects
  -----------------------------
      Small Business Server Folder Redirection

This would indicate that it is configured correctly and then I would suspect that the problem would be caused by one of two things.  Either the offline file folder is corrupt or the Laptop was never added to the domain correctly using the connectcomputer wizard.

If the offline files are corrupt you can just delete them entirely with a rather non-documented but very important to follow method.

Open My Computer > Tools > Folder Options > Offline Files TAB.  

Hold down Ctrl + Shift and then click on the Delete Files... button.  A warning box will pop-up asking you to confirm the deletiion and reinitialization of the offline file store and after clicking YES, you should log off and back on to recreate the offline files.  If there are a lot of files it will take quite awhile for the logon process to complete (5+ minutes is a possibility).

If the reason that it's not working is because you didn't attach the computer to the domain correctily then please take these steps to correct the problem:  

The following needs to be done with the client machine:
1.  Log in with THAT machine's LOCAL administrator account.
2.  Unjoin the domain into a WORKGROUP
3.  Change the name of the computer
4.  Delete or rename the following directory C:\Program Files\Microsoft Windows Small Business Server\Clients (if it exists)
5.  Ensure that DHCP is enabled and there are  no manually configured network settings
6.  Reboot

Then on the server, from the Server Management Console:
1.  Remove the client computers if it still shows in the Client Computer screen on the Server Management Console
2.  Add the client with it's NEW name using the Add Computer wizard

Then, go back to the client machine and join the domain by opening Internet Explorer and navigating to http://servername/connectcomputer

Jeff
TechSoEasy
0
 
slangdellAuthor Commented:
Thanks, Jeff.

It seems that the the laptop was joined to the domain correctly and the policies were applied properly. However, there was an issue with the policy that had been applied. I ended up creating a new OU, creating a policy to enable offline files, then added the appropriate computer object to that OU.

Now, regarding points - the above didn't "fix" the problem, however, it gave me a good place to start and to troubleshoot. Can I award some points for this question?

Thanks,

Shawna
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Well... let me first ask you if when you created a new OU, did you create it under the MyBusiness OU?

Jeff
TechSoEasy
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
slangdellAuthor Commented:
Yes, I did create it under the MyBusiness OU.

Shawna
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Sorry, I should have been a bit more precise... because generally you don't want to creat new OU's for Users or Computers on an SBS unless they are contained within the original.

So for a user, it should be in MyBusiness\Users\SBSUsers  or for a computer it should be in MyBusiness\Computers\SBSComputers

Jeff
TechSoEasy
0
 
slangdellAuthor Commented:
I am going to award the points since it led me to the final resolution to the problem.

Thanks, Jeff.

Shawna
0

Featured Post

Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now